summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-04-12 21:52:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-04-12 21:52:39 +0000
commit39d96b28e1787ca96834eac809d832152ceed206 (patch)
treede07f0e0b274a3e014f6053e1ad75a7e15d26b3e /games-board/cgoban2/cgoban2-2.6.12.ebuild
parentManual Manifest commit. (diff)
downloadgentoo-2-39d96b28e1787ca96834eac809d832152ceed206.tar.gz
gentoo-2-39d96b28e1787ca96834eac809d832152ceed206.tar.bz2
gentoo-2-39d96b28e1787ca96834eac809d832152ceed206.zip
version bump; clean older version
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-board/cgoban2/cgoban2-2.6.12.ebuild')
-rw-r--r--games-board/cgoban2/cgoban2-2.6.12.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-board/cgoban2/cgoban2-2.6.12.ebuild b/games-board/cgoban2/cgoban2-2.6.12.ebuild
new file mode 100644
index 000000000000..33e45c9d5ccc
--- /dev/null
+++ b/games-board/cgoban2/cgoban2-2.6.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/cgoban2/cgoban2-2.6.12.ebuild,v 1.1 2005/04/12 21:52:39 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A Java client for the Kiseido Go Server, and a SGF editor"
+HOMEPAGE="http://kgs.kiseido.com/"
+SRC_URI="http://kgs.kiseido.com/cgoban-unix-${PV}.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~amd64"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.3
+ virtual/x11"
+
+S="${WORKDIR}/cgoban"
+
+src_install() {
+ dodir "${GAMES_BINDIR}"
+ sed -e "s:INSTALL_DIR:${GAMES_DATADIR}/${PN}:" \
+ "${FILESDIR}/${PN}" > "${D}${GAMES_BINDIR}/${PN}" \
+ || die "sed failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins cgoban.jar || die "doins failed"
+ prepgamesdirs
+}