summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-04-11 15:41:11 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-04-11 15:41:11 +0000
commit34c0f356665205815cc96d5a027b4b72ea288c5b (patch)
tree035d8c0f538c5d7ff7682cb21050f70b2db39db1 /games-board/crafty/crafty-22.0.ebuild
parentSync no-multilib/package.mask from default-linux. (diff)
downloadgentoo-2-34c0f356665205815cc96d5a027b4b72ea288c5b.tar.gz
gentoo-2-34c0f356665205815cc96d5a027b4b72ea288c5b.tar.bz2
gentoo-2-34c0f356665205815cc96d5a027b4b72ea288c5b.zip
Removed icc USE flag use for bug #216511.
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-board/crafty/crafty-22.0.ebuild')
-rw-r--r--games-board/crafty/crafty-22.0.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/games-board/crafty/crafty-22.0.ebuild b/games-board/crafty/crafty-22.0.ebuild
index f76d3ba5dd8c..14eaef03be02 100644
--- a/games-board/crafty/crafty-22.0.ebuild
+++ b/games-board/crafty/crafty-22.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-22.0.ebuild,v 1.1 2008/02/29 23:41:34 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-22.0.ebuild,v 1.2 2008/04/11 15:41:11 wolf31o2 Exp $
inherit flag-o-matic games
@@ -12,13 +12,12 @@ SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.zip
LICENSE="crafty"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="icc no-opts"
+IUSE="no-opts"
RESTRICT="test"
RDEPEND=""
DEPEND="${RDEPEND}
- app-arch/unzip
- icc? ( >=dev-lang/icc-5.0 )"
+ app-arch/unzip"
src_unpack() {
unpack ${A}
@@ -37,7 +36,7 @@ src_compile() {
local makeopts="target=LINUX"
if ! use no-opts ; then
- if use icc ; then
+ if [[ $(tc-getCC) = icc ]] ; then
makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
append-flags -D_REENTRANT -tpp6 \
-DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \