summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-01-19 08:43:27 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-01-19 08:43:27 +0000
commit8e8270a4bd186b889bbcd7aa22ba6445f223d562 (patch)
tree06b95ea592e9cb83ac900939475bd969535da956 /games-board/fruit
parentMoved IUSE to JAVA_PKG_IUSE to allow building with JAVA_PKG_STRICT. was miss... (diff)
downloadgentoo-2-8e8270a4bd186b889bbcd7aa22ba6445f223d562.tar.gz
gentoo-2-8e8270a4bd186b889bbcd7aa22ba6445f223d562.tar.bz2
gentoo-2-8e8270a4bd186b889bbcd7aa22ba6445f223d562.zip
Remove strip from makefile
(Portage version: 2.1.4)
Diffstat (limited to 'games-board/fruit')
-rw-r--r--games-board/fruit/ChangeLog7
-rw-r--r--games-board/fruit/fruit-2.1.ebuild33
2 files changed, 23 insertions, 17 deletions
diff --git a/games-board/fruit/ChangeLog b/games-board/fruit/ChangeLog
index e15755478d82..3d5d93760c47 100644
--- a/games-board/fruit/ChangeLog
+++ b/games-board/fruit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-board/fruit
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/fruit/ChangeLog,v 1.3 2007/03/12 13:48:12 genone Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/fruit/ChangeLog,v 1.4 2008/01/19 08:43:27 nyhm Exp $
+
+ 19 Jan 2008; Tristan Heaven <nyhm@gentoo.org> fruit-2.1.ebuild:
+ Remove strip from makefile
12 Mar 2007; Marius Mauch <genone@gentoo.org> fruit-2.1.ebuild:
Replacing einfo with elog
diff --git a/games-board/fruit/fruit-2.1.ebuild b/games-board/fruit/fruit-2.1.ebuild
index fb8609e7c3ae..2478d73daf24 100644
--- a/games-board/fruit/fruit-2.1.ebuild
+++ b/games-board/fruit/fruit-2.1.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/fruit/fruit-2.1.ebuild,v 1.3 2007/03/12 13:48:12 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/fruit/fruit-2.1.ebuild,v 1.4 2008/01/19 08:43:27 nyhm Exp $
inherit eutils versionator games
MY_PV=$(replace_all_version_separators '')
MY_P=${PN}_${MY_PV}_linux
-
-DESCRIPTION="UCI-only chess engine."
+DESCRIPTION="UCI-only chess engine"
HOMEPAGE="http://arctrix.com/nas/fruit/"
SRC_URI="http://arctrix.com/nas/${PN}/${MY_P}.zip"
@@ -16,6 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+RDEPEND=""
DEPEND="app-arch/unzip"
S=${WORKDIR}/${MY_P}/src
@@ -24,24 +24,27 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}"-gentoo.patch
- sed -i -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
- option.cpp
- sed -i -e "/^CXXFLAGS/d" Makefile
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ option.cpp \
+ || die "sed option.cpp failed"
+ sed -i \
+ -e '/^CXXFLAGS/d' \
+ -e '/^LDFLAGS/d' \
+ Makefile \
+ || die "sed Makefile failed"
}
src_install() {
- dogamesbin ${PN} || die "Cannot install ${PN}"
-
+ dogamesbin ${PN} || die "dogamesbin failed"
insinto "${GAMES_DATADIR}/${PN}"
- doins ../book_small.bin || die "Cannot install book"
- dodoc ../readme.txt ../technical_10.txt || die "Cannot install doc"
-
+ doins ../book_small.bin || die "doins failed"
+ dodoc ../readme.txt ../technical_10.txt
prepgamesdirs
}
pkg_postinst() {
games_pkg_postinst
-
- elog "To use this engine you need to install a chess GUI that talk UCI"
- elog "emerge games-board/glchess to have one"
+ elog "To use this engine you need to install a UCI chess GUI"
+ elog "e.g. games-board/glchess"
}