summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-05-21 16:30:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-05-21 16:30:44 +0000
commitf135196fd0153d5cee77427952e0c86eadd7a26d (patch)
treeee8ff9602ad050f886f627fcb8bb011a1be221d0 /games-board/gtkboard
parentOld. (diff)
downloadgentoo-2-f135196fd0153d5cee77427952e0c86eadd7a26d.tar.gz
gentoo-2-f135196fd0153d5cee77427952e0c86eadd7a26d.tar.bz2
gentoo-2-f135196fd0153d5cee77427952e0c86eadd7a26d.zip
EAPI=2; add use deps for SDL libs
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-board/gtkboard')
-rw-r--r--games-board/gtkboard/ChangeLog8
-rw-r--r--games-board/gtkboard/gtkboard-0.11_pre0.ebuild19
2 files changed, 14 insertions, 13 deletions
diff --git a/games-board/gtkboard/ChangeLog b/games-board/gtkboard/ChangeLog
index 5ae23aeb82cc..1d0f0c6c5006 100644
--- a/games-board/gtkboard/ChangeLog
+++ b/games-board/gtkboard/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/gtkboard
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gtkboard/ChangeLog,v 1.10 2008/10/07 02:40:32 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gtkboard/ChangeLog,v 1.11 2010/05/21 16:30:44 mr_bones_ Exp $
+
+ 21 May 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ gtkboard-0.11_pre0.ebuild:
+ EAPI=2; add use deps for SDL libs
07 Oct 2008; Michael Sterrett <mr_bones_@gentoo.org>
gtkboard-0.11_pre0.ebuild:
diff --git a/games-board/gtkboard/gtkboard-0.11_pre0.ebuild b/games-board/gtkboard/gtkboard-0.11_pre0.ebuild
index 14759ac4f73a..f2d565e9a38b 100644
--- a/games-board/gtkboard/gtkboard-0.11_pre0.ebuild
+++ b/games-board/gtkboard/gtkboard-0.11_pre0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gtkboard/gtkboard-0.11_pre0.ebuild,v 1.13 2008/10/07 02:40:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gtkboard/gtkboard-0.11_pre0.ebuild,v 1.14 2010/05/21 16:30:44 mr_bones_ Exp $
+EAPI=2
inherit eutils games
MY_P=${P/_}
@@ -15,29 +16,25 @@ KEYWORDS="amd64 ppc x86"
IUSE="gnome"
RDEPEND=">=x11-libs/gtk+-2
- media-libs/libsdl
- media-libs/sdl-mixer
+ media-libs/libsdl[audio]
+ media-libs/sdl-mixer[vorbis]
gnome? ( gnome-base/libgnomeui )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-gcc41.patch
}
-src_compile() {
+src_configure() {
egamesconf \
--disable-dependency-tracking \
--datadir="${GAMES_DATADIR}"/${PN} \
--enable-gtk2 \
--enable-sdl \
- $(use_enable gnome) \
- || die
- emake || die "emake failed"
+ $(use_enable gnome)
}
src_install() {