summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-06-09 21:23:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-06-09 21:23:10 +0000
commit6d274bad6b3f5c40c77d52141e37e15b99f12317 (patch)
tree15b8c97592a152a52e82029286525cc98ae53b6b /games-board/pokerth
parentInitial commit (diff)
downloadgentoo-2-6d274bad6b3f5c40c77d52141e37e15b99f12317.tar.gz
gentoo-2-6d274bad6b3f5c40c77d52141e37e15b99f12317.tar.bz2
gentoo-2-6d274bad6b3f5c40c77d52141e37e15b99f12317.zip
support later eselect-enabled versions of boost
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-board/pokerth')
-rw-r--r--games-board/pokerth/ChangeLog5
-rw-r--r--games-board/pokerth/pokerth-0.6.3.ebuild26
2 files changed, 27 insertions, 4 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index d4237162e5dd..51e590b7dcb2 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-board/pokerth
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.4 2009/03/25 12:23:07 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.5 2009/06/09 21:23:10 mr_bones_ Exp $
+
+ 09 Jun 2009; Michael Sterrett <mr_bones_@gentoo.org> pokerth-0.6.3.ebuild:
+ support later eselect-enabled versions of boost
25 Mar 2009; Joseph Jezak <josejx@gentoo.org> pokerth-0.6.3.ebuild:
Marked ~ppc for bug #263432.
diff --git a/games-board/pokerth/pokerth-0.6.3.ebuild b/games-board/pokerth/pokerth-0.6.3.ebuild
index 4080bc4f73fa..7cd0c2a3a36a 100644
--- a/games-board/pokerth/pokerth-0.6.3.ebuild
+++ b/games-board/pokerth/pokerth-0.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.6.3.ebuild,v 1.4 2009/03/25 12:23:07 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.6.3.ebuild,v 1.5 2009/06/09 21:23:10 mr_bones_ Exp $
EAPI=2
inherit eutils qt4 games
@@ -15,18 +15,34 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="dedicated"
-DEPEND=">=dev-libs/boost-1.34.1
+DEPEND="
+ || ( >=dev-libs/boost-1.35.0-r5:0
+ ~dev-libs/boost-1.34.1
+ ~dev-libs/boost-1.33.1 )
>=net-libs/gnutls-2.2.2
>=net-misc/curl-7.16
!dedicated? (
media-libs/libsdl
media-libs/sdl-mixer[mikmod,vorbis]
>=sys-libs/zlib-1.2.3
- || ( x11-libs/qt-gui:4 x11-libs/qt:4 )
+ x11-libs/qt-gui:4
)"
S=${WORKDIR}/${MY_P}
+pkg_setup() {
+ games_pkg_setup
+ if has_version '>=dev-libs/boost-1.35.0-r5:0' ; then
+ local boost_ver=$(f=$(eselect boost show | tail -n1); echo $f)
+
+ if [[ "$boost_ver" != "boost-1_35" ]] ; then
+ ewarn "${P} requires boost to be set to version 1_35"
+ ewarn "use eselect to set boost to the required version"
+ die "Incorrect boost version currently selected (currently $boost_ver)"
+ fi
+ fi
+}
+
src_prepare() {
if use dedicated ; then
sed -i \
@@ -34,6 +50,10 @@ src_prepare() {
pokerth.pro \
|| die "sed failed"
fi
+ sed -i \
+ -e '/no_dead_strip_inits_and_terms/d' \
+ *pro \
+ || die 'sed failed'
}
src_configure() {