summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-30 06:22:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-30 06:22:28 +0000
commit3576cb38303f8e6a951ad8a92b457b3a5f000308 (patch)
tree6f7843e49968d8e90d2ef3b9d4a288fe8490ed03 /games-board/six
parentversion bump (diff)
downloadgentoo-2-3576cb38303f8e6a951ad8a92b457b3a5f000308.tar.gz
gentoo-2-3576cb38303f8e6a951ad8a92b457b3a5f000308.tar.bz2
gentoo-2-3576cb38303f8e6a951ad8a92b457b3a5f000308.zip
add patch for building with gcc-4.3; submitting by Dieter Ries via bug #227151
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-board/six')
-rw-r--r--games-board/six/ChangeLog8
-rw-r--r--games-board/six/files/six-0.5.3-gcc43.patch34
-rw-r--r--games-board/six/six-0.5.3.ebuild6
3 files changed, 44 insertions, 4 deletions
diff --git a/games-board/six/ChangeLog b/games-board/six/ChangeLog
index 2160238f04b6..4f58389b7c3d 100644
--- a/games-board/six/ChangeLog
+++ b/games-board/six/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/six
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/six/ChangeLog,v 1.12 2006/06/21 00:24:40 mr_bones_ Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/six/ChangeLog,v 1.13 2008/06/30 06:22:27 mr_bones_ Exp $
+
+ 30 Jun 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/six-0.5.3-gcc43.patch, six-0.5.3.ebuild:
+ add patch for building with gcc-4.3; submitting by Dieter Ries via bug #227151
*six-0.5.3 (19 Jun 2006)
diff --git a/games-board/six/files/six-0.5.3-gcc43.patch b/games-board/six/files/six-0.5.3-gcc43.patch
new file mode 100644
index 000000000000..d3e066686125
--- /dev/null
+++ b/games-board/six/files/six-0.5.3-gcc43.patch
@@ -0,0 +1,34 @@
+diff -u -ur a/six/carrier.h b/six/carrier.h
+--- a/six/carrier.h 2004-07-19 10:30:51.000000000 +0200
++++ b/six/carrier.h 2008-06-15 13:09:35.000000000 +0200
+@@ -4,6 +4,7 @@
+
+ #include <iostream>
+ #include <vector>
++#include <cstring>
+
+ using std::vector;
+ using std::istream;
+diff -u -ur a/six/hexgame.cpp b/six/hexgame.cpp
+--- a/six/hexgame.cpp 2004-07-19 10:30:51.000000000 +0200
++++ b/six/hexgame.cpp 2008-06-15 13:10:26.000000000 +0200
+@@ -3,7 +3,7 @@
+ #include <cassert>
+ #include <cctype>
+ #include <cstdio>
+-
++#include <cstdlib>
+ #include <string>
+
+ using std::endl;
+diff -u -ur a/six/main.cpp b/six/main.cpp
+--- a/six/main.cpp 2004-07-19 10:30:51.000000000 +0200
++++ b/six/main.cpp 2008-06-15 13:08:59.000000000 +0200
+@@ -11,6 +11,7 @@
+ #include <klocale.h>
+ #include <kmessagebox.h>
+ #include <qfile.h>
++#include <cstdlib>
+
+ using std::cin;
+
diff --git a/games-board/six/six-0.5.3.ebuild b/games-board/six/six-0.5.3.ebuild
index 1dd5c29a460a..48d15734e36e 100644
--- a/games-board/six/six-0.5.3.ebuild
+++ b/games-board/six/six-0.5.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/six/six-0.5.3.ebuild,v 1.1 2006/06/21 00:24:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/six/six-0.5.3.ebuild,v 1.2 2008/06/30 06:22:27 mr_bones_ Exp $
ARTS_REQUIRED="yes"
inherit kde
@@ -14,4 +14,6 @@ SLOT="0"
KEYWORDS="ppc ~sparc x86"
IUSE=""
+PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+
need-kde 3