summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-27 04:32:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-27 04:32:17 +0000
commit822927a125ab7a4afeeefeb56e64e48de71bb990 (patch)
treeb386538c8738718960f40ca7f77fdb4d605b479b /games-emulation/gtuxnes/gtuxnes-0.75.ebuild
parentAdded ~sparc keyword wrt bug #82670. (diff)
downloadgentoo-2-822927a125ab7a4afeeefeb56e64e48de71bb990.tar.gz
gentoo-2-822927a125ab7a4afeeefeb56e64e48de71bb990.tar.bz2
gentoo-2-822927a125ab7a4afeeefeb56e64e48de71bb990.zip
use games eclass; add patch from Myk Taylor (bug #82768) to support spaces in the rc file; tidy
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-emulation/gtuxnes/gtuxnes-0.75.ebuild')
-rw-r--r--games-emulation/gtuxnes/gtuxnes-0.75.ebuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/games-emulation/gtuxnes/gtuxnes-0.75.ebuild b/games-emulation/gtuxnes/gtuxnes-0.75.ebuild
index c5aa2a6d9688..ddb8f16dabc3 100644
--- a/games-emulation/gtuxnes/gtuxnes-0.75.ebuild
+++ b/games-emulation/gtuxnes/gtuxnes-0.75.ebuild
@@ -1,36 +1,34 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gtuxnes/gtuxnes-0.75.ebuild,v 1.5 2004/06/24 22:29:03 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gtuxnes/gtuxnes-0.75.ebuild,v 1.6 2005/02/27 04:32:17 mr_bones_ Exp $
+
+inherit eutils games
DESCRIPTION="GTK frontend for tuxnes, the emulator for the 8-bit Nintendo Entertainment System"
HOMEPAGE="http://www.scottweber.com/projects/gtuxnes/"
SRC_URI="http://www.scottweber.com/projects/gtuxnes/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86"
SLOT="0"
+KEYWORDS="x86"
IUSE=""
-DEPEND="x11-libs/gtk+
- >=sys-apps/sed-4"
-RDEPEND=">=games-emulation/tuxnes-0.75"
+DEPEND="=x11-libs/gtk+-1.2*"
+RDEPEND="${DEPEND}
+ >=games-emulation/tuxnes-0.75"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
- -e 's/gcc/$(CC) $(CFLAGS)/' Makefile || \
- die 'sed Makefile failed'
-}
-
-src_compile() {
- emake || die 'emake failed'
+ -e 's/gcc/$(CC) $(CFLAGS)/' Makefile \
+ || die 'sed Makefile failed'
+ epatch "${FILESDIR}/${PV}-rc.patch"
}
src_install() {
- dobin gtuxnes
-
- # Install documentation
+ dogamesbin gtuxnes || die "dogamesbin failed"
dodoc AUTHORS CHANGES INSTALL README TODO
+ prepgamesdirs
}