summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-18 06:24:19 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-18 06:24:19 +0000
commitbe380471d2ba3fc98614b5caa40f86ef146a9996 (patch)
tree07b4d72775b727b940823b5b0c0371cca8234110 /games-emulation/neopocott
parentinitial ebuild #37963 (diff)
downloadgentoo-2-be380471d2ba3fc98614b5caa40f86ef146a9996.tar.gz
gentoo-2-be380471d2ba3fc98614b5caa40f86ef146a9996.tar.bz2
gentoo-2-be380471d2ba3fc98614b5caa40f86ef146a9996.zip
initial ebuild #38025
Diffstat (limited to 'games-emulation/neopocott')
-rw-r--r--games-emulation/neopocott/ChangeLog8
-rw-r--r--games-emulation/neopocott/files/digest-neopocott-0.38b1
-rw-r--r--games-emulation/neopocott/neopocott-0.38b.ebuild27
3 files changed, 36 insertions, 0 deletions
diff --git a/games-emulation/neopocott/ChangeLog b/games-emulation/neopocott/ChangeLog
new file mode 100644
index 000000000000..9f4c5907b699
--- /dev/null
+++ b/games-emulation/neopocott/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-emulation/neopocott
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/neopocott/ChangeLog,v 1.1 2004/01/18 06:24:19 vapier Exp $
+
+*neopocott-0.38b (18 Jan 2004)
+
+ 18 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Chris Aniszczyk <zx@mea-culpa.net> #38025.
diff --git a/games-emulation/neopocott/files/digest-neopocott-0.38b b/games-emulation/neopocott/files/digest-neopocott-0.38b
new file mode 100644
index 000000000000..cbeb84d99920
--- /dev/null
+++ b/games-emulation/neopocott/files/digest-neopocott-0.38b
@@ -0,0 +1 @@
+MD5 d30f08944f1ddad4cd926bb8fdcd96e0 NeoPocott-SDL-0.38bR2.1.i386.linux-glibc22.tar.bz2 58729
diff --git a/games-emulation/neopocott/neopocott-0.38b.ebuild b/games-emulation/neopocott/neopocott-0.38b.ebuild
new file mode 100644
index 000000000000..2d8c5e5446e8
--- /dev/null
+++ b/games-emulation/neopocott/neopocott-0.38b.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+inherit games
+
+MY_RLS="R2.1"
+DESCRIPTION="A NeoGeo Pocket emulator for Linux"
+HOMEPAGE="http://sdlemu.ngemu.com/neopocottsdl.php"
+SRC_URI="http://sdlemu.ngemu.com/releases/NeoPocott-SDL-${PV}${MY_RLS}.i386.linux-glibc22.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* x86"
+
+RDEPEND="media-libs/libsdl
+ sys-libs/zlib
+ virtual/glibc"
+
+S=${WORKDIR}
+
+src_install() {
+ exeinto /opt/bin
+ doexe neopocott || die "doexe failed"
+ dodoc doc/*
+ games_make_wrapper neopocott ./neopocott /opt/bin
+ prepgamesdirs
+}