summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-18 10:57:11 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-18 10:57:11 +0000
commit6328e1ebd9cb4ed3736583d8cf2889b9cffebd00 (patch)
tree411421699f352869b90bfb6f1232ff5ed4074ff1 /games-emulation/nestopia
parentVersion Bump, sci has taken over maintainership (diff)
downloadgentoo-2-6328e1ebd9cb4ed3736583d8cf2889b9cffebd00.tar.gz
gentoo-2-6328e1ebd9cb4ed3736583d8cf2889b9cffebd00.tar.bz2
gentoo-2-6328e1ebd9cb4ed3736583d8cf2889b9cffebd00.zip
Respect LDFLAGS. Bug #333659
(Portage version: 2.1.9.14/cvs/Linux i686)
Diffstat (limited to 'games-emulation/nestopia')
-rw-r--r--games-emulation/nestopia/ChangeLog6
-rw-r--r--games-emulation/nestopia/files/nestopia-1.40-makefile.patch4
-rw-r--r--games-emulation/nestopia/nestopia-1.40.ebuild5
3 files changed, 10 insertions, 5 deletions
diff --git a/games-emulation/nestopia/ChangeLog b/games-emulation/nestopia/ChangeLog
index efcfbab4b436..246b5c02aa3a 100644
--- a/games-emulation/nestopia/ChangeLog
+++ b/games-emulation/nestopia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/nestopia
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestopia/ChangeLog,v 1.4 2010/05/31 20:49:34 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestopia/ChangeLog,v 1.5 2010/10/18 10:57:11 tupone Exp $
+
+ 18 Oct 2010; Tupone Alfredo <tupone@gentoo.org>
+ files/nestopia-1.40-makefile.patch:
+ Respect LDFLAGS. Bug #333659 by flameeyes@gentoo.org
31 May 2010; Joseph Jezak <josejx@gentoo.org> nestopia-1.40.ebuild:
Marked ~ppc for bug #321497.
diff --git a/games-emulation/nestopia/files/nestopia-1.40-makefile.patch b/games-emulation/nestopia/files/nestopia-1.40-makefile.patch
index aba885d51e19..467e49445ec4 100644
--- a/games-emulation/nestopia/files/nestopia-1.40-makefile.patch
+++ b/games-emulation/nestopia/files/nestopia-1.40-makefile.patch
@@ -44,7 +44,7 @@
objs/%.o: source/%.cpp
@echo Compiling $<...
- @$(CC) $(CFLAGS) $(CPPFLAGS) $< -o $@
-+ @$(CC) $(CXXFLAGS) $< -o $@
++ $(CC) $(CXXFLAGS) $< -o $@
objs/%.o: source/%.o
@echo Compiling $<...
@@ -63,7 +63,7 @@
$(EXE): $(OBJS)
@echo Linking $@...
- @$(CPP) -g -o $(EXE) $^ $(LIBS)
-+ @$(CXX) -g -o $(EXE) $^ $(LIBS)
++ $(CXX) $(LDFLAGS) -g -o $(EXE) $^ $(LIBS)
clean:
-@rm -f $(OBJS) $(EXE) $(GENNSTCONTROLS)
diff --git a/games-emulation/nestopia/nestopia-1.40.ebuild b/games-emulation/nestopia/nestopia-1.40.ebuild
index cbe9367af396..33972e662b2e 100644
--- a/games-emulation/nestopia/nestopia-1.40.ebuild
+++ b/games-emulation/nestopia/nestopia-1.40.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestopia/nestopia-1.40.ebuild,v 1.4 2010/05/31 20:49:34 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestopia/nestopia-1.40.ebuild,v 1.5 2010/10/18 10:57:11 tupone Exp $
EAPI=2
inherit eutils games
@@ -17,12 +17,13 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
-DEPEND=">=x11-libs/gtk+-2.4:2
+RDEPEND=">=x11-libs/gtk+-2.4:2
media-libs/alsa-lib
>=media-libs/libsdl-1.2.12[audio,joystick,video]
sys-libs/zlib
virtual/opengl
virtual/glu"
+DEPEND="${RDEPEND}"
S=${WORKDIR}