summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-19 05:19:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-19 05:19:53 +0000
commitfbe087cd30bed97035c5ab260ba6f9da21c37cbc (patch)
tree51f1e86fb79ceb5a9627c895f14346278705915e /games-emulation/nestopia
parentold (diff)
downloadgentoo-2-fbe087cd30bed97035c5ab260ba6f9da21c37cbc.tar.gz
gentoo-2-fbe087cd30bed97035c5ab260ba6f9da21c37cbc.tar.bz2
gentoo-2-fbe087cd30bed97035c5ab260ba6f9da21c37cbc.zip
switch to nestopia UE (bug #531716)
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation/nestopia')
-rw-r--r--games-emulation/nestopia/ChangeLog8
-rw-r--r--games-emulation/nestopia/nestopia-1.46.2.ebuild76
2 files changed, 82 insertions, 2 deletions
diff --git a/games-emulation/nestopia/ChangeLog b/games-emulation/nestopia/ChangeLog
index d505042ca4a2..3227026e307a 100644
--- a/games-emulation/nestopia/ChangeLog
+++ b/games-emulation/nestopia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/nestopia
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestopia/ChangeLog,v 1.9 2015/01/17 16:39:55 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestopia/ChangeLog,v 1.10 2015/02/19 05:19:53 mr_bones_ Exp $
+
+*nestopia-1.46.2 (19 Feb 2015)
+
+ 19 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> +nestopia-1.46.2.ebuild:
+ switch to nestopia UE (bug #531716)
17 Jan 2015; Tupone Alfredo <tupone@gentoo.org> nestopia-1.40.ebuild:
EAPI 5
@@ -35,4 +40,3 @@
+files/nestopia, +metadata.xml:
Initial commit - files submitted by Michał Ziąbkowski and Jared via bug
#254479
-
diff --git a/games-emulation/nestopia/nestopia-1.46.2.ebuild b/games-emulation/nestopia/nestopia-1.46.2.ebuild
new file mode 100644
index 000000000000..e5e6570fc838
--- /dev/null
+++ b/games-emulation/nestopia/nestopia-1.46.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestopia/nestopia-1.46.2.ebuild,v 1.1 2015/02/19 05:19:53 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+MY_P=${P/ue/}
+DESCRIPTION="A portable Nintendo Entertainment System emulator written in C++"
+HOMEPAGE="http://0ldsk00l.ca/nestopia/"
+SRC_URI="mirror://sourceforge/nestopiaue/${PV%.*}/${MY_P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="x11-libs/gtk+:3
+ media-libs/libao
+ media-libs/libsdl2[sound,joystick,video]
+ sys-libs/zlib
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i \
+ -e '/^CC /d' \
+ -e '/^CXX /d' \
+ -e '/^LDFLAGS /d' \
+ -e '/^LIBS =/ s/=/+=/' \
+ -e '/^CFLAGS / s/=/+=/' \
+ -e "/^PREFIX / s:=.*:=${GAMES_PREFIX}:" \
+ -e "/^BINDIR / s:=.*:=${GAMES_BINDIR}:" \
+ -e "/^DATADIR / s:=.*:=${GAMES_DATADIR}/${PN}:" \
+ Makefile || die
+}
+
+src_install() {
+ local res
+
+ dogamesbin ${PN}
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r NstDatabase.xml source/unix/icons
+
+ domenu source/unix/icons/nestopia.desktop
+ for res in 32 48 64 128
+ do
+ newicon -s ${res} source/unix/icons/nestopia${res}.png nestopia.png
+ done
+ doicon -s scalable source/unix/icons/nestopia.svg
+
+ dodoc AUTHORS README.* changelog.txt
+ use doc && dohtml -r readme.html doc/*.html doc/details
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
+