summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
commitae044aeba549da343d278a26bb72bac844e5a5e4 (patch)
treeb16ea879113ef2bd09bb78bb00e8338b088d3afb /games-emulation/pcsx2
parentNew package - rename. (diff)
downloadgentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.gz
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.bz2
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.zip
welcome to games-emulation
Diffstat (limited to 'games-emulation/pcsx2')
-rw-r--r--games-emulation/pcsx2/ChangeLog8
-rw-r--r--games-emulation/pcsx2/Manifest5
-rw-r--r--games-emulation/pcsx2/files/0.41-time-renames.patch16
-rw-r--r--games-emulation/pcsx2/files/digest-pcsx2-0.411
-rw-r--r--games-emulation/pcsx2/files/pcsx250
-rw-r--r--games-emulation/pcsx2/pcsx2-0.41.ebuild46
6 files changed, 126 insertions, 0 deletions
diff --git a/games-emulation/pcsx2/ChangeLog b/games-emulation/pcsx2/ChangeLog
new file mode 100644
index 000000000000..442a933a0b91
--- /dev/null
+++ b/games-emulation/pcsx2/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-emulation/pcsx2
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/ChangeLog,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+*pcsx2-0.41 (14 Aug 2003)
+
+ 14 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me. Wish they werent such asses on efnet ;)
diff --git a/games-emulation/pcsx2/Manifest b/games-emulation/pcsx2/Manifest
new file mode 100644
index 000000000000..d480bf6f6c31
--- /dev/null
+++ b/games-emulation/pcsx2/Manifest
@@ -0,0 +1,5 @@
+MD5 ae83b13b8fd78cb3d081d50adb38c920 files/0.41-time-renames.patch 732
+MD5 5f167c3b3688c456e81d43bbdf4d41fa files/digest-pcsx2-0.41 62
+MD5 8ecb9d8f54b0527e788b7aa5ef5bc11b files/pcsx2 1280
+MD5 263fdae4b5400049ba732d4499d308fe ChangeLog 383
+MD5 d693b59d4fa1cc0985814341fa5d4843 pcsx2-0.41.ebuild 1043
diff --git a/games-emulation/pcsx2/files/0.41-time-renames.patch b/games-emulation/pcsx2/files/0.41-time-renames.patch
new file mode 100644
index 000000000000..96b924beffd7
--- /dev/null
+++ b/games-emulation/pcsx2/files/0.41-time-renames.patch
@@ -0,0 +1,16 @@
+--- Pcsx2Src/RPC/80000001fileio.h.orig 2003-08-14 11:39:42.319499152 -0400
++++ Pcsx2Src/RPC/80000001fileio.h 2003-08-14 11:40:09.145420992 -0400
+@@ -73,10 +73,10 @@
+ 4 Symbolic link */
+ unsigned int st_attr;// Flag compatible with memory card mode
+ unsigned int st_size;
+- unsigned char st_ctime[8];// Creation time
+- unsigned char st_atime[8];/* This field is updated at the same time as last access time
++ unsigned char sr_ctime[8];// Creation time
++ unsigned char sr_atime[8];/* This field is updated at the same time as last access time
+ and last update time. */
+- unsigned char st_mtime[8];/* Last update time
++ unsigned char sr_mtime[8];/* Last update time
+ byte0 Reserved
+ byte1 Seconds
+ byte2 Minutes
diff --git a/games-emulation/pcsx2/files/digest-pcsx2-0.41 b/games-emulation/pcsx2/files/digest-pcsx2-0.41
new file mode 100644
index 000000000000..f2a0408e7299
--- /dev/null
+++ b/games-emulation/pcsx2/files/digest-pcsx2-0.41
@@ -0,0 +1 @@
+MD5 1748f41ba1b0b61cbff5b6f61285cf0b Pcsx2Src-0.41.tgz 588804
diff --git a/games-emulation/pcsx2/files/pcsx2 b/games-emulation/pcsx2/files/pcsx2
new file mode 100644
index 000000000000..6a4776c3c882
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2
@@ -0,0 +1,50 @@
+#!/bin/bash
+
+source /sbin/functions.sh
+
+if [ ! -f ${HOME}/.pcsx2/Pcsx2.cfg ]; then
+ einfo You are running PCSX2 for the first time.
+ einfo Setting up your PCSX2 environment... Please wait...
+
+ mkdir -p ${HOME}/.pcsx2
+ cd ${HOME}/.pcsx2
+ mkdir Bios Docs Plugins host memcards snap
+
+ ln -s /usr/games/bin/pcsx2.bin pcsx2
+ ln -s /usr/games/lib/ps2emu/plugins/* Plugins/
+ ln -s /usr/games/lib/ps2emu/Langs Langs
+
+ cd Bios
+ if [ -f /usr/games/lib/ps2emu/bios/scph1001.bin ]; then
+ ln -s /usr/games/lib/ps2emu/bios/scph1001.bin .
+ biosname=scph1001.bin
+ else
+ biosname=HLE
+ fi
+ cd ..
+
+ cat >${HOME}/.pcsx2/Pcsx2.cfg <<EOF
+Bios = $biosname
+GS = $(basename $(ls Plugins/libGS* | cut -f1 -d\ ) )
+SPU2 = $(basename $(ls Plugins/libSPU2* | cut -f1 -d\ ) )
+CDVD = $(basename $(ls Plugins/libCDVD* | cut -f1 -d\ ) )
+PAD1 = $(basename $(ls Plugins/libPADxwin-* | cut -f1 -d\ ) )
+PAD2 = $(basename $(ls Plugins/libPADxwin-* | cut -f1 -d\ ) )
+Mcd1 = ${HOME}/.pcsx2/memcards/Mcd001.mcr
+Mcd2 = ${HOME}/.pcsx2/memcards/Mcd002.mcr
+PluginsDir = ${HOME}/.pcsx2/Plugins/
+BiosDir = ${HOME}/.pcsx2/Bios/
+Cpu = 0
+PsxOut = 0
+varLog = 0
+Lang = en
+EOF
+
+fi
+
+cd ${HOME}/.pcsx2/
+
+ln -s /usr/games/lib/ps2emu/cfg/* cfg/ &>/dev/null
+ln -s /usr/games/lib/ps2emu/plugins/* plugins/ &>/dev/null
+
+exec ./pcsx2 "$@"
diff --git a/games-emulation/pcsx2/pcsx2-0.41.ebuild b/games-emulation/pcsx2/pcsx2-0.41.ebuild
new file mode 100644
index 000000000000..d9193f716e3b
--- /dev/null
+++ b/games-emulation/pcsx2/pcsx2-0.41.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.41.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Playstation2 emulator"
+HOMEPAGE="http://www.pcsx2.net/"
+SRC_URI="http://www.pcsx2.net/download/0.4release/Pcsx2Src-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND="virtual/x11
+ =x11-libs/gtk+-1*
+ || (
+ app-emulation/ps2emu-cddvdlinuz
+ app-emulation/ps2emu-cdvdiso
+ )
+ app-emulation/ps2emu-gssoft
+ app-emulation/ps2emu-padxwin
+ app-emulation/ps2emu-spu2null"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+S=${WORKDIR}/Pcsx2Src
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-time-renames.patch
+}
+
+src_compile() {
+ cd Linux
+ emake OPTIMIZE="${CFLAGS}" || die
+}
+
+src_install() {
+ newgamesbin Linux/pcsx2 pcsx2.bin
+ dogamesbin ${FILESDIR}/pcsx2
+ dodir ${GAMES_LIBDIR}/ps2emu/Langs
+ cp -r Intl/Langs/* ${D}/${GAMES_LIBDIR}/ps2emu/Langs/
+ dodoc Docs/*.txt
+ prepgamesdirs
+}