summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
commitae044aeba549da343d278a26bb72bac844e5a5e4 (patch)
treeb16ea879113ef2bd09bb78bb00e8338b088d3afb /games-emulation/ps2emu-spu2null
parentNew package - rename. (diff)
downloadgentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.gz
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.bz2
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.zip
welcome to games-emulation
Diffstat (limited to 'games-emulation/ps2emu-spu2null')
-rw-r--r--games-emulation/ps2emu-spu2null/ChangeLog8
-rw-r--r--games-emulation/ps2emu-spu2null/Manifest4
-rw-r--r--games-emulation/ps2emu-spu2null/files/0.2-makefile.patch11
-rw-r--r--games-emulation/ps2emu-spu2null/files/digest-ps2emu-spu2null-0.21
-rw-r--r--games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.2.ebuild36
5 files changed, 60 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-spu2null/ChangeLog b/games-emulation/ps2emu-spu2null/ChangeLog
new file mode 100644
index 000000000000..f9c9dec06404
--- /dev/null
+++ b/games-emulation/ps2emu-spu2null/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-emulation/ps2emu-spu2null
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-spu2null/ChangeLog,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+*ps2emu-spu2null-0.2 (14 Aug 2003)
+
+ 14 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-emulation/ps2emu-spu2null/Manifest b/games-emulation/ps2emu-spu2null/Manifest
new file mode 100644
index 000000000000..ce0e5c3ab231
--- /dev/null
+++ b/games-emulation/ps2emu-spu2null/Manifest
@@ -0,0 +1,4 @@
+MD5 bc72b18d9522e1e5ad87aa252cf852a3 files/0.2-makefile.patch 374
+MD5 2f1a22d92b7bb71d70a02fc6fca605a0 files/digest-ps2emu-spu2null-0.2 60
+MD5 95bbbed35ee86795ff956e4fd8e0779c ChangeLog 371
+MD5 cc8f944ec481e620f45c83ca8e9089e0 ps2emu-spu2null-0.2.ebuild 755
diff --git a/games-emulation/ps2emu-spu2null/files/0.2-makefile.patch b/games-emulation/ps2emu-spu2null/files/0.2-makefile.patch
new file mode 100644
index 000000000000..468f96b3408b
--- /dev/null
+++ b/games-emulation/ps2emu-spu2null/files/0.2-makefile.patch
@@ -0,0 +1,11 @@
+--- Src/Makefile.orig 2003-08-14 21:14:02.092817328 -0400
++++ Src/Makefile 2003-08-14 21:14:09.306720648 -0400
+@@ -4,7 +4,7 @@
+ VERSION = 0
+ BUILD = 2
+ PLUGIN = libSPU2null-${VERSION}.${BUILD}.so
+-CFLAGS+= -fPIC -Wall -O2 -fomit-frame-pointer -D__LINUX__
++CFLAGS+= -fPIC -Wall $(OPTFLAGS) -D__LINUX__
+ OBJS = SPU2.o
+ DEPS:= $(OBJS:.o=.d)
+ LIBS = $(shell gtk-config --libs)
diff --git a/games-emulation/ps2emu-spu2null/files/digest-ps2emu-spu2null-0.2 b/games-emulation/ps2emu-spu2null/files/digest-ps2emu-spu2null-0.2
new file mode 100644
index 000000000000..d307f631d7fb
--- /dev/null
+++ b/games-emulation/ps2emu-spu2null/files/digest-ps2emu-spu2null-0.2
@@ -0,0 +1 @@
+MD5 7c778c52bd7233910baa573e502c7d36 SPU2null-0.2.zip 38242
diff --git a/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.2.ebuild b/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.2.ebuild
new file mode 100644
index 000000000000..60ce561d2087
--- /dev/null
+++ b/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.2.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+inherit games
+
+DESCRIPTION="PSEmu2 NULL Sound plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+SRC_URI="http://www.pcsx2.net/download/0.4release/SPU2null-${PV}.zip"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="=x11-libs/gtk+-1*"
+
+S=${WORKDIR}/SPU2null
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-makefile.patch
+}
+
+src_compile() {
+ cd Src
+ emake OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ cd Src
+ exeinto ${GAMES_LIBDIR}/ps2emu/plugins
+ doexe lib*
+ prepgamesdirs
+}