summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-15 06:31:49 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-15 06:31:49 +0000
commit97a7e6545923b667aeff671d9d36c83d7ab17af4 (patch)
treecb9ca5cde794324aa3a9bd733d89e5e50056d427 /games-emulation/psemu-peopssoftgpu
parentPatch to change the default data path to /var/lib/setiathome where gentoo put... (diff)
downloadgentoo-2-97a7e6545923b667aeff671d9d36c83d7ab17af4.tar.gz
gentoo-2-97a7e6545923b667aeff671d9d36c83d7ab17af4.tar.bz2
gentoo-2-97a7e6545923b667aeff671d9d36c83d7ab17af4.zip
make ARCH happy #56763
Diffstat (limited to 'games-emulation/psemu-peopssoftgpu')
-rw-r--r--games-emulation/psemu-peopssoftgpu/ChangeLog6
-rw-r--r--games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.15.ebuild22
2 files changed, 17 insertions, 11 deletions
diff --git a/games-emulation/psemu-peopssoftgpu/ChangeLog b/games-emulation/psemu-peopssoftgpu/ChangeLog
index d0b2a62ee1a6..a444fc460db9 100644
--- a/games-emulation/psemu-peopssoftgpu/ChangeLog
+++ b/games-emulation/psemu-peopssoftgpu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/psemu-peopssoftgpu
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopssoftgpu/ChangeLog,v 1.5 2004/06/24 22:34:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopssoftgpu/ChangeLog,v 1.6 2004/08/15 06:31:49 vapier Exp $
+
+ 15 Aug 2004; Mike Frysinger <vapier@gentoo.org>
+ psemu-peopssoftgpu-1.15.ebuild:
+ Remove all the x86-specifc code when ARCH != x86 #56763.
03 Jun 2004; Aron Griffis <agriffis@gentoo.org>
psemu-peopssoftgpu-1.15.ebuild:
diff --git a/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.15.ebuild b/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.15.ebuild
index 4f59a374d36d..65219d120973 100644
--- a/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.15.ebuild
+++ b/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.15.ebuild,v 1.6 2004/08/15 06:21:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.15.ebuild,v 1.7 2004/08/15 06:31:49 vapier Exp $
inherit games eutils
@@ -25,17 +25,19 @@ S=${WORKDIR}
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PV}-makefile-cflags.patch
+
+ if [ "${ARCH}" != "x86" ] ; then
+ cd src
+ sed -i -e "s/^CPU = i386/CPU = ${ARCH}/g" makes/mk.x11
+ sed -i \
+ -e "s/OBJECTS.*i386.o//g" \
+ -e "s/-D__i386__//g" makes/mk.fpse
+ sed -i -e '/^XF86VM =/s:TRUE:FALSE:' makes/mk.x11
+ fi
}
src_compile() {
cd src
-
- if [ "${ARCH}" = "ppc" ]; then
- sed -i -e "s/^CPU\ =\ i386/CPU = PowerPC/g" makes/mk.x11
- sed -i -e "s/OBJECTS.*i386.o//g" makes/mk.fpse
- sed -i -e "s/-D__i386__//g" makes/mk.fpse
- fi
-
emake OPTFLAGS="${CFLAGS}" || die "x11 build failed"
if use sdl ; then
@@ -51,8 +53,8 @@ src_install() {
doins gpuPeopsSoftX.cfg
cd src
exeinto ${GAMES_LIBDIR}/psemu/plugins
- doexe libgpuPeops*
+ doexe libgpuPeops* || die
exeinto ${GAMES_LIBDIR}/psemu/cfg
- doexe cfgPeopsSoft
+ doexe cfgPeopsSoft || die
prepgamesdirs
}