summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-10-12 18:50:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-10-12 18:50:03 +0000
commit18dd552977acb9b56deaf0f6ecd6bbc59d41f2e7 (patch)
treeaff8bde316fd6ad636e08c0364fc8372a30dd5a8 /games-emulation/sdlmame
parentVersion bump for Gnome 2.32 (diff)
downloadgentoo-2-18dd552977acb9b56deaf0f6ecd6bbc59d41f2e7.tar.gz
gentoo-2-18dd552977acb9b56deaf0f6ecd6bbc59d41f2e7.tar.bz2
gentoo-2-18dd552977acb9b56deaf0f6ecd6bbc59d41f2e7.zip
work around buggy patch version (bug #336004); clean old
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-emulation/sdlmame')
-rw-r--r--games-emulation/sdlmame/ChangeLog6
-rw-r--r--games-emulation/sdlmame/sdlmame-0.139_p2.ebuild148
-rw-r--r--games-emulation/sdlmame/sdlmame-0.139_p3.ebuild3
3 files changed, 7 insertions, 150 deletions
diff --git a/games-emulation/sdlmame/ChangeLog b/games-emulation/sdlmame/ChangeLog
index 78f04b54ae2d..1a4fca2c32a0 100644
--- a/games-emulation/sdlmame/ChangeLog
+++ b/games-emulation/sdlmame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/sdlmame
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/ChangeLog,v 1.34 2010/09/20 20:30:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/ChangeLog,v 1.35 2010/10/12 18:50:03 mr_bones_ Exp $
+
+ 12 Oct 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ -sdlmame-0.139_p2.ebuild, sdlmame-0.139_p3.ebuild:
+ work around buggy patch version (bug #336004); clean old
*sdlmame-0.139_p3 (20 Sep 2010)
diff --git a/games-emulation/sdlmame/sdlmame-0.139_p2.ebuild b/games-emulation/sdlmame/sdlmame-0.139_p2.ebuild
deleted file mode 100644
index 3b5394bf6e84..000000000000
--- a/games-emulation/sdlmame/sdlmame-0.139_p2.ebuild
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/sdlmame-0.139_p2.ebuild,v 1.3 2010/09/09 16:01:53 mr_bones_ Exp $
-
-EAPI=2
-inherit eutils flag-o-matic games
-
-MY_PV=${PV/.}
-MY_CONF_PN=${PN/sdl}
-MY_P=${PN}${MY_PV}
-MY_P=${MY_P%%_p*}
-DESCRIPTION="Multiple Arcade Machine Emulator (SDL)"
-HOMEPAGE="http://mamedev.org/"
-UPDATES="$(for PATCH_VER in $(seq 1 ${PV##*_p}) ; do echo "mirror://gentoo/${MY_P}u${PATCH_VER}_diff.zip"; done)"
-# Upstream doesn't allow fetching with unknown User-Agent such as wget
-SRC_URI="mirror://gentoo/${MY_P/sdl}s.zip $UPDATES"
-
-LICENSE="XMAME"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug opengl"
-
-RDEPEND=">=media-libs/libsdl-1.2.10[audio,joystick,opengl?,video]
- dev-libs/expat
- x11-libs/libXinerama
- debug? (
- x11-libs/gtk+:2
- gnome-base/gconf
- )"
-DEPEND="${RDEPEND}
- app-arch/unzip
- x11-proto/xineramaproto"
-
-S=${WORKDIR}
-
-# Function to disable a makefile option
-disable_feature() {
- sed -i \
- -e "/$1.*=/s:^:# :" \
- "${S}"/makefile \
- || die "sed failed"
-}
-
-# Function to enable a makefile option
-enable_feature() {
- sed -i \
- -e "/^#.*$1.*=/s:^# ::" \
- "${S}"/makefile \
- || die "sed failed"
-}
-
-src_unpack() {
- base_src_unpack
- unpack ./mame.zip
- rm -f mame.zip
-}
-
-src_prepare() {
- if [[ $PV == *_p* ]] ; then
- einfo "Patching release with source updates"
- epatch ${MY_PV%%_p*}*.diff
- fi
- sed -i \
- -e '/CFLAGS += -O$(OPTIMIZE)/s:^:# :' \
- -e '/CFLAGS += -pipe/s:^:# :' \
- -e '/LDFLAGS += -s/s:^:# :' \
- -e '/LDFLAGS =/d' \
- -e 's:-Werror::' \
- makefile \
- || die "sed failed"
- # Don't compile zlib and expat
- einfo "Disabling embedded libraries: zlib and expat"
- disable_feature BUILD_ZLIB
- disable_feature BUILD_EXPAT
-
- if use amd64; then
- einfo "Enabling 64-bit support"
- enable_feature PTR64
- fi
-
- if use ppc; then
- einfo "Enabling PPC support"
- enable_feature BIGENDIAN
- fi
-
- if use debug; then
- einfo "Enabling DEBUG support"
- enable_feature DEBUG
- fi
-}
-
-src_compile() {
- local make_opts
-
- use opengl || make_opts="${make_opts} NO_OPENGL=1"
-
- emake \
- NAME="${PN}" \
- OPT_FLAGS='-DINI_PATH=\"\$$HOME/.'${PN}'\;'"${GAMES_SYSCONFDIR}/${PN}"'\"'" ${CXXFLAGS}" \
- CC="${CXX}" \
- SUFFIX="" \
- ${make_opts} \
- all \
- || die "emake failed"
-}
-
-src_install() {
- dogamesbin ${PN}$(use amd64 && echo 64) || die
-
- # Avoid collision on /usr/games/bin/jedutil
- exeinto "$(games_get_libdir)/${PN}"
- doexe chdman jedutil ldverify romcmp testkeys || die
- doman src/osd/sdl/man/{chdman,jedutil,ldverify,romcmp,testkeys}.1
- newman src/osd/sdl/man/mame.1 ${PN}.1
-
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r src/osd/sdl/keymaps || die "doins -r keymaps failed"
-
- insinto "${GAMES_SYSCONFDIR}/${PN}"
- doins "${FILESDIR}"/{joymap.dat,vector.ini} || die "doins joymap.dat vector.ini failed"
-
- sed \
- -e "s:@GAMES_SYSCONFDIR@:${GAMES_SYSCONFDIR}:" \
- -e "s:@GAMES_DATADIR@:${GAMES_DATADIR}:" \
- "${FILESDIR}"/mame.ini.in > "${D}/${GAMES_SYSCONFDIR}/${PN}/"mame.ini \
- || die "sed failed"
-
- dodoc docs/{config,mame,newvideo}.txt whatsnew*.txt
-
- keepdir \
- "${GAMES_DATADIR}/${PN}"/{roms,samples,artwork} \
- "${GAMES_SYSCONFDIR}/${PN}"/ctrlr
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
-
- elog "It's strongly recommended that you change either the system-wide"
- elog "${MY_CONF_PN}.ini at \"${GAMES_SYSCONFDIR}/${PN}\" or use a per-user setup at \$HOME/.${PN}"
-
- if use opengl; then
- echo
- elog "You built ${PN} with opengl support and should set"
- elog "\"video\" to \"opengl\" in ${MY_CONF_PN}.ini to take advantage of that"
- fi
-}
diff --git a/games-emulation/sdlmame/sdlmame-0.139_p3.ebuild b/games-emulation/sdlmame/sdlmame-0.139_p3.ebuild
index 5ab395c5c983..b65257a5a011 100644
--- a/games-emulation/sdlmame/sdlmame-0.139_p3.ebuild
+++ b/games-emulation/sdlmame/sdlmame-0.139_p3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/sdlmame-0.139_p3.ebuild,v 1.1 2010/09/20 20:30:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/sdlmame-0.139_p3.ebuild,v 1.2 2010/10/12 18:50:03 mr_bones_ Exp $
EAPI=2
inherit eutils flag-o-matic games
@@ -58,6 +58,7 @@ src_unpack() {
}
src_prepare() {
+ edos2unix $(find . -type f)
if [[ $PV == *_p* ]] ; then
einfo "Patching release with source updates"
epatch ${MY_PV%%_p*}*.diff