summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-08-28 02:35:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-08-28 02:35:52 +0000
commit76e93343db4281786c7b7513453a9fc027b37509 (patch)
treeb6cb63a372166e31056b2df0f6b7295c275c27d6 /games-emulation/stella
parentOld. (diff)
downloadgentoo-2-76e93343db4281786c7b7513453a9fc027b37509.tar.gz
gentoo-2-76e93343db4281786c7b7513453a9fc027b37509.tar.bz2
gentoo-2-76e93343db4281786c7b7513453a9fc027b37509.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-emulation/stella')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/stella-3.2.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index f063786cdfe9..2578a5783073 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.49 2010/06/01 08:20:23 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.50 2010/08/28 02:35:52 mr_bones_ Exp $
+
+*stella-3.2.1 (28 Aug 2010)
+
+ 28 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org> +stella-3.2.1.ebuild:
+ version bump
01 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> stella-3.1.ebuild:
x86 stable wrt bug #321345
diff --git a/games-emulation/stella/stella-3.2.1.ebuild b/games-emulation/stella/stella-3.2.1.ebuild
new file mode 100644
index 000000000000..8c89a4b647e7
--- /dev/null
+++ b/games-emulation/stella/stella-3.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-3.2.1.ebuild,v 1.1 2010/08/28 02:35:52 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl[video]
+ sys-libs/zlib
+ opengl? ( virtual/opengl )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl gl) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/common/stella.png
+ make_desktop_entry stella Stella
+ dohtml -r docs/*
+ dodoc Announce.txt Changes.txt Copyright.txt README-GP2X.txt README-SDL.txt Readme.txt Todo.txt
+ prepgamesdirs
+}