summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-27 08:28:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-27 08:28:17 +0000
commit06321cf27f94232de4c224eece222f47bb83ecc6 (patch)
tree726289b9b90a6eacf7fa9fe4b3acf967fe3bb9a8 /games-emulation/virtualjaguar
parentMarked as stable on x86 and alpha (diff)
downloadgentoo-2-06321cf27f94232de4c224eece222f47bb83ecc6.tar.gz
gentoo-2-06321cf27f94232de4c224eece222f47bb83ecc6.tar.bz2
gentoo-2-06321cf27f94232de4c224eece222f47bb83ecc6.zip
Added gcc331.patch from Daniel Goller via bug 29642
Diffstat (limited to 'games-emulation/virtualjaguar')
-rw-r--r--games-emulation/virtualjaguar/ChangeLog6
-rw-r--r--games-emulation/virtualjaguar/Manifest9
-rw-r--r--games-emulation/virtualjaguar/files/gcc331.patch56
-rw-r--r--games-emulation/virtualjaguar/virtualjaguar-1.0.6.ebuild5
4 files changed, 69 insertions, 7 deletions
diff --git a/games-emulation/virtualjaguar/ChangeLog b/games-emulation/virtualjaguar/ChangeLog
index 6e274d78b320..ea97a8656a01 100644
--- a/games-emulation/virtualjaguar/ChangeLog
+++ b/games-emulation/virtualjaguar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/virtualjaguar
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/ChangeLog,v 1.2 2003/09/26 07:44:52 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/ChangeLog,v 1.3 2003/09/27 08:28:15 mr_bones_ Exp $
+
+ 27 Sep 2003; Michael Sterrett <msterret@gentoo.org>
+ virtualjaguar-1.0.6.ebuild, files/gcc331.patch:
+ Added gcc331.patch from Daniel Goller via bug 29642
*virtualjaguar-1.0.6 (26 Sep 2003)
diff --git a/games-emulation/virtualjaguar/Manifest b/games-emulation/virtualjaguar/Manifest
index 570ef3e319e8..6aec869dc6d5 100644
--- a/games-emulation/virtualjaguar/Manifest
+++ b/games-emulation/virtualjaguar/Manifest
@@ -1,7 +1,8 @@
-MD5 4a4a373db40f51edf294c6fecb5b12cc virtualjaguar-1.0.5.ebuild 1247
+MD5 13cb3e3d65ff22ee4bde1ca998b1ad26 ChangeLog 803
MD5 2e2132e40a658dfaa598ff0066a93da5 metadata.xml 417
-MD5 3ccf87ec1c571674278813dcfc230a73 ChangeLog 643
-MD5 ea5d4e7516daf558dfae45b24bf65280 virtualjaguar-1.0.6.ebuild 1225
+MD5 4a4a373db40f51edf294c6fecb5b12cc virtualjaguar-1.0.5.ebuild 1247
+MD5 d0d841e8442a545b2fa6f0462becdbd5 virtualjaguar-1.0.6.ebuild 1266
+MD5 8425919508218348801f7b6be2262dcd files/gcc331.patch 1930
MD5 537c716601ef69dc13d9285e99d0f339 files/digest-virtualjaguar-1.0.5 72
-MD5 761a5f5c9d623d7caac8ef5c34eabd2c files/virtualjaguar 751
MD5 8c33120cd4e2306208ebe81ada04636d files/digest-virtualjaguar-1.0.6 76
+MD5 761a5f5c9d623d7caac8ef5c34eabd2c files/virtualjaguar 751
diff --git a/games-emulation/virtualjaguar/files/gcc331.patch b/games-emulation/virtualjaguar/files/gcc331.patch
new file mode 100644
index 000000000000..dd02172d29a1
--- /dev/null
+++ b/games-emulation/virtualjaguar/files/gcc331.patch
@@ -0,0 +1,56 @@
+--- src/objectp.cpp.wrong 2003-09-26 02:43:48.380421352 -0500
++++ src/objectp.cpp 2003-09-26 02:42:29.977340432 -0500
+@@ -451,16 +451,16 @@
+ // if (height)
+ height--;
+
+- uint64 data = (p0 & 0xFFFFF80000000000) >> 40;
++ uint64 data = (p0 & 0xFFFFF80000000000LL) >> 40;
+ uint64 dwidth = (p1 & 0xFFC0000) >> 15;
+ data += dwidth;
+
+- p0 &= ~0xFFFFF80000FFC000; // Mask out old data...
++ p0 &= ~0xFFFFF80000FFC000LL; // Mask out old data...
+ p0 |= (uint64)height << 14;
+ p0 |= data << 40;
+ OPStorePhrase(oldOPP, p0);
+ }
+- op_pointer = (p0 & 0x000007FFFF000000) >> 21;
++ op_pointer = (p0 & 0x000007FFFF000000LL) >> 21;
+ break;
+ }
+ case OBJECT_TYPE_SCALE:
+@@ -504,7 +504,7 @@
+ // if (remainder & 0x80) // I.e., it's negative
+ if ((remainder & 0x80) || remainder == 0) // I.e., it's <= 0
+ {
+- uint64 data = (p0 & 0xFFFFF80000000000) >> 40;
++ uint64 data = (p0 & 0xFFFFF80000000000LL) >> 40;
+ uint64 dwidth = (p1 & 0xFFC0000) >> 15;
+
+ // while (remainder & 0x80)
+@@ -516,21 +516,21 @@
+
+ data += dwidth;
+ }
+- p0 &= ~0xFFFFF80000FFC000; // Mask out old data...
++ p0 &= ~0xFFFFF80000FFC000LL; // Mask out old data...
+ p0 |= (uint64)height << 14;
+ p0 |= data << 40;
+ OPStorePhrase(oldOPP, p0);
+ }
+
+ //WriteLog(" [%08X%08X -> ", (uint32)(p2>>32), (uint32)(p2&0xFFFFFFFF));
+- p2 &= ~0x0000000000FF0000;
++ p2 &= ~0x0000000000FF0000LL;
+ p2 |= (uint64)remainder << 16;
+ //WriteLog("%08X%08X]\n", (uint32)(p2>>32), (uint32)(p2&0xFFFFFFFF));
+ OPStorePhrase(oldOPP+16, p2);
+ //remainder = (uint8)(p2 >> 16), vscale = (uint8)(p2 >> 8);
+ //WriteLog(" [after]: rem=%02X, vscale=%02X\n", remainder, vscale);
+ }
+- op_pointer = (p0 & 0x000007FFFF000000) >> 21;
++ op_pointer = (p0 & 0x000007FFFF000000LL) >> 21;
+ break;
+ }
+ case OBJECT_TYPE_GPU:
diff --git a/games-emulation/virtualjaguar/virtualjaguar-1.0.6.ebuild b/games-emulation/virtualjaguar/virtualjaguar-1.0.6.ebuild
index 97dae3af8128..1add924c0be1 100644
--- a/games-emulation/virtualjaguar/virtualjaguar-1.0.6.ebuild
+++ b/games-emulation/virtualjaguar/virtualjaguar-1.0.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/virtualjaguar-1.0.6.ebuild,v 1.1 2003/09/26 07:44:53 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/virtualjaguar-1.0.6.ebuild,v 1.2 2003/09/27 08:28:15 mr_bones_ Exp $
-inherit games
+inherit eutils games
S="${WORKDIR}/${P}-src"
DESCRIPTION="an Atari Jaguar emulator"
@@ -26,6 +26,7 @@ src_unpack() {
sed -i \
-e "s:-O3:${CFLAGS}:" Makefile.unix || \
die "sed Makefile.unix failed"
+ epatch ${FILESDIR}/gcc331.patch
}
src_compile() {