summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-30 04:13:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-30 04:13:27 +0000
commit32c8487f9a761ab732f0316c63efdc49b40d3946 (patch)
tree189369cf704da3136cd3cbc485ce049db0a374c5 /games-emulation/yabause
parent Assorted fixes, triggered by bug #223765. (diff)
downloadgentoo-2-32c8487f9a761ab732f0316c63efdc49b40d3946.tar.gz
gentoo-2-32c8487f9a761ab732f0316c63efdc49b40d3946.tar.bz2
gentoo-2-32c8487f9a761ab732f0316c63efdc49b40d3946.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-emulation/yabause')
-rw-r--r--games-emulation/yabause/ChangeLog8
-rw-r--r--games-emulation/yabause/yabause-0.9.6.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/games-emulation/yabause/ChangeLog b/games-emulation/yabause/ChangeLog
index e5506d53986c..2ba1bc901a70 100644
--- a/games-emulation/yabause/ChangeLog
+++ b/games-emulation/yabause/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/yabause
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.25 2008/05/11 23:53:29 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.26 2008/06/30 04:13:27 mr_bones_ Exp $
+
+*yabause-0.9.6 (30 Jun 2008)
+
+ 30 Jun 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +yabause-0.9.6.ebuild:
+ version bump
*yabause-0.9.5 (11 May 2008)
diff --git a/games-emulation/yabause/yabause-0.9.6.ebuild b/games-emulation/yabause/yabause-0.9.6.ebuild
new file mode 100644
index 000000000000..54bbbe8debf0
--- /dev/null
+++ b/games-emulation/yabause/yabause-0.9.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/yabause-0.9.6.ebuild,v 1.1 2008/06/30 04:13:27 mr_bones_ Exp $
+
+EAPI=1
+inherit games
+
+DESCRIPTION="A Sega Saturn emulator"
+HOMEPAGE="http://yabause.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/gtkglext
+ virtual/opengl
+ virtual/glu
+ virtual/glut
+ media-libs/libsdl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ egamesconf \
+ --datadir=/usr/share \
+ --with-port=gtk \
+ || die
+ emake -C src/c68k gen68k || die "emake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog GOALS README README.LIN TODO
+ prepgamesdirs
+}