summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-14 08:45:05 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-14 08:45:05 +0000
commit27867ac76ed1e7123e7f2825a801f37d7ad75e8d (patch)
tree4674650a870bb99b0b99c58ba46f4cacf86441db /games-emulation/zsnes
parentVersion bump. Fixes bug #382803 (diff)
downloadgentoo-2-27867ac76ed1e7123e7f2825a801f37d7ad75e8d.tar.gz
gentoo-2-27867ac76ed1e7123e7f2825a801f37d7ad75e8d.tar.bz2
gentoo-2-27867ac76ed1e7123e7f2825a801f37d7ad75e8d.zip
Fix building with libpng15 wrt #378735 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/zsnes')
-rw-r--r--games-emulation/zsnes/ChangeLog8
-rw-r--r--games-emulation/zsnes/files/zsnes-1.51-libpng15.patch12
-rw-r--r--games-emulation/zsnes/zsnes-1.51-r2.ebuild6
3 files changed, 22 insertions, 4 deletions
diff --git a/games-emulation/zsnes/ChangeLog b/games-emulation/zsnes/ChangeLog
index ab28b4714c3e..62a11c82543b 100644
--- a/games-emulation/zsnes/ChangeLog
+++ b/games-emulation/zsnes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/zsnes
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.46 2010/01/03 11:52:55 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.47 2011/09/14 08:45:05 ssuominen Exp $
+
+ 14 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> zsnes-1.51-r2.ebuild,
+ +files/zsnes-1.51-libpng15.patch:
+ Fix building with libpng15 wrt #378735 by Diego Elio Pettenò
03 Jan 2010; Christian Faulhammer <fauli@gentoo.org> zsnes-1.51-r2.ebuild:
Transfer Prefix keywords
diff --git a/games-emulation/zsnes/files/zsnes-1.51-libpng15.patch b/games-emulation/zsnes/files/zsnes-1.51-libpng15.patch
new file mode 100644
index 000000000000..b32c30967547
--- /dev/null
+++ b/games-emulation/zsnes/files/zsnes-1.51-libpng15.patch
@@ -0,0 +1,12 @@
+Use existing png_set_IHDR() and stop accessing PNG structure members directly
+
+--- src/zip/zpng.c
++++ src/zip/zpng.c
+@@ -129,7 +129,6 @@
+ png_set_IHDR(png_ptr, info_ptr, width, height, 8,
+ PNG_COLOR_TYPE_RGB, PNG_INTERLACE_NONE,
+ PNG_COMPRESSION_TYPE_DEFAULT, PNG_FILTER_TYPE_DEFAULT);
+- info_ptr->color_type = PNG_COLOR_TYPE_RGB;
+
+ //Allocate an array of scanline pointers
+ row_pointers = (png_bytep*)malloc(height*sizeof(png_bytep));
diff --git a/games-emulation/zsnes/zsnes-1.51-r2.ebuild b/games-emulation/zsnes/zsnes-1.51-r2.ebuild
index 320cf726835c..8853821544bf 100644
--- a/games-emulation/zsnes/zsnes-1.51-r2.ebuild
+++ b/games-emulation/zsnes/zsnes-1.51-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.51-r2.ebuild,v 1.7 2010/01/03 11:52:55 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.51-r2.ebuild,v 1.8 2011/09/14 08:45:05 ssuominen Exp $
inherit eutils autotools flag-o-matic toolchain-funcs multilib games
@@ -40,6 +40,8 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-depbuild.patch
# Fix bug #260247
epatch "${FILESDIR}"/${P}-CC-quotes.patch
+ # Fix compability with libpng15 wrt #378735
+ epatch "${FILESDIR}"/${P}-libpng15.patch
# Remove hardcoded CFLAGS and LDFLAGS
sed -i \