summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-06-13 15:50:14 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-06-13 15:50:14 +0000
commit27b9161edb22fd87617fb945cc10f09d85ab156b (patch)
tree14baaf74155dc8657c67bb8d10368691266a7719 /games-emulation
parentStable for HPPA (bug #273141). (diff)
downloadgentoo-2-27b9161edb22fd87617fb945cc10f09d85ab156b.tar.gz
gentoo-2-27b9161edb22fd87617fb945cc10f09d85ab156b.tar.bz2
gentoo-2-27b9161edb22fd87617fb945cc10f09d85ab156b.zip
Fix building with glibc-2.10, bug #273518
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/visualboyadvance/ChangeLog9
-rw-r--r--games-emulation/visualboyadvance/files/visualboyadvance-1.7.2-glibc2.10.patch76
-rw-r--r--games-emulation/visualboyadvance/visualboyadvance-1.7.2-r2.ebuild7
3 files changed, 87 insertions, 5 deletions
diff --git a/games-emulation/visualboyadvance/ChangeLog b/games-emulation/visualboyadvance/ChangeLog
index b971b67369d6..a5c6814defce 100644
--- a/games-emulation/visualboyadvance/ChangeLog
+++ b/games-emulation/visualboyadvance/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/visualboyadvance
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/visualboyadvance/ChangeLog,v 1.34 2008/11/17 20:36:42 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/visualboyadvance/ChangeLog,v 1.35 2009/06/13 15:50:14 nyhm Exp $
+
+ 13 Jun 2009; Tristan Heaven <nyhm@gentoo.org>
+ visualboyadvance-1.7.2-r2.ebuild,
+ +files/visualboyadvance-1.7.2-glibc2.10.patch:
+ Fix building with glibc-2.10, bug #273518
17 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
files/1.7.2-gcc41.patch, files/visualboyadvance-1.7.2-uninit.patch:
diff --git a/games-emulation/visualboyadvance/files/visualboyadvance-1.7.2-glibc2.10.patch b/games-emulation/visualboyadvance/files/visualboyadvance-1.7.2-glibc2.10.patch
new file mode 100644
index 000000000000..5211b362350e
--- /dev/null
+++ b/games-emulation/visualboyadvance/files/visualboyadvance-1.7.2-glibc2.10.patch
@@ -0,0 +1,76 @@
+--- src/GBA.cpp
++++ src/GBA.cpp
+@@ -1130,7 +1130,7 @@
+ bool CPUIsZipFile(const char * file)
+ {
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".zip") == 0)
+@@ -1145,7 +1145,7 @@
+ {
+ cpuIsMultiBoot = false;
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".gba") == 0)
+@@ -1169,7 +1169,7 @@
+ bool CPUIsGBABios(const char * file)
+ {
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".gba") == 0)
+@@ -1189,7 +1189,7 @@
+ bool CPUIsELF(const char *file)
+ {
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".elf") == 0)
+--- src/Util.cpp
++++ src/Util.cpp
+@@ -478,7 +478,7 @@
+ {
+ cpuIsMultiBoot = false;
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".gba") == 0)
+@@ -502,7 +502,7 @@
+ bool utilIsGBImage(const char * file)
+ {
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".gb") == 0)
+@@ -522,7 +522,7 @@
+ bool utilIsZipFile(const char *file)
+ {
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".zip") == 0)
+@@ -552,7 +552,7 @@
+ bool utilIsGzipFile(const char *file)
+ {
+ if(strlen(file) > 3) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".gz") == 0)
diff --git a/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r2.ebuild b/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r2.ebuild
index 3ecde3041e4d..732f70447bcd 100644
--- a/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r2.ebuild
+++ b/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r2.ebuild,v 1.2 2008/05/02 21:34:30 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r2.ebuild,v 1.3 2009/06/13 15:50:14 nyhm Exp $
inherit eutils flag-o-matic games
@@ -50,7 +50,8 @@ src_unpack() {
"${FILESDIR}"/${PV}-gcc34.patch \
"${FILESDIR}"/${PV}-gcc41.patch \
"${WORKDIR}"/${P}-deprecatedsigc++.patch \
- "${FILESDIR}"/${P}-uninit.patch
+ "${FILESDIR}"/${P}-uninit.patch \
+ "${FILESDIR}"/${P}-glibc2.10.patch
}
src_compile() {