summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-29 10:36:24 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-29 10:36:24 +0000
commit367bcc409df6aeb568526900829dd8ae8035d6d7 (patch)
treec5bdef526b3244cef67f58cf07c69a0d578c5e1e /games-emulation
parenttouchups (diff)
downloadgentoo-2-367bcc409df6aeb568526900829dd8ae8035d6d7.tar.gz
gentoo-2-367bcc409df6aeb568526900829dd8ae8035d6d7.tar.bz2
gentoo-2-367bcc409df6aeb568526900829dd8ae8035d6d7.zip
make it stable
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/hatari/hatari-0.45.ebuild12
-rw-r--r--games-emulation/openmsx/openmsx-0.3.4.ebuild30
2 files changed, 22 insertions, 20 deletions
diff --git a/games-emulation/hatari/hatari-0.45.ebuild b/games-emulation/hatari/hatari-0.45.ebuild
index 3b291a50698a..bed06f1d2b63 100644
--- a/games-emulation/hatari/hatari-0.45.ebuild
+++ b/games-emulation/hatari/hatari-0.45.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-0.45.ebuild,v 1.2 2004/02/20 06:26:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-0.45.ebuild,v 1.3 2004/02/29 10:31:38 vapier Exp $
inherit games
DESCRIPTION="Atari ST emulator"
-SRC_URI="mirror://sourceforge/hatari/${P}.tar.gz"
HOMEPAGE="http://hatari.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hatari/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc"
SLOT="0"
+KEYWORDS="x86 ppc"
RDEPEND="games-emulation/emutos
media-libs/libsdl
@@ -36,9 +36,9 @@ src_compile() {
src_install() {
dogamesbin ${S}/src/hatari || die "dogamesbin failed"
insinto ${GAMES_DATADIR}/${PN}
- doins src/font8.bmp || die "doins failed"
- dodoc readme.txt doc/*.txt || die "dodoc failed"
- dohtml doc/ || die "dohtml failed"
+ doins src/font8.bmp || die "doins font8.bmp failed"
+ dodoc readme.txt doc/*.txt
+ dohtml -r doc/
prepgamesdirs
}
diff --git a/games-emulation/openmsx/openmsx-0.3.4.ebuild b/games-emulation/openmsx/openmsx-0.3.4.ebuild
index 7039e46936b3..4c6cc182c72c 100644
--- a/games-emulation/openmsx/openmsx-0.3.4.ebuild
+++ b/games-emulation/openmsx/openmsx-0.3.4.ebuild
@@ -1,20 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.3.4.ebuild,v 1.1 2004/01/27 23:38:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.3.4.ebuild,v 1.2 2004/02/29 10:36:24 vapier Exp $
-inherit flag-o-matic games
+inherit games flag-o-matic
DESCRIPTION="MSX emulator that aims for perfection"
HOMEPAGE="http://openmsx.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-KEYWORDS="~x86 ~sparc"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-
-# fix bug 32745
-replace-flags '-Os' '-O2'
+KEYWORDS="x86 sparc"
DEPEND="dev-libs/libxml2
media-libs/libpng
@@ -30,14 +26,21 @@ src_unpack() {
# Remove all symlinking from the Makefile.in
sed -i \
- -e "/ln /d" Makefile.in || \
- die "sed Makefile.in failed"
+ -e "/ln /d" Makefile.in \
+ || die "sed Makefile.in failed"
# Change the hardcoded default SystemDir.
sed -i \
-e "s:/opt/openMSX/:${GAMES_DATADIR}/${PN}/:" \
- src/file/FileOperations.cc || \
- die "sed FileOperations.cc failed"
+ src/file/FileOperations.cc \
+ || die "sed FileOperations.cc failed"
+}
+
+src_compile() {
+ # fix bug 32745
+ replace-flags -Os -O2
+ egamesconf || die
+ emake || die
}
src_install() {
@@ -53,9 +56,8 @@ src_install() {
dosym ${GAMES_DATADIR}/${PN}/share/machines/Panasonic_FS-A1GT \
${GAMES_DATADIR}/${PN}/share/machines/turbor
- dodoc README AUTHORS NEWS ${D}${GAMES_DATADIR}/openmsx/*.{txt,tex} || \
- die "dodoc failed"
- dohtml -r doc/* || die "dohtml failed"
+ dodoc README AUTHORS NEWS ${D}${GAMES_DATADIR}/openmsx/*.{txt,tex}
+ dohtml -r doc/*
# Tidy up install
rm -f ${D}${GAMES_DATADIR}/openmsx/*.{txt,tex,html,png,css}