summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-02-07 22:31:33 +0000
committerMike Frysinger <vapier@gentoo.org>2013-02-07 22:31:33 +0000
commit431712208c85c07016eebd774c056673b30c8c36 (patch)
treec8b80761003ee8b8624b495191edc3d552762207 /games-emulation
parentMove Creative Commons licenses to shorter names. (diff)
downloadgentoo-2-431712208c85c07016eebd774c056673b30c8c36.tar.gz
gentoo-2-431712208c85c07016eebd774c056673b30c8c36.tar.bz2
gentoo-2-431712208c85c07016eebd774c056673b30c8c36.zip
Fix cross-compiling.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/zsnes/ChangeLog6
-rw-r--r--games-emulation/zsnes/files/zsnes-1.51-cross-compile.patch34
-rw-r--r--games-emulation/zsnes/zsnes-1.51-r4.ebuild10
3 files changed, 47 insertions, 3 deletions
diff --git a/games-emulation/zsnes/ChangeLog b/games-emulation/zsnes/ChangeLog
index 7dd719385f80..afc739f60489 100644
--- a/games-emulation/zsnes/ChangeLog
+++ b/games-emulation/zsnes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/zsnes
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.57 2013/02/07 21:46:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.58 2013/02/07 22:31:33 vapier Exp $
+
+ 07 Feb 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/zsnes-1.51-cross-compile.patch, zsnes-1.51-r4.ebuild:
+ Fix cross-compiling.
07 Feb 2013; Mike Frysinger <vapier@gentoo.org> metadata.xml,
zsnes-1.51-r4.ebuild:
diff --git a/games-emulation/zsnes/files/zsnes-1.51-cross-compile.patch b/games-emulation/zsnes/files/zsnes-1.51-cross-compile.patch
new file mode 100644
index 000000000000..5823c6aa6ade
--- /dev/null
+++ b/games-emulation/zsnes/files/zsnes-1.51-cross-compile.patch
@@ -0,0 +1,34 @@
+--- a/src/acinclude.m4
++++ b/src/acinclude.m4
+@@ -107,7 +107,7 @@ int main (int argc, char *argv[])
+ with_zlib=yes,
+ with_zlib=no,
+ [AC_MSG_RESULT(cross-compiling)
+- with_zlib=""
++ with_zlib="cross"
+ AC_MSG_WARN(Assuming zlib is available)])
+
+ if test x$with_zlib != x; then
+@@ -116,7 +116,7 @@ fi
+ if test x$with_zlib = xyes; then
+ ZLIB_VERSION=$(<conf.zlibtest)
+ ifelse([$2], , :, [$2])
+-else
++elif test x$with_zlib != xcross; then
+ ZLIB_CFLAGS=""
+ ZLIB_LIBS=""
+ ZLIB_VERSION=""
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -103,8 +103,10 @@ main: makefile.dep $(Z_OBJS)
+ @ZC@ -o @ZSNESEXE@ $(Z_OBJS) @ZCFLAGS@ @LDFLAGS@
+ rm -f version.o
+
++BUILD_CXX ?= g++
++BUILD_CXXFLAGS ?= -O2 -pipe
+ $(PSR): parsegen.cpp
+- @CXX@ @CXXFLAGS@ -o $@ $< -lz
++ $(BUILD_CXX) $(BUILD_CXXFLAGS) -o $@ $< -lz
+
+ TOOLSEXE=$(TOOL_D)/archopt $(TOOL_D)/cutrtype $(TOOL_D)/extraext\
+ $(TOOL_D)/macroll $(TOOL_D)/minwhite $(TOOL_D)/nreplace\
diff --git a/games-emulation/zsnes/zsnes-1.51-r4.ebuild b/games-emulation/zsnes/zsnes-1.51-r4.ebuild
index b868fec237da..0a460fd51d85 100644
--- a/games-emulation/zsnes/zsnes-1.51-r4.ebuild
+++ b/games-emulation/zsnes/zsnes-1.51-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.51-r4.ebuild,v 1.4 2013/02/07 21:46:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.51-r4.ebuild,v 1.5 2013/02/07 22:31:33 vapier Exp $
EAPI=2
inherit eutils autotools flag-o-matic toolchain-funcs multilib pax-utils games
@@ -45,7 +45,13 @@ src_prepare() {
"${FILESDIR}"/${P}-CC-quotes.patch \
"${FILESDIR}"/${P}-libpng15.patch \
"${FILESDIR}"/${P}-buffer.patch \
- "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-cross-compile.patch
+
+ # The sdl detection logic uses AC_PROG_PATH instead of
+ # AC_PROG_TOOL, so force the var to get set the way we
+ # need for things to work correctly.
+ tc-is-cross-compiler && export ac_cv_path_SDL_CONFIG=${CHOST}-sdl-config
sed -i -e '67i#define OF(x) x' zip/zunzip.h || die