summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-12 15:38:21 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-12 15:38:21 +0000
commit497048320a07778a39d4f04f331833a4c8d8e1d6 (patch)
treee6ae7b656a2bd03c7ea27c122e223a4a2cb874c5 /games-emulation
parentremove inherit magic and call functions explicitly (diff)
downloadgentoo-2-497048320a07778a39d4f04f331833a4c8d8e1d6.tar.gz
gentoo-2-497048320a07778a39d4f04f331833a4c8d8e1d6.tar.bz2
gentoo-2-497048320a07778a39d4f04f331833a4c8d8e1d6.zip
remove inherit magic and call functions explicitly
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gfceux/ChangeLog5
-rw-r--r--games-emulation/gfceux/gfceux-2.1.1-r1.ebuild11
2 files changed, 12 insertions, 4 deletions
diff --git a/games-emulation/gfceux/ChangeLog b/games-emulation/gfceux/ChangeLog
index 147e53907d3d..7fd9056faaab 100644
--- a/games-emulation/gfceux/ChangeLog
+++ b/games-emulation/gfceux/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/gfceux
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gfceux/ChangeLog,v 1.5 2013/01/11 19:04:23 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gfceux/ChangeLog,v 1.6 2013/01/12 15:38:21 hasufell Exp $
+
+ 12 Jan 2013; Julian Ospald <hasufell@gentoo.org> gfceux-2.1.1-r1.ebuild:
+ remove inherit magic and call functions explicitly
*gfceux-2.1.1-r1 (11 Jan 2013)
diff --git a/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild b/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild
index 48dc700fa1df..91f0521a3088 100644
--- a/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild
+++ b/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild,v 1.1 2013/01/11 19:04:23 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild,v 1.2 2013/01/12 15:38:21 hasufell Exp $
EAPI=5
PYTHON_COMPAT=( python2_6 python2_7 )
-# inherit base explicitly to avoid overrides on distutils-r1
-inherit base eutils gnome2-utils distutils-r1 games
+inherit eutils gnome2-utils distutils-r1 games
DESCRIPTION="A graphical frontend for the FCEUX emulator"
HOMEPAGE="http://fceux.com"
@@ -25,6 +24,8 @@ RDEPEND="${DEPEND}
S=${WORKDIR}/${PN}
python_prepare_all() {
+ distutils-r1_python_prepare_all
+
sed -i \
-e "s#data/gfceux.glade#${GAMES_DATADIR}/${PN}/gfceux.glade#" \
src/main.py || die
@@ -34,6 +35,10 @@ python_install() {
distutils-r1_python_install --install-scripts="${GAMES_BINDIR}"
}
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
src_compile() {
distutils-r1_src_compile
}