summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-31 22:27:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-31 22:27:25 +0000
commit4c2c61362ef430cf76612e3afa903fcf774e813c (patch)
tree2ebf7c055e02e625a0c5ef0ca49cf4c12fe3b1a6 /games-emulation
parentFixed problem reported in bug #83071. Parallel build broken bug #121089, work... (diff)
downloadgentoo-2-4c2c61362ef430cf76612e3afa903fcf774e813c.tar.gz
gentoo-2-4c2c61362ef430cf76612e3afa903fcf774e813c.tar.bz2
gentoo-2-4c2c61362ef430cf76612e3afa903fcf774e813c.zip
version bump
(Portage version: 2.0.54)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/Manifest2
-rw-r--r--games-emulation/stella/files/digest-stella-2.11
-rw-r--r--games-emulation/stella/stella-2.1.ebuild56
4 files changed, 65 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index a332ea70161f..e71fdb1058e0 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.17 2006/01/08 01:40:33 malc Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.18 2006/01/31 22:27:25 mr_bones_ Exp $
+
+*stella-2.1 (31 Jan 2006)
+
+ 31 Jan 2006; Michael Sterrett <mr_bones_@gentoo.org> +stella-2.1.ebuild:
+ version bump
07 Jan 2006; Malcolm Lashley <malc@gentoo.org> stella-2.0.1.ebuild:
~amd64 - bug #115715
diff --git a/games-emulation/stella/Manifest b/games-emulation/stella/Manifest
index 80b9686d7fb6..b9993e37f9a5 100644
--- a/games-emulation/stella/Manifest
+++ b/games-emulation/stella/Manifest
@@ -1,6 +1,8 @@
MD5 724bc3ff34b66973b74a4ab1f1dcbb57 ChangeLog 2192
MD5 bf8549c6a110987d2861afe3d1cbb205 files/digest-stella-1.4.2 68
MD5 78a370769bf849d9d3b7771e204f6d7a files/digest-stella-2.0.1 69
+MD5 69bd65ccb905c2f378a86a1c9621bf9a files/digest-stella-2.1 67
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 e863cc9ae62eb20dd3c83e07a15ef6a4 stella-1.4.2.ebuild 1141
MD5 d5c0468e81769bee08a77ce1594f91b3 stella-2.0.1.ebuild 1288
+MD5 d5c0468e81769bee08a77ce1594f91b3 stella-2.1.ebuild 1288
diff --git a/games-emulation/stella/files/digest-stella-2.1 b/games-emulation/stella/files/digest-stella-2.1
new file mode 100644
index 000000000000..320d7899111f
--- /dev/null
+++ b/games-emulation/stella/files/digest-stella-2.1
@@ -0,0 +1 @@
+MD5 74250daa816f044e97684640f750f140 stella-2.1-src.tar.gz 1062215
diff --git a/games-emulation/stella/stella-2.1.ebuild b/games-emulation/stella/stella-2.1.ebuild
new file mode 100644
index 000000000000..42becdde64a5
--- /dev/null
+++ b/games-emulation/stella/stella-2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-2.1.ebuild,v 1.1 2006/01/31 22:27:25 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ media-libs/libpng
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:/etc:${GAMES_SYSCONFDIR}:g" \
+ src/macosx/OSystemMACOSX.cxx \
+ src/unix/OSystemUNIX.cxx \
+ src/unix/stella.spec \
+ src/psp/OSystemPSP.cxx \
+ docs/stella.html \
+ docs/debugger.html \
+ Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "/icons/d" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ doicon src/common/stella.xpm
+ make_desktop_entry stella Stella stella.xpm
+ prepgamesdirs
+}