summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-03-26 08:44:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-03-26 08:44:16 +0000
commit693227568bf6c02e2eff739f950a03c87876d639 (patch)
tree4adbb3d2c04f92b799dbcce03f6f0496dbd40180 /games-emulation
parentsync with xmame ebuild (diff)
downloadgentoo-2-693227568bf6c02e2eff739f950a03c87876d639.tar.gz
gentoo-2-693227568bf6c02e2eff739f950a03c87876d639.tar.bz2
gentoo-2-693227568bf6c02e2eff739f950a03c87876d639.zip
check for existence of utilities before installing them (bug #127601)
(Portage version: 2.1_pre6-r7)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/xmame/ChangeLog5
-rw-r--r--games-emulation/xmame/xmame-0.104.ebuild13
2 files changed, 10 insertions, 8 deletions
diff --git a/games-emulation/xmame/ChangeLog b/games-emulation/xmame/ChangeLog
index 47e6b71c40f8..af13c32faee3 100644
--- a/games-emulation/xmame/ChangeLog
+++ b/games-emulation/xmame/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/xmame
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.63 2006/03/24 21:44:57 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.64 2006/03/26 08:44:15 mr_bones_ Exp $
+
+ 26 Mar 2006; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.104.ebuild:
+ check for existence of utilities before installing them (bug #127601)
24 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org> xmame-0.83.1.ebuild,
-xmame-0.103.ebuild:
diff --git a/games-emulation/xmame/xmame-0.104.ebuild b/games-emulation/xmame/xmame-0.104.ebuild
index 627b104da580..487e7114fe41 100644
--- a/games-emulation/xmame/xmame-0.104.ebuild
+++ b/games-emulation/xmame/xmame-0.104.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.104.ebuild,v 1.2 2006/03/23 03:19:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.104.ebuild,v 1.3 2006/03/26 08:44:16 mr_bones_ Exp $
inherit flag-o-matic toolchain-funcs eutils games
@@ -173,7 +173,7 @@ src_compile() {
src_install() {
local disp=0, f
- local utils="chdman imgtool dat2html"
+ local utils="chdman imgtool dat2html romcmp xml2info"
sed -i \
-e "s:^PREFIX.*:PREFIX=${D}/usr:" \
@@ -202,12 +202,11 @@ src_install() {
exeinto "${GAMES_LIBDIR}/${PN}"
for f in $utils
do
- doexe $f || die "doexe failed"
- rm -f "${D}${GAMES_BINDIR}"/$f 2> /dev/null
+ if [[ -f "${D}${GAMES_BINDIR}"/$f ]] ; then
+ doexe $f || die "doexe failed"
+ rm -f "${D}${GAMES_BINDIR}"/$f 2> /dev/null
+ fi
done
- if [[ ${PN} == "xmame" ]] ; then
- doexe xml2info || die "doexe failed"
- fi
insinto "${GAMES_DATADIR}/${PN}"
doins -r ctrlr || die "doins failed"