summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-07-13 21:57:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-07-13 21:57:09 +0000
commit77fa6382b450a1a352b44daf03402feeb04387f2 (patch)
tree947b50384c06a298e730029882ce2bc383a27354 /games-emulation
parentChanged dependency on dvb according to Bug #98672 (diff)
downloadgentoo-2-77fa6382b450a1a352b44daf03402feeb04387f2.tar.gz
gentoo-2-77fa6382b450a1a352b44daf03402feeb04387f2.tar.bz2
gentoo-2-77fa6382b450a1a352b44daf03402feeb04387f2.zip
call games_pkg_setup more; error check sed; use default src_compile
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/nestra/ChangeLog6
-rw-r--r--games-emulation/nestra/nestra-0.66-r1.ebuild16
2 files changed, 12 insertions, 10 deletions
diff --git a/games-emulation/nestra/ChangeLog b/games-emulation/nestra/ChangeLog
index 5761f01fe5ae..8dec2d657ff8 100644
--- a/games-emulation/nestra/ChangeLog
+++ b/games-emulation/nestra/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/nestra
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/ChangeLog,v 1.6 2005/07/13 21:48:05 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/ChangeLog,v 1.7 2005/07/13 21:57:09 mr_bones_ Exp $
+
+ 13 Jul 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ nestra-0.66-r1.ebuild:
+ call games_pkg_setup more; error check sed; use default src_compile
13 Jul 2005; Simon Stelling <blubb@gentoo.org> nestra-0.66-r1.ebuild:
fixed bug 94871
diff --git a/games-emulation/nestra/nestra-0.66-r1.ebuild b/games-emulation/nestra/nestra-0.66-r1.ebuild
index c16d2b9cedad..411b62e0abaa 100644
--- a/games-emulation/nestra/nestra-0.66-r1.ebuild
+++ b/games-emulation/nestra/nestra-0.66-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.8 2005/07/13 21:48:05 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.9 2005/07/13 21:57:09 mr_bones_ Exp $
inherit eutils toolchain-funcs flag-o-matic games
@@ -22,6 +22,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}
pkg_setup() {
+ games_pkg_setup
use amd64 || return 0
export ABI=x86
if has_m32 ; then
@@ -34,7 +35,6 @@ pkg_setup() {
eerror " USE=multilib FEATURES=-sandbox"
die "Cannot produce 32bit code"
fi
- games_pkg_setup
}
src_unpack() {
@@ -45,18 +45,16 @@ src_unpack() {
-e 's:-O2 ::' \
-e "s:ld:$(tc-getLD) ${LDFLAGS}:" \
-e "s:gcc:$(tc-getCC) ${CFLAGS}:" Makefile \
- || die "sed Makefile failed"
-
+ || die "sed failed"
+
#94871
if use amd64 ; then
- sed -i -e "s:-L/usr/X11R6/lib:-L/emul/linux/x86/usr/lib32:" Makefile
+ sed -i \
+ -e "s:-L/usr/X11R6/lib:-L/emul/linux/x86/usr/lib32:" Makefile \
+ || die "sed failed"
fi
}
-src_compile() {
- emake || die "emake failed"
-}
-
src_install() {
dogamesbin nestra || die "dogamesbin failed"
dodoc BUGS CHANGES README