summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-06 19:53:05 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-06 19:53:05 +0000
commit7c9be69242faedabec942e408a9d2c5ebf8fb029 (patch)
tree0a8192138e60913fd1ec0d3881ec9f56023f0cbf /games-emulation
parentStable on amd64 wrt bug 171428 (diff)
downloadgentoo-2-7c9be69242faedabec942e408a9d2c5ebf8fb029.tar.gz
gentoo-2-7c9be69242faedabec942e408a9d2c5ebf8fb029.tar.bz2
gentoo-2-7c9be69242faedabec942e408a9d2c5ebf8fb029.zip
use games_get_libdir
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild b/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild
index 858180972238..313a21801b8a 100644
--- a/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild
+++ b/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild,v 1.4 2006/09/26 18:50:15 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild,v 1.5 2007/04/06 19:53:05 nyhm Exp $
inherit eutils games
@@ -20,7 +20,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/CDVDiso${PV//.}
src_unpack() {
- unrar x -idq "${DISTDIR}"/${A} || die
+ unpack ${A}
cd "${S}"
sed -i \
-e 's:-O2 -fomit-frame-pointer:$(OPTFLAGS):' \
@@ -37,9 +37,9 @@ src_compile() {
src_install() {
dodoc ReadMe.txt
cd src/Linux
- exeinto "${GAMES_LIBDIR}"/ps2emu/plugins
+ exeinto "$(games_get_libdir)"/ps2emu/plugins
newexe libCDVDiso.so libCDVDiso-${PV}.so || die
- exeinto "${GAMES_LIBDIR}"/ps2emu/cfg
+ exeinto "$(games_get_libdir)"/ps2emu/cfg
doexe cfgCDVDiso || die
prepgamesdirs
}