summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-12-31 07:53:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-12-31 07:53:54 +0000
commit96a85cd267e6fa53eda3548c923fdc9bd058cbf7 (patch)
treef82509c57658d537697b09f29f2a9077ac34b851 /games-emulation
parentMark arm64/m68k/s390/sh stable. (diff)
downloadgentoo-2-96a85cd267e6fa53eda3548c923fdc9bd058cbf7.tar.gz
gentoo-2-96a85cd267e6fa53eda3548c923fdc9bd058cbf7.tar.bz2
gentoo-2-96a85cd267e6fa53eda3548c923fdc9bd058cbf7.zip
version bump (bug #466382); create menu entry (bug #499938)
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fceux/ChangeLog11
-rw-r--r--games-emulation/fceux/fceux-2.2.2.ebuild49
-rw-r--r--games-emulation/fceux/files/fceux-2.1.5-gcc46.patch5
-rw-r--r--games-emulation/fceux/files/fceux-2.1.5-gcc47.patch4
-rw-r--r--games-emulation/fceux/files/fceux-2.1.5-underlink.patch4
-rw-r--r--games-emulation/fceux/files/fceux-2.2.2-warnings.patch33
6 files changed, 97 insertions, 9 deletions
diff --git a/games-emulation/fceux/ChangeLog b/games-emulation/fceux/ChangeLog
index 5f1ff055efcf..6679dd0e9099 100644
--- a/games-emulation/fceux/ChangeLog
+++ b/games-emulation/fceux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-emulation/fceux
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.17 2013/01/30 22:28:01 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.18 2014/12/31 07:53:54 mr_bones_ Exp $
+
+*fceux-2.2.2 (31 Dec 2014)
+
+ 31 Dec 2014; Michael Sterrett <mr_bones_@gentoo.org> +fceux-2.2.2.ebuild,
+ +files/fceux-2.2.2-warnings.patch, files/fceux-2.1.5-gcc46.patch,
+ files/fceux-2.1.5-gcc47.patch, files/fceux-2.1.5-underlink.patch:
+ version bump (bug #466382); create menu entry (bug #499938)
30 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> -fceux-2.1.4a.ebuild,
-files/fceux-2.1.4a-ovflfix.patch, -files/fceux-2.1.4a-underlink.patch:
diff --git a/games-emulation/fceux/fceux-2.2.2.ebuild b/games-emulation/fceux/fceux-2.2.2.ebuild
new file mode 100644
index 000000000000..576d4f0042a3
--- /dev/null
+++ b/games-emulation/fceux/fceux-2.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/fceux-2.2.2.ebuild,v 1.1 2014/12/31 07:53:54 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils scons-utils games
+
+DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
+HOMEPAGE="http://fceux.com/"
+SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk +lua +opengl"
+
+DEPEND="lua? ( dev-lang/lua )
+ media-libs/libsdl[opengl?,video]
+ opengl? ( virtual/opengl )
+ gtk? ( x11-libs/gtk+:3 )
+ sys-libs/zlib[minizip]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-warnings.patch
+}
+
+src_compile() {
+ escons \
+ GTK=0 \
+ CREATE_AVI=1 \
+ SYSTEM_LUA=1 \
+ SYSTEM_MINIZIP=1 \
+ $(use_scons gtk GTK3) \
+ $(use_scons opengl OPENGL) \
+ $(use_scons lua LUA)
+}
+
+src_install() {
+ dogamesbin bin/fceux
+
+ doman documentation/fceux.6
+ docompress -x /usr/share/doc/${PF}/documentation /usr/share/doc/${PF}/fceux.chm
+ dodoc -r Authors changelog.txt TODO-SDL bin/fceux.chm documentation
+ rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
+ make_desktop_entry fceux FCEUX
+ doicon fceux.png
+ prepgamesdirs
+}
diff --git a/games-emulation/fceux/files/fceux-2.1.5-gcc46.patch b/games-emulation/fceux/files/fceux-2.1.5-gcc46.patch
index 90dacf4bb4a8..8062f946518a 100644
--- a/games-emulation/fceux/files/fceux-2.1.5-gcc46.patch
+++ b/games-emulation/fceux/files/fceux-2.1.5-gcc46.patch
@@ -1,6 +1,5 @@
-diff -Naur a/fceu2.1.5/src/file.cpp b/fceu2.1.5/src/file.cpp
---- a/fceu2.1.5/src/file.cpp 2010-09-19 00:05:09.000000000 +0000
-+++ b/fceu2.1.5/src/file.cpp 2012-03-01 19:21:25.856204727 +0000
+--- a/fceu2.1.5/src/file.cpp
++++ b/fceu2.1.5/src/file.cpp
@@ -310,7 +310,7 @@
if(magic==0x088b1f) {
// maybe gzip...
diff --git a/games-emulation/fceux/files/fceux-2.1.5-gcc47.patch b/games-emulation/fceux/files/fceux-2.1.5-gcc47.patch
index 0b15cc89ad5c..de32c5f35b73 100644
--- a/games-emulation/fceux/files/fceux-2.1.5-gcc47.patch
+++ b/games-emulation/fceux/files/fceux-2.1.5-gcc47.patch
@@ -1,5 +1,5 @@
---- src/utils/endian.h.old 2012-10-26 09:07:24.000000000 +0200
-+++ src/utils/endian.h 2012-10-26 09:08:25.000000000 +0200
+--- src/utils/endian.h.old
++++ src/utils/endian.h
@@ -93,19 +93,6 @@
}
}
diff --git a/games-emulation/fceux/files/fceux-2.1.5-underlink.patch b/games-emulation/fceux/files/fceux-2.1.5-underlink.patch
index b45730738ac0..9e98967227d4 100644
--- a/games-emulation/fceux/files/fceux-2.1.5-underlink.patch
+++ b/games-emulation/fceux/files/fceux-2.1.5-underlink.patch
@@ -1,5 +1,5 @@
---- SConstruct.org 2011-06-07 21:33:28.876609681 +0200
-+++ SConstruct 2011-06-07 21:34:11.420368249 +0200
+--- SConstruct.org
++++ SConstruct
@@ -70,6 +70,10 @@
env.ParseConfig('pkg-config --cflags --libs gtk+-3.0')
env.Append(CPPDEFINES=["_GTK3"])
diff --git a/games-emulation/fceux/files/fceux-2.2.2-warnings.patch b/games-emulation/fceux/files/fceux-2.2.2-warnings.patch
new file mode 100644
index 000000000000..f0af4631abda
--- /dev/null
+++ b/games-emulation/fceux/files/fceux-2.2.2-warnings.patch
@@ -0,0 +1,33 @@
+diff -ru fceux-2.2.2.orig/src/input.cpp fceux-2.2.2/src/input.cpp
+--- fceux-2.2.2.orig/src/input.cpp 2013-06-15 15:44:11.000000000 -0400
++++ fceux-2.2.2/src/input.cpp 2014-12-31 01:32:46.302001912 -0500
+@@ -1161,7 +1161,7 @@
+ // FIXME this will always evaluate to true, should this be
+ // if (*lastSavestateMade...) to check if it holds a string or just
+ // a '\0'?
+- if (lastSavestateMade && (undoSS || redoSS))
++ if (*lastSavestateMade && (undoSS || redoSS))
+ SwapSaveState();
+ }
+
+diff -ru fceux-2.2.2.orig/src/state.cpp fceux-2.2.2/src/state.cpp
+--- fceux-2.2.2.orig/src/state.cpp 2013-09-18 19:03:59.000000000 -0400
++++ fceux-2.2.2/src/state.cpp 2014-12-31 01:33:11.453155054 -0500
+@@ -1048,7 +1048,7 @@
+ //Both files must exist
+ //--------------------------------------------------------------------------------------------
+
+- if (!lastSavestateMade)
++ if (!*lastSavestateMade)
+ {
+ FCEUI_DispMessage("Can't Undo",0);
+ FCEUI_printf("Undo savestate was attempted but unsuccessful because there was not a recently used savestate.\n");
+@@ -1153,7 +1153,7 @@
+ void RedoLoadState()
+ {
+ if (!redoLS) return;
+- if (lastLoadstateMade && redoLS)
++ if (*lastLoadstateMade && redoLS)
+ {
+ FCEUSS_Load(lastLoadstateMade);
+ FCEUI_printf("Redoing %s\n",lastLoadstateMade);