summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-01-11 19:12:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-01-11 19:12:23 +0000
commit972d43a8a6801b64c7fb379318bbec91124b5346 (patch)
tree42b54861367f1da591c1fca6a23112fadddd9a9d /games-emulation
parentamd64 stable - #202181 (diff)
downloadgentoo-2-972d43a8a6801b64c7fb379318bbec91124b5346.tar.gz
gentoo-2-972d43a8a6801b64c7fb379318bbec91124b5346.tar.bz2
gentoo-2-972d43a8a6801b64c7fb379318bbec91124b5346.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/raine/ChangeLog9
-rw-r--r--games-emulation/raine/files/digest-raine-0.50.69
-rw-r--r--games-emulation/raine/raine-0.50.6.ebuild68
3 files changed, 84 insertions, 2 deletions
diff --git a/games-emulation/raine/ChangeLog b/games-emulation/raine/ChangeLog
index 3cbc3db1f428..1ce85724888d 100644
--- a/games-emulation/raine/ChangeLog
+++ b/games-emulation/raine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/raine
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.17 2007/10/02 09:37:10 opfer Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.18 2008/01/11 19:12:23 mr_bones_ Exp $
+
+*raine-0.50.6 (11 Jan 2008)
+
+ 11 Jan 2008; Michael Sterrett <mr_bones_@gentoo.org> +raine-0.50.6.ebuild:
+ version bump
02 Oct 2007; Christian Faulhammer <opfer@gentoo.org> raine-0.50.5.ebuild:
stable x86, bug 192909; adding media-libs/sdl-image and media-libs/sdl-ttf
diff --git a/games-emulation/raine/files/digest-raine-0.50.6 b/games-emulation/raine/files/digest-raine-0.50.6
new file mode 100644
index 000000000000..75c57ef4b42f
--- /dev/null
+++ b/games-emulation/raine/files/digest-raine-0.50.6
@@ -0,0 +1,9 @@
+MD5 3529c30187861c37af8e1ce544746b1e icons.zip 3641
+RMD160 002a5512dab68a76bd83b87528aa9b256074fde8 icons.zip 3641
+SHA256 18822c1b15a310c08e66d1597a6aaba650c36eb21a5a32b41fa5469d65ee6741 icons.zip 3641
+MD5 cec6e5ba7beeb2ece310c66fd55c7b4d rainedocs.zip 88671
+RMD160 7c782301d8b1115a2579ca95b9b6200e3a45d446 rainedocs.zip 88671
+SHA256 6cd173b8e348b8e5d4fd2e13d3663f4890b87dbe007fb2be76150b9fb5cb05b3 rainedocs.zip 88671
+MD5 755e8e28a8fb65aec53100dd33e2d354 raines-0.50.6.tar.bz2 1855489
+RMD160 039dd3635a080f7ae4b35945cc93feb8878860cd raines-0.50.6.tar.bz2 1855489
+SHA256 68071c76779409ed7d815a9d8832af21fb9acf621ca1dcbc80e29b25983a009a raines-0.50.6.tar.bz2 1855489
diff --git a/games-emulation/raine/raine-0.50.6.ebuild b/games-emulation/raine/raine-0.50.6.ebuild
new file mode 100644
index 000000000000..7a5724631e42
--- /dev/null
+++ b/games-emulation/raine/raine-0.50.6.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/raine-0.50.6.ebuild,v 1.1 2008/01/11 19:12:23 mr_bones_ Exp $
+
+inherit versionator games
+
+MY_PV=$(replace_version_separator 3 '-')
+
+DESCRIPTION="R A I N E M680x0 Arcade Emulation"
+HOMEPAGE="http://www.rainemu.com/"
+SRC_URI="http://www.rainemu.com/html/archive/raines-${MY_PV}.tar.bz2
+ http://www.rainemu.com/html/archive/rainedocs.zip
+ http://www.rainemu.com/html/archive/icons.zip"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static kde"
+
+RDEPEND="media-libs/allegro
+ media-libs/libsdl
+ sys-libs/zlib
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range -3)
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo > detect-cpu
+ echo > cpuinfo
+ sed -i \
+ -e "/prefix =/s:/usr::" \
+ -e "s:nasm -r:echo nasm:" \
+ -e "/bindir/s:=.*:=\$(DESTDIR)${GAMES_BINDIR}:" \
+ -e "/sharedir =/s:=.*:=\$(DESTDIR)${GAMES_DATADIR}:" \
+ -e "/mandir/s:=.*:=\$(DESTDIR)/usr/share/man/man6:" \
+ makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ local myopts=
+ use static \
+ && myopts="${myopts} STATIC=1" \
+ || myopts="${myopts} STATIC="
+ emake \
+ _MARCH="${CFLAGS}" \
+ ${myopts} || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ keepdir "${GAMES_DATADIR}"/${PN}/{roms,artwork,emudx}
+ dodoc "${WORKDIR}/raine.txt"
+
+ insinto /usr/share/icons
+ doins "${WORKDIR}/"*.png
+ if use kde ; then
+ insinto /usr/share/applnk/Games
+ doins "${FILESDIR}/Raine.desktop"
+ fi
+ prepgamesdirs
+}