summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-01 01:23:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-01 01:23:00 +0000
commitc6b00a915642cb0dd84f50ef97147557e6e6c7a0 (patch)
treedefa4d3ea628d8396f1c44d881b98f7cc825e1eb /games-emulation
parentStable sparc. (diff)
downloadgentoo-2-c6b00a915642cb0dd84f50ef97147557e6e6c7a0.tar.gz
gentoo-2-c6b00a915642cb0dd84f50ef97147557e6e6c7a0.tar.bz2
gentoo-2-c6b00a915642cb0dd84f50ef97147557e6e6c7a0.zip
version bump
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/Manifest2
-rw-r--r--games-emulation/advancemame/advancemame-0.88.0.ebuild82
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.88.01
4 files changed, 92 insertions, 1 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index 162b8352ddd5..17c5a9a7d5c6 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.19 2004/09/25 07:21:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.20 2004/12/01 01:23:00 mr_bones_ Exp $
+
+*advancemame-0.88.0 (30 Nov 2004)
+
+ 30 Nov 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +advancemame-0.88.0.ebuild:
+ version bump
*advancemame-0.87.0 (25 Sep 2004)
diff --git a/games-emulation/advancemame/Manifest b/games-emulation/advancemame/Manifest
index 4503311923fe..b30204ce0cc0 100644
--- a/games-emulation/advancemame/Manifest
+++ b/games-emulation/advancemame/Manifest
@@ -2,7 +2,9 @@ MD5 cfb931d2caa71723841dca77eccde082 ChangeLog 3770
MD5 c7a56ad2d4cb791e613869debc9e18df advancemame-0.86.0.ebuild 1823
MD5 ebee324f3a2e25e2d43962b10672d214 advancemame-0.87.0.ebuild 1942
MD5 972b8c9f939a33a7074e0819fb55455c metadata.xml 962
+MD5 ebee324f3a2e25e2d43962b10672d214 advancemame-0.88.0.ebuild 1942
MD5 a67ea9d0aba6813bf7099ba0533ba44d advancemame-0.85.0.ebuild 1820
MD5 cfcb101ca859965c03e4c39303d3c481 files/digest-advancemame-0.86.0 72
MD5 0fcd53e6dc55e784545e640310890175 files/digest-advancemame-0.85.0 72
MD5 2781f763e847a14eef2b5f3520b04231 files/digest-advancemame-0.87.0 72
+MD5 f43f9c3039884207b6e5fc1d91bb46cb files/digest-advancemame-0.88.0 72
diff --git a/games-emulation/advancemame/advancemame-0.88.0.ebuild b/games-emulation/advancemame/advancemame-0.88.0.ebuild
new file mode 100644
index 000000000000..640acc87ff15
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.88.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.88.0.ebuild,v 1.1 2004/12/01 01:23:00 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 xmame"
+SLOT="0"
+KEYWORDS="x86 ppc ~amd64"
+IUSE="alsa expat fbcon oss sdl slang static svga truetype zlib"
+
+RDEPEND="virtual/libc
+ app-arch/unzip
+ app-arch/zip
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ expat? ( >=dev-libs/expat-1.95.6 )
+ zlib? ( sys-libs/zlib )
+ truetype? ( media-libs/freetype )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ x86? ( >=dev-lang/nasm-0.98 )
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+
+ use x86 && \
+ ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ use sdl && \
+ ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && \
+ ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_compile() {
+ PATH="${PATH}:${T}"
+ egamesconf \
+ $(use_enable alsa) \
+ $(use_enable expat) \
+ $(use_enable fbcon fb) \
+ $(use_enable oss) \
+ $(use_enable sdl) \
+ $(use_enable slang) \
+ $(use_enable static) \
+ $(use_enable svga svgalib) \
+ $(use_enable truetype freetype) \
+ $(use_enable zlib) \
+ $(use_enable x86 asm) \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local f
+
+ for f in adv* ; do
+ if [ -L "${f}" ] ; then
+ dogamesbin "${f}" || die "dogamesbin failed"
+ fi
+ done
+
+ insinto "${GAMES_DATADIR}/advance"
+ doins support/event.dat
+ keepdir "${GAMES_DATADIR}/advance/"{artwork,diff,image,rom,sample,snap}
+
+ dodoc HISTORY README RELEASE
+ cd doc
+ dodoc *.txt
+ dohtml *.html
+ for f in *.1 ; do
+ newman ${f} ${f/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.88.0 b/games-emulation/advancemame/files/digest-advancemame-0.88.0
new file mode 100644
index 000000000000..03d1c33fae94
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.88.0
@@ -0,0 +1 @@
+MD5 0d8ae3453451caa33011b3d5d8247fdd advancemame-0.88.0.tar.gz 13729600