summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-09-29 22:07:29 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-09-29 22:07:29 +0000
commitd36784d0a01bb07b8b3ebb4b0895b9203a7015a6 (patch)
tree1f9f71c7e69a2814debb2315c8fd044b749bf3eb /games-emulation
parentMarking sqlite3-ruby-1.3.1 ~ppc64 for bug 321283 (diff)
downloadgentoo-2-d36784d0a01bb07b8b3ebb4b0895b9203a7015a6.tar.gz
gentoo-2-d36784d0a01bb07b8b3ebb4b0895b9203a7015a6.tar.bz2
gentoo-2-d36784d0a01bb07b8b3ebb4b0895b9203a7015a6.zip
Respect LDFLAGS. Bug #338504
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dboxfe/ChangeLog6
-rw-r--r--games-emulation/dboxfe/dboxfe-0.1.3.ebuild6
-rw-r--r--games-emulation/dboxfe/files/dboxfe-0.1.3-ldflags.patch20
3 files changed, 29 insertions, 3 deletions
diff --git a/games-emulation/dboxfe/ChangeLog b/games-emulation/dboxfe/ChangeLog
index 4aeac8b010c5..5c0bffbd3956 100644
--- a/games-emulation/dboxfe/ChangeLog
+++ b/games-emulation/dboxfe/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/dboxfe
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dboxfe/ChangeLog,v 1.12 2010/09/18 16:29:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dboxfe/ChangeLog,v 1.13 2010/09/29 22:07:29 tupone Exp $
+
+ 29 Sep 2010; Tupone Alfredo <tupone@gentoo.org> dboxfe-0.1.3.ebuild,
+ +files/dboxfe-0.1.3-ldflags.patch:
+ Respect LDFLAGS. Bug #338504 by flameeyes@gentoo.org
18 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org> dboxfe-0.1.3.ebuild:
clean old atom
diff --git a/games-emulation/dboxfe/dboxfe-0.1.3.ebuild b/games-emulation/dboxfe/dboxfe-0.1.3.ebuild
index 709585a14578..681f514246ac 100644
--- a/games-emulation/dboxfe/dboxfe-0.1.3.ebuild
+++ b/games-emulation/dboxfe/dboxfe-0.1.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dboxfe/dboxfe-0.1.3.ebuild,v 1.7 2010/09/18 16:29:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dboxfe/dboxfe-0.1.3.ebuild,v 1.8 2010/09/29 22:07:29 tupone Exp $
-EAPI=1
+EAPI=2
inherit eutils qt4 games
DESCRIPTION="Creates and manages configuration files for DOSBox"
@@ -18,6 +18,8 @@ DEPEND="x11-libs/qt-gui:4"
RDEPEND="${DEPEND}
>=games-emulation/dosbox-0.65"
+PATCHES=( "${FILESDIR}"/${P}-ldflags.patch )
+
src_install() {
dogamesbin bin/dboxfe || die "dogamesbin failed"
dodoc TODO ChangeLog
diff --git a/games-emulation/dboxfe/files/dboxfe-0.1.3-ldflags.patch b/games-emulation/dboxfe/files/dboxfe-0.1.3-ldflags.patch
new file mode 100644
index 000000000000..6ceb1d2d5c29
--- /dev/null
+++ b/games-emulation/dboxfe/files/dboxfe-0.1.3-ldflags.patch
@@ -0,0 +1,20 @@
+--- dboxfe.pro.old 2010-09-29 23:53:38.000000000 +0200
++++ dboxfe.pro 2010-09-29 23:54:11.000000000 +0200
+@@ -83,6 +83,7 @@
+ # Unix/Linux settings
+ unix{
+ TARGET = dboxfe
++ QMAKE_LFLAGS += $(LDFLAGS)
+ #QMAKE_POST_LINK = strip -s bin/dboxfe
+ RCC_DIR = .unix/rcc
+ MOC_DIR += .unix/moc
+--- dboxfetray/dboxfetray.pro.old 2010-09-29 23:55:31.000000000 +0200
++++ dboxfetray/dboxfetray.pro 2010-09-29 23:56:12.000000000 +0200
+@@ -56,6 +56,7 @@
+ # Unix/Linux settings
+ unix{
+ TARGET = dboxfetray
++ QMAKE_LFLAGS += $(LDFLAGS)
+ #QMAKE_POST_LINK = strip -s bin/dboxfetray
+ RCC_DIR = .unix/rcc
+ MOC_DIR += .unix/moc