summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-29 05:16:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-29 05:16:35 +0000
commite4d1744e4dfb8f2a38ae90be1dc2a5dccfdeec90 (patch)
tree42ea3d6b75613e574bbbde8f780ca75013284927 /games-emulation
parentupstream recommends opengl and lua (diff)
downloadgentoo-2-e4d1744e4dfb8f2a38ae90be1dc2a5dccfdeec90.tar.gz
gentoo-2-e4d1744e4dfb8f2a38ae90be1dc2a5dccfdeec90.tar.bz2
gentoo-2-e4d1744e4dfb8f2a38ae90be1dc2a5dccfdeec90.zip
initial commit
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gfceux/ChangeLog10
-rw-r--r--games-emulation/gfceux/files/gfceux-2.1.1-gentoo.patch18
-rw-r--r--games-emulation/gfceux/gfceux-2.1.1.ebuild43
-rw-r--r--games-emulation/gfceux/metadata.xml5
4 files changed, 76 insertions, 0 deletions
diff --git a/games-emulation/gfceux/ChangeLog b/games-emulation/gfceux/ChangeLog
new file mode 100644
index 000000000000..826029c56dc3
--- /dev/null
+++ b/games-emulation/gfceux/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-emulation/gfceux
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gfceux/ChangeLog,v 1.1 2009/09/29 05:16:34 mr_bones_ Exp $
+
+*gfceux-2.1.1 (29 Sep 2009)
+
+ 29 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org> +gfceux-2.1.1.ebuild,
+ +files/gfceux-2.1.1-gentoo.patch, +metadata.xml:
+ intial commit
+
diff --git a/games-emulation/gfceux/files/gfceux-2.1.1-gentoo.patch b/games-emulation/gfceux/files/gfceux-2.1.1-gentoo.patch
new file mode 100644
index 000000000000..b8eee53a4b88
--- /dev/null
+++ b/games-emulation/gfceux/files/gfceux-2.1.1-gentoo.patch
@@ -0,0 +1,18 @@
+diff -ru gfceux.orig/src/main.py gfceux/src/main.py
+--- gfceux.orig/src/main.py 2009-04-29 01:09:52.000000000 -0400
++++ gfceux/src/main.py 2009-09-29 00:38:53.152619918 -0400
+@@ -279,12 +279,8 @@
+ def load_ui(self):
+ global widgets
+ """ Search for the glade XML file and load it """
+- # Check first in the directory of this script.
+- if os.path.isfile('data/gfceux.glade'):
+- glade_file = 'data/gfceux.glade'
+- # Then check to see if its installed on a *nix system
+- elif os.path.isfile(os.path.join(os.path.dirname(sys.argv[0]), '../share/gfceux/gfceux.glade')):
+- glade_file = os.path.join(os.path.dirname(sys.argv[0]), '../share/gfceux/gfceux.glade')
++ if os.path.isfile('/usr/share/gfceux/gfceux.glade'):
++ glade_file = '/usr/share/gfceux/gfceux.glade'
+ else:
+ print 'ERROR.'
+ print 'Could not find the glade UI file.'
diff --git a/games-emulation/gfceux/gfceux-2.1.1.ebuild b/games-emulation/gfceux/gfceux-2.1.1.ebuild
new file mode 100644
index 000000000000..92eda8baf23e
--- /dev/null
+++ b/games-emulation/gfceux/gfceux-2.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gfceux/gfceux-2.1.1.ebuild,v 1.1 2009/09/29 05:16:34 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils distutils games
+
+DESCRIPTION="A graphical frontend for the FCEUX emulator"
+HOMEPAGE="http://fceux.com"
+SRC_URI="mirror://sourceforge/fceultra/fceux-${PV}.src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.5
+ dev-python/pygtk"
+RDEPEND="${DEPEND}
+ games-emulation/fceux"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ python_version
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install \
+ --install-scripts="${GAMES_BINDIR}"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ distutils_pkg_postinst
+}
diff --git a/games-emulation/gfceux/metadata.xml b/games-emulation/gfceux/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-emulation/gfceux/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>