summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-06-20 20:28:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-06-20 20:28:23 +0000
commite80260b32b50cc7dc0ffc8b92c1211166b61baad (patch)
tree3bd017548e067bf99ba0fce4c25487ffa7d46cee /games-emulation
parentgnome-python-desktop blocks older gnome-python-extras. Bug #132596 (diff)
downloadgentoo-2-e80260b32b50cc7dc0ffc8b92c1211166b61baad.tar.gz
gentoo-2-e80260b32b50cc7dc0ffc8b92c1211166b61baad.tar.bz2
gentoo-2-e80260b32b50cc7dc0ffc8b92c1211166b61baad.zip
version bump
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gngeo/ChangeLog8
-rw-r--r--games-emulation/gngeo/files/digest-gngeo-0.6.123
-rw-r--r--games-emulation/gngeo/files/gngeo-0.6.12-execstacks.patch118
-rw-r--r--games-emulation/gngeo/gngeo-0.6.12.ebuild42
4 files changed, 170 insertions, 1 deletions
diff --git a/games-emulation/gngeo/ChangeLog b/games-emulation/gngeo/ChangeLog
index 3bbaa1ed79b7..d457117b9130 100644
--- a/games-emulation/gngeo/ChangeLog
+++ b/games-emulation/gngeo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/gngeo
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/ChangeLog,v 1.13 2006/05/21 03:44:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/ChangeLog,v 1.14 2006/06/20 20:28:22 mr_bones_ Exp $
+
+*gngeo-0.6.12 (20 Jun 2006)
+
+ 20 Jun 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/gngeo-0.6.12-execstacks.patch, +gngeo-0.6.12.ebuild:
+ version bump
21 May 2006; Michael Sterrett <mr_bones_@gentoo.org> gngeo-0.6.11.ebuild:
force newer gcc for bug #128587
diff --git a/games-emulation/gngeo/files/digest-gngeo-0.6.12 b/games-emulation/gngeo/files/digest-gngeo-0.6.12
new file mode 100644
index 000000000000..38eace2f6c3e
--- /dev/null
+++ b/games-emulation/gngeo/files/digest-gngeo-0.6.12
@@ -0,0 +1,3 @@
+MD5 cad0232606b7c4f0449445ba0dea080f gngeo-0.6.12.tar.gz 826845
+RMD160 a5c0a70b4b8b53cc660d18d227cd0da2eeda54d2 gngeo-0.6.12.tar.gz 826845
+SHA256 f67cd32baf54286f6c6f75655847ebb86266a198c5292a3116db595ad0c091be gngeo-0.6.12.tar.gz 826845
diff --git a/games-emulation/gngeo/files/gngeo-0.6.12-execstacks.patch b/games-emulation/gngeo/files/gngeo-0.6.12-execstacks.patch
new file mode 100644
index 000000000000..a2b18cbdcbad
--- /dev/null
+++ b/games-emulation/gngeo/files/gngeo-0.6.12-execstacks.patch
@@ -0,0 +1,118 @@
+--- src/memcpy.S
++++ src/memcpy.S
+@@ -495,4 +495,8 @@
+
+ Lmemcpy_bsrcul1l4:
+ add r1, r1, #1
+-b Lmemcpy_bl4
+\ No newline at end of file
++b Lmemcpy_bl4
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",@progbits
++#endif
+--- src/video_arm.s
++++ src/video_arm.s
+@@ -763,3 +763,7 @@
+ ldmfd sp!, {r4-r10} @ restore the registers
+ mov pc, lr @ return
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",@progbits
++#endif
++
+--- ./src/effect/hq3x16.asm
++++ ./src/effect/hq3x16.asm
+@@ -2520,3 +2520,7 @@
+ dd ..@cross8, ..@flag0, ..@flag0, ..@flag0,
+ dd ..@flag0, ..@flag0, ..@flag0, ..@flag0
+
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/effect/2xsaimmx.asm
++++ ./src/effect/2xsaimmx.asm
+@@ -2107,3 +2107,7 @@
+ final1b resb 8
+ final2a resb 8
+ final2b resb 8
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/effect/effect_i386.asm
++++ ./src/effect/effect_i386.asm
+@@ -88,3 +88,7 @@
+ emms
+
+ endproc
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/effect/hq2x16.asm
++++ ./src/effect/hq2x16.asm
+@@ -1935,3 +1935,7 @@
+ dd ..@cross8, ..@flag0, ..@flag0, ..@flag0,
+ dd ..@flag0, ..@flag0, ..@flag0, ..@flag0
+
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/video_i386.asm
++++ ./src/video_i386.asm
+@@ -86,3 +86,7 @@
+
+ popa
+ endproc
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+
+ *Note: there are three underscores here on purpose ... otherwise the strip_
+ script will produce _OUTPUT_FORMAT__ instead of __OUTPUT_FORMAT__
+--- ./src/raze/raze.asm
++++ ./src/raze/raze.asm
+@@ -4259,3 +4259,6 @@
+
+ ;- the end ------------------------------------------------------------------;
+
++%ifidn ___OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/screen_i386.asm
++++ ./src/screen_i386.asm
+@@ -96,3 +96,6 @@
+ endproc
+
+
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- src/raze/Makefile.in
++++ src/raze/Makefile.in
+@@ -238,7 +238,7 @@
+ ./strip_ raze.reg raze.regu
+
+ raze2.asm: raze.asmu raze.incu raze.regu
+- nasm -w+orphan-labels -e $< -o $@
++ nasm -w+orphan-labels -f elf -e $< -o $@
+
+ # This assembles the file, once it's been pre-processed
+ raze.o: raze2.asm
+--- src/star/star.c
++++ src/star/star.c
+@@ -2431,6 +2431,10 @@
+ */
+ static void suffixes(void) {
+ emit("end\n");
++
++ emit("%%ifidn ___OUTPUT_FORMAT__,elf\n");
++ emit("section .note.GNU-stack noalloc noexec nowrite progbits\n");
++ emit("%%endif\n");
+ }
+
+ /****************************************************************************
diff --git a/games-emulation/gngeo/gngeo-0.6.12.ebuild b/games-emulation/gngeo/gngeo-0.6.12.ebuild
new file mode 100644
index 000000000000..8e3b71aeec94
--- /dev/null
+++ b/games-emulation/gngeo/gngeo-0.6.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/gngeo-0.6.12.ebuild,v 1.1 2006/06/20 20:28:23 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="A NeoGeo emulator"
+HOMEPAGE="http://m.peponas.free.fr/gngeo/"
+SRC_URI="http://m.peponas.free.fr/gngeo/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ sys-libs/zlib
+ media-libs/sdl-image
+ >=media-libs/libsdl-1.2"
+# gcc-3.3 gets it wrong - bug #128587
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-3.4
+ x86? ( >=dev-lang/nasm-0.98 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-execstacks.patch"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README sample_gngeorc
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "A licensed NeoGeo BIOS copy is required to run the emulator."
+ echo
+}