summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-05-08 05:11:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-05-08 05:11:38 +0000
commitc88bd2d07686b8ab363648d68b7a2ad32968def9 (patch)
treee8ffcd146e3d6b3ce63a7845866bc6bc3c3d5da2 /games-engines/frobtads
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-c88bd2d07686b8ab363648d68b7a2ad32968def9.tar.gz
gentoo-2-c88bd2d07686b8ab363648d68b7a2ad32968def9.tar.bz2
gentoo-2-c88bd2d07686b8ab363648d68b7a2ad32968def9.zip
version bump (bug #268971)
(Portage version: 2.1.6.11/cvs/Linux i686)
Diffstat (limited to 'games-engines/frobtads')
-rw-r--r--games-engines/frobtads/ChangeLog10
-rw-r--r--games-engines/frobtads/frobtads-0.13.ebuild57
2 files changed, 65 insertions, 2 deletions
diff --git a/games-engines/frobtads/ChangeLog b/games-engines/frobtads/ChangeLog
index 988448ec390e..47e5ddaa2c2c 100644
--- a/games-engines/frobtads/ChangeLog
+++ b/games-engines/frobtads/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/frobtads
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/frobtads/ChangeLog,v 1.1 2008/09/05 06:39:00 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/frobtads/ChangeLog,v 1.2 2009/05/08 05:11:38 mr_bones_ Exp $
+
+*frobtads-0.13 (08 May 2009)
+
+ 08 May 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +frobtads-0.13.ebuild:
+ version bump (bug #268971)
*frobtads-0.12 (05 Sep 2008)
diff --git a/games-engines/frobtads/frobtads-0.13.ebuild b/games-engines/frobtads/frobtads-0.13.ebuild
new file mode 100644
index 000000000000..7df95908c0b3
--- /dev/null
+++ b/games-engines/frobtads/frobtads-0.13.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/frobtads/frobtads-0.13.ebuild,v 1.1 2009/05/08 05:11:38 mr_bones_ Exp $
+
+EAPI=2
+inherit flag-o-matic games
+
+DESCRIPTION="Curses-based interpreter and development tools for TADS 2 and TADS 3 text adventures"
+HOMEPAGE="http://www.tads.org/frobtads.htm"
+SRC_URI="http://www.tads.org/frobtads/${P}.tar.gz
+ tads2compiler? ( http://www.tads.org/frobtads/${PN}-t2compiler-${PV}.tar.gz )
+ tads3compiler? ( http://www.tads.org/frobtads/${PN}-t3compiler-${PV}.tar.gz )"
+
+LICENSE="TADS2 TADS3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tads2compiler tads3compiler"
+
+RESTRICT="!tads3compiler? ( test )"
+
+DEPEND="sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ if use tads2compiler; then
+ mv t2compiler/* "${S}"/t2compiler || die "mv t2compiler failed"
+ fi
+ if use tads3compiler; then
+ mv t3compiler/* "${S}"/t3compiler || die "mv t3compiler failed"
+ fi
+}
+
+src_configure() {
+ append-cxxflags -fno-strict-aliasing
+ egamesconf $(use_enable debug t3debug) || die "egamesconf failed"
+}
+
+src_test() {
+ if use debug; then
+ emake -j1 check || die "TADS 3 compiler test suite failed"
+ fi
+
+ emake -j1 sample || die "Failed to build test game"
+ ./frob -i plain -p samples/sample.t3 <<- END_FROB_TEST
+ save
+ testsave.sav
+ restore
+ testsave.sav
+ END_FROB_TEST
+ [[ $? -eq 0 ]] || die "Failed to run test game"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc doc/{AUTHORS,BUGS,ChangeLog,NEWS,README,SRC_GUIDELINES,THANKS}
+ prepgamesdirs
+}