summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-08-22 16:29:24 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-08-22 16:29:24 +0000
commit7a142a6cfb0d511562a20a0ceb46ee0363adf65b (patch)
tree87633f368af63fc35807f9b4dcc25dc65bc1a51a /games-engines
parenthandle new x32 chost (diff)
downloadgentoo-2-7a142a6cfb0d511562a20a0ceb46ee0363adf65b.tar.gz
gentoo-2-7a142a6cfb0d511562a20a0ceb46ee0363adf65b.tar.bz2
gentoo-2-7a142a6cfb0d511562a20a0ceb46ee0363adf65b.zip
rework ebuild, also fix #432304 and #432306
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/gargoyle/ChangeLog5
-rw-r--r--games-engines/gargoyle/gargoyle-2011.1.ebuild62
2 files changed, 46 insertions, 21 deletions
diff --git a/games-engines/gargoyle/ChangeLog b/games-engines/gargoyle/ChangeLog
index 2311a833f470..8cb9889c65ca 100644
--- a/games-engines/gargoyle/ChangeLog
+++ b/games-engines/gargoyle/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-engines/gargoyle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.19 2012/08/21 19:18:49 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.20 2012/08/22 16:29:24 hasufell Exp $
+
+ 22 Aug 2012; Julian Ospald <hasufell@gentoo.org> gargoyle-2011.1.ebuild:
+ rework ebuild, also fix #432304 and #432306
21 Aug 2012; Julian Ospald <hasufell@gentoo.org> gargoyle-2011.1.ebuild,
+files/gargoyle-2011.1-desktopfile.patch:
diff --git a/games-engines/gargoyle/gargoyle-2011.1.ebuild b/games-engines/gargoyle/gargoyle-2011.1.ebuild
index 2255b3c62325..374ca40591cd 100644
--- a/games-engines/gargoyle/gargoyle-2011.1.ebuild
+++ b/games-engines/gargoyle/gargoyle-2011.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-2011.1.ebuild,v 1.4 2012/08/21 19:18:49 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-2011.1.ebuild,v 1.5 2012/08/22 16:29:24 hasufell Exp $
# Regarding licenses: libgarglk is licensed under the GPLv2. Bundled
# interpreters are licensed under GPLv2, BSD or MIT license, except:
@@ -9,8 +9,8 @@
# Since we don't compile or install any of the bundled fonts, their licenses
# don't apply. (Fonts are installed through dependencies instead.)
-EAPI=3
-inherit eutils multiprocessing toolchain-funcs games
+EAPI=4
+inherit eutils multiprocessing toolchain-funcs gnome2-utils games
DESCRIPTION="An Interactive Fiction (IF) player supporting all major formats"
HOMEPAGE="http://ccxvii.net/gargoyle/"
@@ -21,45 +21,54 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="media-libs/freetype:2
- virtual/jpeg
- media-libs/libpng
- media-fonts/liberation-fonts
+RDEPEND="
>=media-fonts/libertine-ttf-5
- sys-libs/zlib
- x11-libs/gtk+:2
+ media-fonts/liberation-fonts
+ media-libs/freetype:2
+ media-libs/libpng:0
media-libs/sdl-mixer
- media-libs/sdl-sound[modplug,mp3,vorbis]"
-
+ media-libs/sdl-sound[modplug,mp3,vorbis]
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/gtk+:2"
DEPEND="${RDEPEND}
app-arch/unzip
dev-util/ftjam
virtual/pkgconfig"
+S=${WORKDIR}
+
src_prepare() {
# Substitute custom CFLAGS/LDFLAGS.
sed -i -e \
"/^\s*OPTIM = / {
- s/ \(-O.*\)\? ;/ ${CFLAGS} ;/
+ s/ \(-O.*\)\? ;/ ;/
a LINKFLAGS = ${LDFLAGS} ;
a SHRLINKFLAGS = ${LDFLAGS} ;
}" Jamrules || die
# Don't link against libraries used indirectly through SDL_sound.
- sed -i -e "/GARGLKLIBS/s/-lsmpeg -lvorbisfile//g" Jamrules
+ sed -i -e "/GARGLKLIBS/s/-lsmpeg -lvorbisfile//g" Jamrules || die
# Convert garglk.ini to UNIX format.
edos2unix garglk/garglk.ini
# The font name of Linux Libertine changed in version 5.
- sed -i -e 's/Linux Libertine O/Linux Libertine/g' garglk/garglk.ini
+ sed -i -e 's/Linux Libertine O/Linux Libertine/g' garglk/garglk.ini || die
epatch "${FILESDIR}"/${P}-desktopfile.patch
}
src_compile() {
+ # build system messes up flags and toolchain completely
+ # append flags to compiler commands to have consistent behavior
jam \
-sAR="$(tc-getAR) cru" \
+ -sCC="$(tc-getCC) ${CFLAGS}" \
+ -sCCFLAGS="" \
+ -sC++="$(tc-getCXX) ${CXXFLAGS}" \
+ -sCXX="$(tc-getCXX) ${CXXFLAGS}" \
+ -sC++FLAGS="" \
-sGARGLKINI="${GAMES_SYSCONFDIR}/garglk.ini" \
-sUSESDL=yes \
-sBUNDLEFONTS=no \
@@ -78,24 +87,37 @@ src_install() {
# Install config file.
insinto "${GAMES_SYSCONFDIR}"
- newins garglk/garglk.ini garglk.ini || die
+ newins garglk/garglk.ini garglk.ini
# Install application entry and icon.
- insinto /usr/share/applications
- doins garglk/${PN}.desktop || die
- doicon garglk/${PN}-house.png || die
+ domenu garglk/${PN}.desktop
+ doicon -s 32 garglk/${PN}-house.png
# Symlink binaries to avoid name clashes.
for terp in advsys agility alan2 alan3 frotz geas git glulxe hugo jacl \
level9 magnetic nitfol scare tadsr
do
dosym "${GAMES_PREFIX}/libexec/${PN}/${terp}" \
- "${GAMES_BINDIR}/${PN}-${terp}" || die
+ "${GAMES_BINDIR}/${PN}-${terp}"
done
# Also symlink the main binary since it resides in libexec.
dosym "${GAMES_PREFIX}/libexec/${PN}/${PN}" \
- "${GAMES_BINDIR}/${PN}" || die
+ "${GAMES_BINDIR}/${PN}"
prepgamesdirs
}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}