summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-30 21:13:27 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-30 21:13:27 +0000
commitb3646de30c2f820d7a99def6134055ce684c365f (patch)
treeeac47720261f1458d5a7bf4dcd3cd29abcbd9c17 /games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild
parentVersion bump (diff)
downloadgentoo-2-b3646de30c2f820d7a99def6134055ce684c365f.tar.gz
gentoo-2-b3646de30c2f820d7a99def6134055ce684c365f.tar.bz2
gentoo-2-b3646de30c2f820d7a99def6134055ce684c365f.zip
Added new revision for testing which uses the brand-spankin-new games-mods.eclass to reduce ebuild code. This also closes bug #133996 since it installs into its own directory.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild')
-rw-r--r--games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild b/games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild
new file mode 100644
index 000000000000..310da68aebc8
--- /dev/null
+++ b/games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild,v 1.1 2006/10/30 21:13:27 wolf31o2 Exp $
+
+MOD_DESC="sticks flashlights to your machinegun and shotgun"
+MOD_NAME="Duct Tape"
+MOD_DIR="ducttape"
+
+inherit games games-mods
+
+HOMEPAGE="http://ducttape.glenmurphy.com/"
+SRC_URI="http://ducttape.glenmurphy.com/ducttape${PV}.zip"
+
+LICENSE="as-is"
+
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="games-fps/doom3"
+
+S=${WORKDIR}
+
+src_unpack() {
+ games-mods_src_unpack
+ mkdir -p ${MOD_DIR}
+ mv pak008.pk4 ${MOD_DIR} || die
+}
+
+pkg_postinst() {
+ games-mods_pkg_postinst
+
+ elog "To use old saved games with this mod, run:"
+ echo
+ elog "mkdir -p ~/.doom3/ducttape"
+ elog "cp -r ~/.doom3/base/savegames ~/.doom3/ducttape"
+ echo
+}