summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-07-27 10:24:01 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-07-27 10:24:01 +0000
commit195228c11aab14d7701c6d26afab393772e79ecd (patch)
tree163bec41d1a38559be29291b561b332c4d79777d /games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
parentFix CFLAGS parameters. Should fix build on gcc-4.6. Fixes bug #376567. (diff)
downloadgentoo-2-195228c11aab14d7701c6d26afab393772e79ecd.tar.gz
gentoo-2-195228c11aab14d7701c6d26afab393772e79ecd.tar.bz2
gentoo-2-195228c11aab14d7701c6d26afab393772e79ecd.zip
Fix installing with qmax. Bug #219976
(Portage version: 2.1.10.7/cvs/Linux i686)
Diffstat (limited to 'games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild')
-rw-r--r--games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild b/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
index 3144a9619d74..cf3b284911c3 100644
--- a/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
+++ b/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.22 2010/09/15 10:56:43 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.23 2011/07/27 10:24:01 tupone Exp $
EAPI=2
inherit eutils toolchain-funcs games
@@ -107,7 +107,7 @@ src_compile() {
# rogue fails to build
local libsuffix
for BUILD_QMAX in YES NO ; do
- use qmax && [[ ${BUILD_QMAX} == "NO" ]] && continue
+ ! use qmax && [[ ${BUILD_QMAX} == "YES" ]] && continue
[[ ${BUILD_QMAX} == "YES" ]] \
&& libsuffix=-qmax \
|| libsuffix=
@@ -172,8 +172,10 @@ src_install() {
dodir "${q2maxdir}"
cp -rf my-rel-YES/* "${D}/${q2maxdir}"/ || die
newgamesbin "${D}/${q2maxdir}"/quake2 quake2-qmax || die
- newgamesbin "${D}/${q2maxdir}"/q2ded q2ded-qmax || die
- rm "${D}/${q2maxdir}"/{quake2,q2ded}
+ rm "${D}/${q2maxdir}"/quake2
+ use dedicated \
+ && newgamesbin "${D}/${q2maxdir}"/q2ded q2ded-qmax \
+ && rm "${D}/${q2maxdir}"/q2ded
use sdl \
&& newgamesbin "${D}/${q2maxdir}"/sdlquake2 sdlquake2-qmax \
&& rm "${D}/${q2maxdir}"/sdlquake2