summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-10-06 22:10:02 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-10-06 22:10:02 +0000
commit87176e049f990adbead35f37b4882567e6a3e78a (patch)
tree23ad348e5bb38885b069c7873996323e7588b18c /games-fps/quake3-alliance/quake3-alliance-3.3-r1.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-87176e049f990adbead35f37b4882567e6a3e78a.tar.gz
gentoo-2-87176e049f990adbead35f37b4882567e6a3e78a.tar.bz2
gentoo-2-87176e049f990adbead35f37b4882567e6a3e78a.zip
EAPI=2; fix unpack order; fix SRC_URI, bug #255676
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'games-fps/quake3-alliance/quake3-alliance-3.3-r1.ebuild')
-rw-r--r--games-fps/quake3-alliance/quake3-alliance-3.3-r1.ebuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/games-fps/quake3-alliance/quake3-alliance-3.3-r1.ebuild b/games-fps/quake3-alliance/quake3-alliance-3.3-r1.ebuild
index 7b68fa6e8665..016f47f7a477 100644
--- a/games-fps/quake3-alliance/quake3-alliance-3.3-r1.ebuild
+++ b/games-fps/quake3-alliance/quake3-alliance-3.3-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-alliance/quake3-alliance-3.3-r1.ebuild,v 1.3 2009/10/01 21:15:10 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-alliance/quake3-alliance-3.3-r1.ebuild,v 1.4 2009/10/06 22:10:02 nyhm Exp $
+
+EAPI=2
MOD_DESC="fast paced, off-handed grapple mod"
MOD_NAME="Alliance"
@@ -8,10 +10,20 @@ MOD_DIR="alliance"
inherit games games-mods
-SRC_URI="http://mir2.ovh.net/ftp.planetquake3.net/modifications/alliance/alliance30.zip
- http://mir2.ovh.net/ftp.planetquake3.net/modifications/alliance/alliance30-33.zip"
+SRC_URI="http://www.mirrorservice.org/sites/quakeunity.com/modifications/alliance/alliance30.zip
+ http://www.superkeff.net/mods/mods/alliance/alliance30.zip
+ http://www.mirrorservice.org/sites/quakeunity.com/modifications/alliance/alliance30-33.zip
+ http://www.superkeff.net/mods/mods/alliance/alliance30-33.zip"
HOMEPAGE="http://www.planetquake.com/alliance/"
LICENSE="freedist"
-KEYWORDS="-* ~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="dedicated opengl"
+
+src_unpack() {
+ unpack alliance30.zip alliance30-33.zip
+}
+
+src_prepare() {
+ rm -f *.exe
+}