summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-27 07:34:13 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-27 07:34:13 +0000
commit3542553cf7ddd0609751d8051b64c4cc242e51a6 (patch)
treedbe56382379f863c20d03f4339d6c3084134d4da /games-fps/quake3-data
parentsimplify the cdrom code a bit by unifying some duplicate sections and make su... (diff)
downloadgentoo-2-3542553cf7ddd0609751d8051b64c4cc242e51a6.tar.gz
gentoo-2-3542553cf7ddd0609751d8051b64c4cc242e51a6.tar.bz2
gentoo-2-3542553cf7ddd0609751d8051b64c4cc242e51a6.zip
add a warning for people who dont install with USE=cdinstall
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'games-fps/quake3-data')
-rw-r--r--games-fps/quake3-data/quake3-data-1.32b.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/games-fps/quake3-data/quake3-data-1.32b.ebuild b/games-fps/quake3-data/quake3-data-1.32b.ebuild
index 999488d27abd..2810089a9336 100644
--- a/games-fps/quake3-data/quake3-data-1.32b.ebuild
+++ b/games-fps/quake3-data/quake3-data-1.32b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-data/quake3-data-1.32b.ebuild,v 1.2 2005/10/26 00:27:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-data/quake3-data-1.32b.ebuild,v 1.3 2005/10/27 07:34:13 vapier Exp $
inherit eutils games
@@ -44,3 +44,15 @@ src_install() {
prepgamesdirs
}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! use cdinstall ; then
+ echo
+ einfo "You need to copy pak0.pk3 from your Quake3 CD into ${dir}/baseq3."
+ einfo "Or if you have got a Window installation of Q3 make a symlink to save space."
+ echo
+ einfo "Or, re-emerge quake3-data with USE=cdinstall."
+ echo
+ fi
+}