summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-04 03:57:37 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-04 03:57:37 +0000
commit48141d68ffc56540e6d7045311121d7bc331ac02 (patch)
tree5bb68fc902b793407a877167e6635060439ef493 /games-fps/quake3
parenthppa love for #111322 (diff)
downloadgentoo-2-48141d68ffc56540e6d7045311121d7bc331ac02.tar.gz
gentoo-2-48141d68ffc56540e6d7045311121d7bc331ac02.tar.bz2
gentoo-2-48141d68ffc56540e6d7045311121d7bc331ac02.zip
ver bump with now optional dedicated server support
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'games-fps/quake3')
-rw-r--r--games-fps/quake3/files/digest-quake3-1.33_alpha2091
-rw-r--r--games-fps/quake3/files/digest-quake3-1.33_alpha2551
-rw-r--r--games-fps/quake3/quake3-1.33_alpha255.ebuild (renamed from games-fps/quake3/quake3-1.33_alpha209.ebuild)21
3 files changed, 16 insertions, 7 deletions
diff --git a/games-fps/quake3/files/digest-quake3-1.33_alpha209 b/games-fps/quake3/files/digest-quake3-1.33_alpha209
deleted file mode 100644
index 69b255a9f703..000000000000
--- a/games-fps/quake3/files/digest-quake3-1.33_alpha209
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7f8e3c51857657981a64ec06d270643b quake3-1.33_SVN209M.tar.bz2 2290524
diff --git a/games-fps/quake3/files/digest-quake3-1.33_alpha255 b/games-fps/quake3/files/digest-quake3-1.33_alpha255
new file mode 100644
index 000000000000..ea0cfc546468
--- /dev/null
+++ b/games-fps/quake3/files/digest-quake3-1.33_alpha255
@@ -0,0 +1 @@
+MD5 1ac0e62f63d50c768040e89b2e2feb7a quake3-1.33_SVN255M.tar.bz2 1914739
diff --git a/games-fps/quake3/quake3-1.33_alpha209.ebuild b/games-fps/quake3/quake3-1.33_alpha255.ebuild
index 96545dd3807b..ba0adea8240d 100644
--- a/games-fps/quake3/quake3-1.33_alpha209.ebuild
+++ b/games-fps/quake3/quake3-1.33_alpha255.ebuild
@@ -1,8 +1,14 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.33_alpha209.ebuild,v 1.2 2005/11/03 00:54:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.33_alpha255.ebuild,v 1.1 2005/11/04 03:57:37 vapier Exp $
-if [[ ${PV} == "9999" ]] ; then
+# quake3-9999 -> latest svn
+# quake3-9999.REV -> use svn REV
+# quake3-VER_alphaREV -> svn snapshot REV for version VER
+# quake3-VER -> normal quake release
+
+if [[ ${PV} == 9999* ]] ; then
+ [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999.}"
ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
inherit subversion games toolchain-funcs
@@ -30,11 +36,12 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="dedicated opengl"
-RDEPEND="opengl? ( virtual/opengl virtual/x11 )
+RDEPEND="opengl? ( virtual/opengl virtual/x11 media-libs/libsdl )
+ !dedicated? ( virtual/opengl virtual/x11 media-libs/libsdl )
games-fps/quake3-data"
src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
+ if [[ ${PV} == 9999* ]] ; then
subversion_src_unpack
else
unpack ${A}
@@ -42,12 +49,14 @@ src_unpack() {
}
src_compile() {
- # Force -fno-strict-aliasing to fix graphical bugs #110509
+ buildit() { use $1 && echo 1 || echo 0 ; }
emake \
+ BUILD_SERVER=$(buildit dedicated) \
+ BUILD_CLIENT=$(buildit opengl) \
TEMPDIR="${T}" \
CC="$(tc-getCC)" \
ARCH=$(tc-arch-kernel) \
- OPTIMIZE="${CFLAGS} -fno-strict-aliasing" \
+ OPTIMIZE="${CFLAGS}" \
DEFAULT_BASEDIR="${GAMES_DATADIR}/quake3" \
DEFAULT_LIBDIR="${GAMES_LIBDIR}/quake3" \
|| die