summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-03-29 00:41:59 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-03-29 00:41:59 +0000
commit9d71b35a36dd7489974fc6fe65e50b20d981db93 (patch)
treef2515806cc89f07f7787c6093ab3c5b7d241df0e /games-fps/quake4-bin
parentremoved because of bug #127882 (diff)
downloadgentoo-2-9d71b35a36dd7489974fc6fe65e50b20d981db93.tar.gz
gentoo-2-9d71b35a36dd7489974fc6fe65e50b20d981db93.tar.bz2
gentoo-2-9d71b35a36dd7489974fc6fe65e50b20d981db93.zip
Version bump to 1.1 and closing bug #127912.
(Portage version: 2.1_pre6-r6)
Diffstat (limited to 'games-fps/quake4-bin')
-rw-r--r--games-fps/quake4-bin/ChangeLog8
-rw-r--r--games-fps/quake4-bin/files/digest-quake4-bin-1.13
-rw-r--r--games-fps/quake4-bin/quake4-bin-1.1.ebuild100
3 files changed, 110 insertions, 1 deletions
diff --git a/games-fps/quake4-bin/ChangeLog b/games-fps/quake4-bin/ChangeLog
index c581574754bd..360ac8ae18d7 100644
--- a/games-fps/quake4-bin/ChangeLog
+++ b/games-fps/quake4-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quake4-bin
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake4-bin/ChangeLog,v 1.9 2006/03/15 22:35:00 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake4-bin/ChangeLog,v 1.10 2006/03/29 00:41:59 wolf31o2 Exp $
+
+*quake4-bin-1.1 (29 Mar 2006)
+
+ 29 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +quake4-bin-1.1.ebuild:
+ Version bump to 1.1 and closing bug #127912.
15 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
quake4-bin-1.0.6.ebuild:
diff --git a/games-fps/quake4-bin/files/digest-quake4-bin-1.1 b/games-fps/quake4-bin/files/digest-quake4-bin-1.1
new file mode 100644
index 000000000000..23182e9748fc
--- /dev/null
+++ b/games-fps/quake4-bin/files/digest-quake4-bin-1.1
@@ -0,0 +1,3 @@
+MD5 33c94890738d251042bd4b71e1370ba7 quake4-linux-1.1.x86.run 120035724
+RMD160 810105a37e5f1cc3c66f2f0679086add077e7865 quake4-linux-1.1.x86.run 120035724
+SHA256 2dd920b8415fb6cf538960eafe3cb30cbb0cd7f2807c54652a5edc93854a979b quake4-linux-1.1.x86.run 120035724
diff --git a/games-fps/quake4-bin/quake4-bin-1.1.ebuild b/games-fps/quake4-bin/quake4-bin-1.1.ebuild
new file mode 100644
index 000000000000..fe0c223027db
--- /dev/null
+++ b/games-fps/quake4-bin/quake4-bin-1.1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake4-bin/quake4-bin-1.1.ebuild,v 1.1 2006/03/29 00:41:59 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Sequel to Quake 2, an Id 3D first-person shooter"
+HOMEPAGE="http://www.quake4game.com/"
+SRC_URI="mirror://3dgamers/quake4/quake4-linux-${PV}.x86.run
+ mirror://idsoftware/quake4-linux/quake4-linux-${PV}.x86.run
+ http://filebase.gmpf.de/quake4/quake4-linux-${PV}.x86.run
+ http://www.holarse.de/mirror/quake4-linux-${PV}.x86.run"
+
+LICENSE="QUAKE4"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="cdinstall alsa opengl dedicated"
+RESTRICT="nostrip"
+
+RDEPEND="sys-libs/glibc
+ !amd64? (
+ media-libs/libsdl )
+ amd64? (
+ app-emulation/emul-linux-x86-sdl
+ app-emulation/emul-linux-x86-xlibs )
+ opengl? (
+ virtual/opengl
+ x86? (
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 ) ) )
+ dedicated? (
+ app-misc/screen )
+ alsa? (
+ >=media-libs/alsa-lib-1.0.6 )
+ cdinstall? (
+ games-fps/quake4-data )"
+
+S=${WORKDIR}
+
+GAMES_CHECK_LICENSE="yes"
+dir=${GAMES_PREFIX_OPT}/quake4
+Ddir=${D}/${dir}
+
+src_unpack() {
+ unpack_makeself quake4-linux-${PV}.x86.run
+}
+
+src_install() {
+ insinto "${dir}"
+ exeinto "${dir}"
+ doins *.txt README q4icon.bmp us/version.info # CHANGES
+ doins -r pb || die "doins pb"
+ doexe openurl.sh || die "openurl.sh"
+ if use x86; then
+ doexe bin/Linux/x86/quake4.x86 bin/Linux/x86/q4ded.x86 \
+ bin/Linux/x86/libgcc_s.so.1 bin/Linux/x86/libstdc++.so.6 \
+ || die "doexe x86 exes/libs"
+ elif use amd64; then
+ doexe bin/Linux/x86_64/quake4.x86 bin/Linux/x86_64/q4ded.x86 \
+ bin/Linux/x86_64/libgcc_s.so.1 bin/Linux/x86_64/libstdc++.so.6 \
+ || die "doexe amd64 exes/libs"
+ else
+ die "Cannot copy executables!"
+ fi
+
+ insinto "${dir}"/q4base
+ use dedicated && games_make_wrapper quake4-ded ./q4ded.x86 "${dir}" "${dir}"
+ doins q4base/* || die "doins q4base"
+ doins us/q4base/* || die "installing us/q4base/*"
+
+ if use opengl
+ then
+ games_make_wrapper quake4 ./quake4.x86 "${dir}" "${dir}"
+# doicon ${FILESDIR}/quake4.png || die "copying icon"
+# make_desktop_entry quake4 "Quake IV" quake4.png
+ newicon q4icon.bmp quake4.bmp || die "copying icon"
+ make_desktop_entry quake4 "Quake IV" /usr/share/pixmaps/quake4.bmp
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall; then
+ einfo "You need to copy pak001.pk4 through pak012.pk4, along with"
+ einfo "zpak*.pk4 from either your installation media or your hard drive"
+ einfo "to ${dir}/q4base before running the game."
+ echo
+ fi
+ einfo "To play the game run:"
+ einfo " quake4"
+ echo
+}