summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-05-15 22:41:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-05-15 22:41:36 +0000
commit1a6cb1a956df0c2bc8216bc60ada7d08f95be72e (patch)
tree69a50ca16895aa6e7b9958d5b7dc0fcb464cb765 /games-fps/transfusion-bin
parent- stable x86 - use toolchain-funcs vs gcc eclass - cleaned out older versions (diff)
downloadgentoo-2-1a6cb1a956df0c2bc8216bc60ada7d08f95be72e.tar.gz
gentoo-2-1a6cb1a956df0c2bc8216bc60ada7d08f95be72e.tar.bz2
gentoo-2-1a6cb1a956df0c2bc8216bc60ada7d08f95be72e.zip
fix typo on wrapper creation (bug #92736); tidy
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-fps/transfusion-bin')
-rw-r--r--games-fps/transfusion-bin/ChangeLog6
-rw-r--r--games-fps/transfusion-bin/transfusion-bin-1.01.ebuild23
2 files changed, 16 insertions, 13 deletions
diff --git a/games-fps/transfusion-bin/ChangeLog b/games-fps/transfusion-bin/ChangeLog
index 4ab7e815d941..62aba7b40392 100644
--- a/games-fps/transfusion-bin/ChangeLog
+++ b/games-fps/transfusion-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/transfusion-bin
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/transfusion-bin/ChangeLog,v 1.7 2005/03/15 20:36:16 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/transfusion-bin/ChangeLog,v 1.8 2005/05/15 22:41:36 mr_bones_ Exp $
+
+ 15 May 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ transfusion-bin-1.01.ebuild:
+ fix typo on wrapper creation (bug #92736); tidy
15 Mar 2005; Chris Gianelloni <wolf31o2@gentoo.org>
transfusion-bin-1.01.ebuild:
diff --git a/games-fps/transfusion-bin/transfusion-bin-1.01.ebuild b/games-fps/transfusion-bin/transfusion-bin-1.01.ebuild
index 32d97ad4401b..9e12e77034a0 100644
--- a/games-fps/transfusion-bin/transfusion-bin-1.01.ebuild
+++ b/games-fps/transfusion-bin/transfusion-bin-1.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/transfusion-bin/transfusion-bin-1.01.ebuild,v 1.9 2005/03/15 20:36:16 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/transfusion-bin/transfusion-bin-1.01.ebuild,v 1.10 2005/05/15 22:41:36 mr_bones_ Exp $
inherit games
@@ -17,12 +17,11 @@ KEYWORDS="-* x86"
IUSE=""
RESTRICT="nostrip"
-RDEPEND="virtual/libc"
+RDEPEND=""
DEPEND="${RDEPEND}
- app-arch/unzip
- >=sys-apps/sed-4"
+ app-arch/unzip"
-S="${WORKDIR}/${MY_PN}"
+S=${WORKDIR}/${MY_PN}
dir=${GAMES_PREFIX_OPT}/${MY_PN}
Ddir=${D}/${dir}
@@ -33,17 +32,17 @@ src_install() {
dohtml ${MY_PN}/doc/*.html
#...then mass copy everything to the install dir...
- dodir ${dir}
- cp -R * ${Ddir}
+ dodir "${dir}"
+ cp -R * "${Ddir}" || die "cp failed"
# ...and remove the docs since we don't need them installed twice.
rm -rf \
- ${Ddir}/${MY_PN}/doc \
- ${Ddir}/qw/*txt \
- ${Ddir}/${MY_PN}/*txt
+ "${Ddir}"/${MY_PN}/doc \
+ "${Ddir}"/qw/*txt \
+ "${Ddir}"/${MY_PN}/*txt
- doicon ${DISTDIR}/${MY_PN}.png
- games_make_wrapper ${MY_PN} ${MY_PN}-glx ${dir}
+ doicon "${DISTDIR}"/${MY_PN}.png
+ games_make_wrapper ${MY_PN} ./${MY_PN}-glx "${dir}"
make_desktop_entry ${MY_PN} "Transfusion" ${MY_PN}.png
prepgamesdirs