summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-07-28 04:30:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-07-28 04:30:14 +0000
commit586e17941ac18fef0c224de00801f7094863746f (patch)
treec70533243182bfa19b94d95a8df74857d7188650 /games-fps/ut2004-crossfire
parentwhitespace (diff)
downloadgentoo-2-586e17941ac18fef0c224de00801f7094863746f.tar.gz
gentoo-2-586e17941ac18fef0c224de00801f7094863746f.tar.bz2
gentoo-2-586e17941ac18fef0c224de00801f7094863746f.zip
version bump (bug #232965)
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-fps/ut2004-crossfire')
-rw-r--r--games-fps/ut2004-crossfire/ChangeLog10
-rw-r--r--games-fps/ut2004-crossfire/ut2004-crossfire-1.9.ebuild41
2 files changed, 49 insertions, 2 deletions
diff --git a/games-fps/ut2004-crossfire/ChangeLog b/games-fps/ut2004-crossfire/ChangeLog
index 2c124ff0c420..3d5a62307b56 100644
--- a/games-fps/ut2004-crossfire/ChangeLog
+++ b/games-fps/ut2004-crossfire/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/ut2004-crossfire
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-crossfire/ChangeLog,v 1.2 2007/05/22 16:49:03 nyhm Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-crossfire/ChangeLog,v 1.3 2008/07/28 04:30:14 mr_bones_ Exp $
+
+*ut2004-crossfire-1.9 (28 Jul 2008)
+
+ 28 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +ut2004-crossfire-1.9.ebuild:
+ version bump (bug #232965)
*ut2004-crossfire-1.7 (22 May 2007)
diff --git a/games-fps/ut2004-crossfire/ut2004-crossfire-1.9.ebuild b/games-fps/ut2004-crossfire/ut2004-crossfire-1.9.ebuild
new file mode 100644
index 000000000000..8d5b2cc1014a
--- /dev/null
+++ b/games-fps/ut2004-crossfire/ut2004-crossfire-1.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+# /var/cvsroot/gentoo-x86/games-fps/ut2004-crossfire/ut2004-crossfire-1.9a.ebuild Exp $
+
+MOD_NAME="Crossfire"
+MOD_DESC="Special Forces vs Terrorists"
+MOD_DIR="TOCrossfire"
+MOD_BINS="crossfire"
+MOD_ICON="Help/icons/TOC_TERROR2.png"
+
+inherit games games-mods
+
+OLD="TOCrossfire_beta_1.9_full"
+UPD="TOCrossfire_beta_1.9a_update"
+HOMEPAGE="http://www.to-crossfire.net/"
+SRC_URI="ftp://mirror1.to-crossfire.net/client/${OLD}.zip
+ ftp://mirror1.to-crossfire.net/client/${OLD}.zip
+ ftp://toc.de-mirror.org/client/${OLD}.zip
+ ftp://mirror1.to-crossfire.net/client/${UPD}.zip
+ ftp://mirror1.to-crossfire.net/client/${UPD}.zip
+ ftp://toc.de-mirror.org/client/${UPD}.zip"
+
+# See Help/EULA.txt
+LICENSE="free-noncomm"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${CATEGORY}/${GAME}"
+
+src_unpack() {
+ mkdir ${OLD} ${UPD}
+
+ cd "${WORKDIR}/${OLD}" && unpack "${OLD}.zip" || die
+ cd "${WORKDIR}/${UPD}" && unpack "${UPD}.zip" || die
+ cd "${WORKDIR}"
+ unpack ./${OLD}/TOCinstall.tgz ./${UPD}/TOCinstall.tgz
+
+ cd "${MOD_DIR}" || die
+ rm -f *.{bat,exe,md5} Help/*.{exe,zip}
+}