summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-10-08 20:03:40 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-10-08 20:03:40 +0000
commit48a1bdb0d1216b0574bbddec6b7d7fb245dbdaf5 (patch)
tree476aeb5336155fe75ab4376c235c2ffd36e0785e /games-fps/ut2004-muralis
parentadd get_modname function that retrieves the shared module extension, like get... (diff)
downloadgentoo-2-48a1bdb0d1216b0574bbddec6b7d7fb245dbdaf5.tar.gz
gentoo-2-48a1bdb0d1216b0574bbddec6b7d7fb245dbdaf5.tar.bz2
gentoo-2-48a1bdb0d1216b0574bbddec6b7d7fb245dbdaf5.zip
EAPI=2; RESTRICT=fetch
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'games-fps/ut2004-muralis')
-rw-r--r--games-fps/ut2004-muralis/ChangeLog7
-rw-r--r--games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild24
2 files changed, 22 insertions, 9 deletions
diff --git a/games-fps/ut2004-muralis/ChangeLog b/games-fps/ut2004-muralis/ChangeLog
index fa2f96d54717..ba6952f8ae2f 100644
--- a/games-fps/ut2004-muralis/ChangeLog
+++ b/games-fps/ut2004-muralis/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/ut2004-muralis
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-muralis/ChangeLog,v 1.3 2008/07/28 17:08:21 wolf31o2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-muralis/ChangeLog,v 1.4 2009/10/08 20:03:40 nyhm Exp $
+
+ 08 Oct 2009; Tristan Heaven <nyhm@gentoo.org> ut2004-muralis-1.15.ebuild:
+ EAPI=2; RESTRICT=fetch
28 Jul 2008; Chris Gianelloni <wolf31o2@gentoo.org> metadata.xml:
Removing myself from metadata.xml since I am retiring from the project.
diff --git a/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild b/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild
index b5d3ce369f54..2f6c991cc271 100644
--- a/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild
+++ b/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild,v 1.3 2009/10/01 22:13:02 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild,v 1.4 2009/10/08 20:03:40 nyhm Exp $
+
+EAPI=2
MOD_DESC="third-person hand-to-hand single/multiplayer mod"
MOD_NAME="Muralis"
@@ -9,15 +11,23 @@ MOD_DIR="muralis"
inherit games games-mods
HOMEPAGE="http://www.ascensiongames.com/"
-
-MOD_FILE="muralis-v${PV}-zip.zip"
-SRC_URI="mirror://beyondunreal/mods/${MOD_FILE}"
+SRC_URI="muralis-v${PV}-zip.zip"
LICENSE="freedist"
KEYWORDS="amd64 x86"
IUSE="dedicated opengl"
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ elog "Please download ${SRC_URI} from:"
+ elog "http://www.atomicgamer.com/file.php?id=42750"
+ elog "and move it to ${DISTDIR}"
+}
src_unpack() {
- unzip "${DISTDIR}"/${MOD_FILE}
- mv ${MOD_NAME} ${MOD_DIR}
+ unzip "${DISTDIR}"/${A} # unpack fails
+}
+
+src_prepare() {
+ mv -f Muralis ${MOD_DIR} || die
}