summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-01-21 15:27:28 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-01-21 15:27:28 +0000
commiteb74eaccd15798fe7408f413a158fc43168e4552 (patch)
treebe424acbe37c3061019bb40d81fe9caf166902f1 /games-fps/warsow
parentInsert missing ifdef's for building without xprint, segmentation faults witho... (diff)
downloadgentoo-2-eb74eaccd15798fe7408f413a158fc43168e4552.tar.gz
gentoo-2-eb74eaccd15798fe7408f413a158fc43168e4552.tar.bz2
gentoo-2-eb74eaccd15798fe7408f413a158fc43168e4552.zip
Version bump, bug #206738
(Portage version: 2.1.4)
Diffstat (limited to 'games-fps/warsow')
-rw-r--r--games-fps/warsow/ChangeLog8
-rw-r--r--games-fps/warsow/files/digest-warsow-0.49
-rw-r--r--games-fps/warsow/files/warsow-0.4-build.patch43
-rw-r--r--games-fps/warsow/warsow-0.4.ebuild110
4 files changed, 169 insertions, 1 deletions
diff --git a/games-fps/warsow/ChangeLog b/games-fps/warsow/ChangeLog
index a515eeb22c5e..06df8c469e3e 100644
--- a/games-fps/warsow/ChangeLog
+++ b/games-fps/warsow/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/warsow
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/ChangeLog,v 1.13 2008/01/18 03:09:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/ChangeLog,v 1.14 2008/01/21 15:27:28 nyhm Exp $
+
+*warsow-0.4 (21 Jan 2008)
+
+ 21 Jan 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/warsow-0.4-build.patch, +warsow-0.4.ebuild:
+ Version bump, bug #206738
18 Jan 2008; Michael Sterrett <mr_bones_@gentoo.org>
warsow-0.3.2-r1.ebuild:
diff --git a/games-fps/warsow/files/digest-warsow-0.4 b/games-fps/warsow/files/digest-warsow-0.4
new file mode 100644
index 000000000000..ed1c623146f4
--- /dev/null
+++ b/games-fps/warsow/files/digest-warsow-0.4
@@ -0,0 +1,9 @@
+MD5 d5eac4a33b3543dbc40d984b84e657f8 warsow.png 1692
+RMD160 098a1505a74a20eb4bdfeda4cf2c537a9524ce23 warsow.png 1692
+SHA256 086968e72271b248ef32609ed1818ff9f5c355297b1eee3cbee9e41f4e18a954 warsow.png 1692
+MD5 f4c9dd0683374c6b12b61723b4f7e647 warsow_0.4_sdk.zip 10844992
+RMD160 abe428d0ebc59c2181e7ab557ead95228cf05e85 warsow_0.4_sdk.zip 10844992
+SHA256 76b7e3a3410774c24ed8f78b55fe426e56fff94bef855b788dd2fd73abec6ce2 warsow_0.4_sdk.zip 10844992
+MD5 fcf88aeada971a108895eb5480005c49 warsow_0.4_unified.zip 176202685
+RMD160 d9376fbd94efce2d57dced777f541663bbfc29f0 warsow_0.4_unified.zip 176202685
+SHA256 706d127e7b1a2965ba87a43253cdd085775798b0c32d2814de0405a8f5bf19f3 warsow_0.4_unified.zip 176202685
diff --git a/games-fps/warsow/files/warsow-0.4-build.patch b/games-fps/warsow/files/warsow-0.4-build.patch
new file mode 100644
index 000000000000..4ccbd31c68d3
--- /dev/null
+++ b/games-fps/warsow/files/warsow-0.4-build.patch
@@ -0,0 +1,43 @@
+--- Makefile
++++ Makefile
+@@ -108,9 +108,9 @@
+ LOCALBASE?=/usr/local
+ X11BASE?=/usr/X11R6
+
+-CFLAGS_COMMON=$(CFLAGS) -I. -I$(LOCALBASE)/include -I$(X11BASE)/include -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -Wall
+-CFLAGS_RELEASE=-O2 -fno-strict-aliasing -ffast-math -funroll-loops -DNDEBUG
+-CFLAGS_DEBUG=-O0 -ggdb -D_DEBUG
++CFLAGS_COMMON=$(CFLAGS) -I. -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -Wall -fno-strict-aliasing
++CFLAGS_RELEASE=-DNDEBUG
++CFLAGS_DEBUG=-D_DEBUG
+ ifeq ($(DEBUG_BUILD),YES)
+ CFLAGS_COMMON+=$(CFLAGS_DEBUG)
+ else
+@@ -125,7 +125,7 @@
+ ifeq ($(OS),FreeBSD)
+ LDFLAGS_COMMON=-L/usr/local/lib -lm
+ else
+-LDFLAGS_COMMON=-L/usr/local/lib -ldl -lm
++LDFLAGS_COMMON=$(LDFLAGS) -ldl -lm
+ endif
+
+ ifeq ($(ARCH),x86_64)
+@@ -353,15 +353,15 @@
+
+ all: client openal qf ded cgame game ui irc tv_server
+
+-client: $(BUILDDIRS) message-client compile-client link-client start-script-client
++client: $(BUILDDIRS) message-client compile-client link-client
+ openal: $(BUILDDIRS) message-openal compile-openal link-openal
+ qf: $(BUILDDIRS) message-qf compile-qf link-qf
+-ded: $(BUILDDIRS) message-ded compile-ded link-ded start-script-ded
++ded: $(BUILDDIRS) message-ded compile-ded link-ded
+ cgame: $(BUILDDIRS) message-cgame compile-cgame link-cgame
+ game: $(BUILDDIRS) message-game compile-game link-game
+ ui: $(BUILDDIRS) message-ui compile-ui link-ui
+ irc: $(BUILDDIRS) message-irc compile-irc link-irc
+-tv_server: $(BUILDDIRS) message-tv_server compile-tv_server link-tv_server start-script-tv_server
++tv_server: $(BUILDDIRS) message-tv_server compile-tv_server link-tv_server
+
+ clean: clean-msg clean-depend clean-client clean-openal clean-qf clean-ded clean-cgame clean-game clean-ui clean-irc clean-tv_server
+
diff --git a/games-fps/warsow/warsow-0.4.ebuild b/games-fps/warsow/warsow-0.4.ebuild
new file mode 100644
index 000000000000..55673dfbfc2d
--- /dev/null
+++ b/games-fps/warsow/warsow-0.4.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/warsow-0.4.ebuild,v 1.1 2008/01/21 15:27:28 nyhm Exp $
+
+inherit eutils toolchain-funcs versionator games
+
+MY_P=${PN}_$(delete_version_separator 2)
+DESCRIPTION="Multiplayer FPS based on the QFusion engine (evolved from Quake 2)"
+HOMEPAGE="http://www.warsow.net/"
+SRC_URI="http://qc-net.com/wsw/${MY_P}_unified.zip
+ http://qc-net.com/wsw/${MY_P}_sdk.zip
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug dedicated irc openal opengl"
+
+UIRDEPEND="media-libs/jpeg
+ media-libs/libvorbis
+ media-libs/libsdl
+ net-misc/curl
+ virtual/opengl
+ x11-libs/libXinerama
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ openal? ( media-libs/openal )"
+RDEPEND="opengl? ( ${UIRDEPEND} )
+ !opengl? ( !dedicated? ( ${UIRDEPEND} ) )"
+UIDEPEND="x11-proto/xineramaproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ x11-misc/makedepend
+ opengl? ( ${UIDEPEND} )
+ !opengl? ( !dedicated? ( ${UIDEPEND} ) )"
+
+S=${WORKDIR}/${MY_P}_src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "/fs_basepath =/ s:\.:${GAMES_DATADIR}/${PN}:" \
+ qcommon/files.c \
+ || die "sed files.c failed"
+
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ yesno() { use ${1} && echo YES || echo NO ; }
+
+ local client="NO" irc="NO" openal="NO"
+ if use opengl || ! use dedicated ; then
+ client="YES"
+ use irc && irc="YES"
+ use openal && openal="YES"
+ fi
+
+ emake \
+ BUILD_CLIENT=${client} \
+ BUILD_SERVER=$(yesno dedicated) \
+ BUILD_TV_SERVER=$(yesno dedicated) \
+ BUILD_IRC=${irc} \
+ BUILD_SND_OPENAL=${openal} \
+ BUILD_SND_QF=${client} \
+ DEBUG_BUILD=$(yesno debug) \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ || die "emake failed"
+}
+
+src_install() {
+ cd release
+
+ if use opengl || ! use dedicated ; then
+ newgamesbin ${PN}.* ${PN} || die "newgamesbin ${PN} failed"
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} Warsow
+ fi
+
+ if use dedicated ; then
+ newgamesbin wsw_server.* ${PN}-ded || die "newgamesbin ${PN}-ded failed"
+ newgamesbin wswtv_server.* ${PN}-tv || die "newgamesbin ${PN}-tv failed"
+ fi
+
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe */*.so || die "doexe failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${WORKDIR}"/basewsw || die "doins failed"
+
+ local so
+ for so in basewsw/*.so ; do
+ dosym "$(games_get_libdir)"/${PN}/${so##*/} \
+ "${GAMES_DATADIR}"/${PN}/${so} || die "dosym ${so} failed"
+ done
+
+ dodir "${GAMES_DATADIR}"/${PN}/libs
+ for so in libs/*.so ; do
+ dosym "$(games_get_libdir)"/${PN}/${so##*/} \
+ "${GAMES_DATADIR}"/${PN}/${so} || die "dosym ${so} failed"
+ done
+
+ dodoc "${WORKDIR}"/docs/*
+ prepgamesdirs
+}