summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-11-14 18:21:32 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-11-14 18:21:32 +0000
commit3a8f112dfc376a8ba36b1d189c701b08b526d580 (patch)
treeb7d617cb0adc50a2c38cbbde614edede91a7087f /games-fps
parentStable on sparc wrt #147570 (diff)
downloadgentoo-2-3a8f112dfc376a8ba36b1d189c701b08b526d580.tar.gz
gentoo-2-3a8f112dfc376a8ba36b1d189c701b08b526d580.tar.bz2
gentoo-2-3a8f112dfc376a8ba36b1d189c701b08b526d580.zip
Updated the ebuild with some changes from Paul Bredbury <brebs@sent.com> and closing bug #154506.
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/americas-army/ChangeLog7
-rw-r--r--games-fps/americas-army/americas-army-250.ebuild85
2 files changed, 51 insertions, 41 deletions
diff --git a/games-fps/americas-army/ChangeLog b/games-fps/americas-army/ChangeLog
index 3a5f0ca6f3e2..6f99ed6f14b3 100644
--- a/games-fps/americas-army/ChangeLog
+++ b/games-fps/americas-army/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/americas-army
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/ChangeLog,v 1.50 2006/10/26 13:59:12 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/ChangeLog,v 1.51 2006/11/14 18:21:32 wolf31o2 Exp $
+
+ 14 Nov 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ americas-army-250.ebuild:
+ Updated the ebuild with some changes from Paul Bredbury <brebs@sent.com> and
+ closing bug #154506.
26 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org>
americas-army-250.ebuild:
diff --git a/games-fps/americas-army/americas-army-250.ebuild b/games-fps/americas-army/americas-army-250.ebuild
index 6bf4a5ab9d40..d2c335ed8b16 100644
--- a/games-fps/americas-army/americas-army-250.ebuild
+++ b/games-fps/americas-army/americas-army-250.ebuild
@@ -1,29 +1,29 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/americas-army-250.ebuild,v 1.13 2006/10/26 13:59:12 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/americas-army-250.ebuild,v 1.14 2006/11/14 18:21:32 wolf31o2 Exp $
inherit eutils games
+DED_PV="0.2"
+DED_FILE="${PN}-all-${DED_PV}.tar.bz2"
MY_P="armyops${PV}-linux.run"
+
DESCRIPTION="military simulations by the U.S. Army to provide civilians with insights on soldiering"
HOMEPAGE="http://www.americasarmy.com/"
SRC_URI="http://treefort.icculus.org/armyops/${MY_P}
http://0day.icculus.org/armyops/${MY_P}
mirror://3dgamers/${PN/-/}/${MY_P}
dedicated? (
- http://dev.gentoo.org/~wolf31o2/sources/dump/${PN}-all-0.2.tar.bz2
- mirror://gentoo/${PN}-all-0.2.tar.bz2 )"
+ http://dev.gentoo.org/~wolf31o2/sources/dump/${DED_FILE}
+ mirror://gentoo/${DED_FILE} )"
LICENSE="Army-EULA"
SLOT="0"
KEYWORDS="amd64 x86"
-RESTRICT="strip mirror"
-
-IUSE="opengl dedicated"
+RESTRICT="mirror strip"
+IUSE="dedicated opengl"
-RDEPEND="sys-libs/glibc
- opengl? (
- virtual/opengl
+UIDEPEND="virtual/opengl
amd64? (
app-emulation/emul-linux-x86-xlibs
|| (
@@ -34,67 +34,72 @@ RDEPEND="sys-libs/glibc
>=x11-drivers/ati-drivers-8.8.25-r1 ) )
x86? (
x11-libs/libXext
- x11-libs/libX11 ) )
- amd64? (
- app-emulation/emul-linux-x86-compat )
+ x11-libs/libX11 )"
+RDEPEND="sys-libs/glibc
+ opengl? ( ${UIDEPEND} )
+ !opengl? ( !dedicated? ( ${UIDEPEND} ) )
+ amd64? ( app-emulation/emul-linux-x86-compat )
x86? ( =virtual/libstdc++-3.3 )"
S=${WORKDIR}
-dir=${GAMES_PREFIX_OPT}/${PN}
-Ddir=${D}/${dir}
pkg_setup() {
games_pkg_setup
- ewarn "The installed game takes about 1.6GB of space when installed and"
- ewarn "2.4GB of space in ${PORTAGE_TMPDIR} to build!"
+ einfo "The installed game takes about 1.6GB of space when installed and"
+ einfo "2.4GB of space in ${PORTAGE_TMPDIR} to build!"
+ echo
}
src_unpack() {
- unpack_makeself ${DISTDIR}/${MY_P} || die "unpacking game"
- tar -zxf setupstuff.tar.gz || die
- if use dedicated; then
- unpack ${PN}-all-0.1.tar.bz2 || die
+ unpack_makeself "${DISTDIR}/${MY_P}" || die "unpacking game"
+ unpack ./setupstuff.tar.gz
+ if use dedicated ; then
+ unpack "${DED_FILE}"
fi
}
src_install() {
- einfo "This will take a while ... go get a pizza or something"
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ local Ddir=${D}/${dir}
- dodir ${dir}
+ einfo "This will take a while... go get a pizza or something."
- tar -jxf armyops${PV}.tar.bz2 -C ${Ddir}/ || die "armyops untar failed"
- tar -jxf binaries.tar.bz2 -C ${Ddir}/ || die "binaries untar failed"
+ dodir "${dir}"
+ tar -jxf armyops${PV}.tar.bz2 -C "${Ddir}"/ || die "armyops untar failed"
+ tar -jxf binaries.tar.bz2 -C "${Ddir}"/ || die "binaries untar failed"
dodoc README.linux
- insinto ${dir}
+ insinto "${dir}"
doins ArmyOps.xpm README.linux ArmyOps${PV}_EULA.txt || die "doins failed"
- newicon ArmyOps.xpm armyops.xpm || die "doins failed"
- exeinto ${dir}
+ newicon ArmyOps.xpm armyops.xpm || die "newicon failed"
+ exeinto "${dir}"
doexe bin/armyops || die "doexe failed"
- fperms ug+x ${dir}/System/pb/pbweb.x86
+ fperms ug+x "${dir}"/System/pb/pbweb.x86
- if use dedicated; then
- newinitd ${S}/armyops-ded.rc armyops-ded
- newconfd ${S}/armyops-ded.conf. armyops-ded
- games_make_wrapper armyops-ded ./server-bin ${dir}/System
+ if use dedicated ; then
+ newinitd "${S}"/armyops-ded.rc armyops-ded || die
+ newconfd "${S}"/armyops-ded.conf.d armyops-ded || die
+ games_make_wrapper armyops-ded ./server-bin "${dir}"/System
fi
- games_make_wrapper armyops ./armyops "${dir}" "${dir}"
+ if use opengl || ! use dedicated ; then
+ games_make_wrapper armyops ./armyops "${dir}" "${dir}"
+ make_desktop_entry armyops "America's Army" armyops.xpm
+ fi
prepgamesdirs
- make_desktop_entry armyops "America's Army" armyops.xpm
}
pkg_postinst() {
games_pkg_postinst
- if use dedicated; then
- einfo "To start a dedicated server, run"
- einfo " /etc/init.d/armyops-ded start"
+
+ if use dedicated ; then
+ elog "To start a dedicated server, run:"
+ elog " /etc/init.d/armyops-ded start"
echo
fi
- if use opengl; then
- einfo "To play the game run:"
- einfo " armyops"
+ if use opengl || ! use dedicated ; then
+ elog "To play the game, run: armyops"
echo
fi
}