summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-06 16:40:35 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-06 16:40:35 +0000
commit4ca6497cd5c15cc9da3e052225fd580b2465e075 (patch)
treef13fe68514c0d1bc34250bc245e02a77cd2d9af8 /games-fps
parentDrop maintainer-needed from metadata since there is an associated herd. (diff)
downloadgentoo-2-4ca6497cd5c15cc9da3e052225fd580b2465e075.tar.gz
gentoo-2-4ca6497cd5c15cc9da3e052225fd580b2465e075.tar.bz2
gentoo-2-4ca6497cd5c15cc9da3e052225fd580b2465e075.zip
migrate to python-r1, provide multiple abi support
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/doomsday/ChangeLog9
-rw-r--r--games-fps/doomsday/doomsday-1.9.8-r1.ebuild147
2 files changed, 154 insertions, 2 deletions
diff --git a/games-fps/doomsday/ChangeLog b/games-fps/doomsday/ChangeLog
index 2d965c458e64..9cbaa7de64a7 100644
--- a/games-fps/doomsday/ChangeLog
+++ b/games-fps/doomsday/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/doomsday
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/ChangeLog,v 1.49 2012/12/31 09:46:38 pinkbyte Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/ChangeLog,v 1.50 2013/02/06 16:40:35 hasufell Exp $
+
+*doomsday-1.9.8-r1 (06 Feb 2013)
+
+ 06 Feb 2013; Julian Ospald <hasufell@gentoo.org> +doomsday-1.9.8-r1.ebuild:
+ migrate to python-r1, provide multiple abi support
31 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> doomsday-1.9.8.ebuild,
+files/doomsday-1.9.8-openal-64bit-fix.patch:
diff --git a/games-fps/doomsday/doomsday-1.9.8-r1.ebuild b/games-fps/doomsday/doomsday-1.9.8-r1.ebuild
new file mode 100644
index 000000000000..4a9bab1f143a
--- /dev/null
+++ b/games-fps/doomsday/doomsday-1.9.8-r1.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/doomsday-1.9.8-r1.ebuild,v 1.1 2013/02/06 16:40:35 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+inherit python-r1 confutils eutils qt4-r2 games
+
+DESCRIPTION="A modern gaming engine for Doom, Heretic, and Hexen"
+HOMEPAGE="http://www.dengine.net/"
+SRC_URI="mirror://sourceforge/deng/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openal snowberry +doom demo freedoom heretic hexen resources"
+
+DEPEND="
+ virtual/opengl
+ virtual/glu
+ media-libs/libsdl[joystick,audio]
+ media-libs/sdl-mixer
+ media-libs/libpng:0
+ x11-libs/qt-opengl:4
+ x11-libs/qt-gui:4
+ net-misc/curl
+ openal? ( media-libs/openal )
+ snowberry? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}
+ snowberry? ( dev-python/wxpython )"
+PDEPEND="
+ demo? ( games-fps/doom-data )
+ freedoom? ( games-fps/freedoom )
+ resources? ( games-fps/doomsday-resources )"
+
+S=${S}/${PN}
+
+REQUIRED_USE="demo? ( doom ) freedoom? ( doom ) resources? ( doom )"
+PATCHES=(
+ "${FILESDIR}"/${P}-openal-64bit-fix.patch
+)
+
+pkg_setup() {
+ games_pkg_setup
+ python_export_best
+}
+
+src_prepare() {
+ sed -i \
+ -e "/^DENG_BASE_DIR =/s:\$\$PREFIX/share:${GAMES_DATADIR}:" \
+ config_unix.pri || die
+ echo "CONFIG += nostrip" > config_user.pri
+ echo "PREFIX=/usr/games" >> config_user.pri
+ use snowberry && \
+ echo "CONFIG += deng_snowberry" >> config_user.pri || \
+ echo "CONFIG += deng_nosnowberry" >> config_user.pri
+
+ if use openal; then
+ echo "CONFIG += deng_openal" >> config_user.pri
+ sed -i \
+ -e 's:\# Generic Unix.:LIBS += -lopenal:' \
+ dep_openal.pri || die
+ epatch "${FILESDIR}"/${P}-openal-link.patch
+ fi
+
+ qt4-r2_src_prepare
+}
+
+#Usage: doom_make_wrapper <name> <game> <icon> <desktop entry title> [args]
+doom_make_wrapper() {
+ local name=$1 game=$2 icon=$3 de_title=$4
+ shift 4
+ games_make_wrapper $name \
+ "doomsday -game ${game} $@"
+ make_desktop_entry $name "${de_title}" ${icon}
+}
+
+src_configure() {
+ qt4-r2_src_configure
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ mv "${D}/${GAMES_DATADIR}"/{${PN}/data/jdoom,doom-data} || die
+ dosym "${GAMES_DATADIR}"/doom-data "${GAMES_DATADIR}"/${PN}/data/jdoom
+
+ if use snowberry; then
+ python_replicate_script "${D}"/"${GAMES_BINDIR}"/launch-doomsday
+
+ installmodules() {
+ # relocate snowberry module directory recursively into site-packages
+ python_domodule "${D}/${GAMES_DATADIR}"/${PN}/snowberry
+ # hack around improper path handling
+ sed -i \
+ -e "s:os.chdir.*$:os.chdir('$(python_get_sitedir)/snowberry'):" \
+ "${D}"/"${GAMES_BINDIR}"/launch-doomsday-${EPYTHON} || die
+ }
+ python_foreach_impl installmodules
+ # remove old module dir
+ rm -r "${D}/${GAMES_DATADIR}"/${PN}/snowberry || die
+
+ make_desktop_entry launch-doomsday "Snowberry DoomsDay" snowberry
+ doicon ../snowberry/graphics/snowberry.png
+ fi
+
+ if use doom; then
+ local res_arg
+ if use resources; then
+ res_arg="-def \"${GAMES_DATADIR}\"/${PN}/defs/jdoom/jDRP.ded"
+ fi
+
+ doicon ../snowberry/graphics/orb-doom.png
+ doom_make_wrapper jdoom doom1 orb-doom "DoomsDay Engine: Doom 1" "${res_arg}"
+ elog "Created jdoom launcher. To play Doom place your doom.wad to"
+ elog "\"${GAMES_DATADIR}\"/doom-data"
+ elog
+
+ if use demo; then
+ doom_make_wrapper jdoom-demo doom1-share orb-doom "DoomsDay Engine: Doom 1 Demo" \
+ "-iwad \"${GAMES_DATADIR}\"/doom-data/doom1.wad ${res_arg}"
+ fi
+ if use freedoom; then
+ doom_make_wrapper jdoom-freedoom doom1-share orb-doom "DoomsDay Engine: FreeDoom" \
+ "-iwad \"${GAMES_DATADIR}\"/doom-data/freedoom/doom1.wad"
+ fi
+ fi
+ if use hexen; then
+ doicon ../snowberry/graphics/orb-hexen.png
+ doom_make_wrapper jhexen hexen orb-hexen "DoomsDay Engine: Hexen"
+
+ elog "Created jhexen launcher. To play Hexen place your hexen.wad to"
+ elog "\"${GAMES_DATADIR}\"/${PN}/data/jhexen"
+ elog
+ fi
+ if use heretic; then
+ doicon ../snowberry/graphics/orb-heretic.png
+ doom_make_wrapper jheretic heretic orb-heretic "DoomsDay Engine: Heretic"
+
+ elog "Created jheretic launcher. To play Heretic place your heretic.wad to"
+ elog "\"${GAMES_DATADIR}\"/${PN}/data/jheretic"
+ elog
+ fi
+
+ prepgamesdirs
+}