summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-19 01:36:47 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-19 01:36:47 +0000
commit783f0a3220d37c7a03f511c06cad12e018cb32dc (patch)
treef9a6d64e9d455c063153faec6439a1004e9435d5 /games-fps
parentUpdate kde-base/* dependencies so that KDE 4 doesn't satisfy it. bug 206528. (diff)
downloadgentoo-2-783f0a3220d37c7a03f511c06cad12e018cb32dc.tar.gz
gentoo-2-783f0a3220d37c7a03f511c06cad12e018cb32dc.tar.bz2
gentoo-2-783f0a3220d37c7a03f511c06cad12e018cb32dc.zip
Fix building with sanitized kernel headers #193107.
(Portage version: 2.2_pre2)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake2-icculus/ChangeLog7
-rw-r--r--games-fps/quake2-icculus/files/quake2-icculus-0.16.1-no-asm-io.patch25
-rw-r--r--games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild3
3 files changed, 33 insertions, 2 deletions
diff --git a/games-fps/quake2-icculus/ChangeLog b/games-fps/quake2-icculus/ChangeLog
index 5a4d83d82083..15287da49481 100644
--- a/games-fps/quake2-icculus/ChangeLog
+++ b/games-fps/quake2-icculus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/quake2-icculus
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.29 2008/02/15 01:06:36 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.30 2008/02/19 01:36:46 vapier Exp $
+
+ 19 Feb 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/quake2-icculus-0.16.1-no-asm-io.patch,
+ quake2-icculus-0.16.1-r1.ebuild:
+ Fix building with sanitized kernel headers #193107.
15 Feb 2008; Chris Gianelloni <wolf31o2@gentoo.org>
quake2-icculus-0.16.1.ebuild, quake2-icculus-0.16.1-r1.ebuild:
diff --git a/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-no-asm-io.patch b/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-no-asm-io.patch
new file mode 100644
index 000000000000..d94925b83e4b
--- /dev/null
+++ b/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-no-asm-io.patch
@@ -0,0 +1,25 @@
+http://bugs.gentoo.org/193107
+
+asm/io.h does not exist with sanitized kernel headers, nor do these source
+files actually need the header, so punt it
+
+--- src/linux/rw_in_aa.c
++++ src/linux/rw_in_aa.c
+@@ -46,7 +46,6 @@
+ #include <sys/mman.h>
+
+ #if defined (__linux__)
+-#include <asm/io.h>
+ #include <sys/vt.h>
+ #endif
+
+--- src/linux/rw_aa.c
++++ src/linux/rw_aa.c
+@@ -63,7 +63,6 @@
+ #include <dlfcn.h>
+ #if defined (__linux__)
+ #include <sys/vt.h>
+-#include <asm/io.h>
+ #endif
+ #include <aalib.h>
+
diff --git a/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild b/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
index 42ba607cde79..cfd3a96a02d1 100644
--- a/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
+++ b/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.9 2008/02/15 01:06:36 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.10 2008/02/19 01:36:46 vapier Exp $
inherit eutils toolchain-funcs games
@@ -67,6 +67,7 @@ src_unpack() {
sed -i -e 's:BUILD_SOFTX:BUILD_X11:' Makefile || die
epatch "${FILESDIR}"/${P}-amd64.patch # make sure this is still needed in future versions
epatch "${FILESDIR}"/${P}-gentoo-paths.patch
+ epatch "${FILESDIR}"/${P}-no-asm-io.patch #193107
# Now we deal with the silly rogue / xatrix addons ... this is ugly :/
ln -s $(type -P echo) "${T}"/more