summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-29 16:19:21 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-29 16:19:21 +0000
commit90a2151854941cb2e20d70e625108ea6e81340ef (patch)
treea085f502193a0b5b0e1dbc70abc977c194a46d41 /games-fps
parentuse unpack_zip from unpacker.eclass instead of unzip (diff)
downloadgentoo-2-90a2151854941cb2e20d70e625108ea6e81340ef.tar.gz
gentoo-2-90a2151854941cb2e20d70e625108ea6e81340ef.tar.bz2
gentoo-2-90a2151854941cb2e20d70e625108ea6e81340ef.zip
use unpack_zip from unpacker.eclass instead of unzip
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/ut2004-muralis/ChangeLog8
-rw-r--r--games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild8
2 files changed, 9 insertions, 7 deletions
diff --git a/games-fps/ut2004-muralis/ChangeLog b/games-fps/ut2004-muralis/ChangeLog
index ba6952f8ae2f..2248d7e389e5 100644
--- a/games-fps/ut2004-muralis/ChangeLog
+++ b/games-fps/ut2004-muralis/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/ut2004-muralis
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-muralis/ChangeLog,v 1.4 2009/10/08 20:03:40 nyhm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-muralis/ChangeLog,v 1.5 2013/03/29 16:19:21 hasufell Exp $
+
+ 29 Mar 2013; Julian Ospald <hasufell@gentoo.org> ut2004-muralis-1.15.ebuild:
+ use unpack_zip from unpacker.eclass instead of unzip
08 Oct 2009; Tristan Heaven <nyhm@gentoo.org> ut2004-muralis-1.15.ebuild:
EAPI=2; RESTRICT=fetch
@@ -18,4 +21,3 @@
+ut2004-muralis-1.15.ebuild:
Initial import. Original ebuild by Paul Bredbury <brebs@sent.com> and ported
to the games-mods eclass by myself. Closing bug #118612.
-
diff --git a/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild b/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild
index 2f6c991cc271..8fc5e30c73c5 100644
--- a/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild
+++ b/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild,v 1.4 2009/10/08 20:03:40 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild,v 1.5 2013/03/29 16:19:21 hasufell Exp $
EAPI=2
@@ -8,7 +8,7 @@ MOD_DESC="third-person hand-to-hand single/multiplayer mod"
MOD_NAME="Muralis"
MOD_DIR="muralis"
-inherit games games-mods
+inherit unpacker games games-mods
HOMEPAGE="http://www.ascensiongames.com/"
SRC_URI="muralis-v${PV}-zip.zip"
@@ -25,7 +25,7 @@ pkg_nofetch() {
}
src_unpack() {
- unzip "${DISTDIR}"/${A} # unpack fails
+ unpack_zip ${A}
}
src_prepare() {