summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-05-26 01:00:38 +0000
committerMike Frysinger <vapier@gentoo.org>2006-05-26 01:00:38 +0000
commitdcce677a44ff24643e3f07582f2f1b44a8ff0692 (patch)
tree20bb0b5d63cb2b4948187ce7ad6ca356bf29b0a0 /games-fps
parentStable on x86 wrt bug #132213 (diff)
downloadgentoo-2-dcce677a44ff24643e3f07582f2f1b44a8ff0692.tar.gz
gentoo-2-dcce677a44ff24643e3f07582f2f1b44a8ff0692.tar.bz2
gentoo-2-dcce677a44ff24643e3f07582f2f1b44a8ff0692.zip
Version bump.
(Portage version: 2.1_rc2-r1)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake3/ChangeLog8
-rw-r--r--games-fps/quake3/files/digest-quake3-1.34_alpha7893
-rw-r--r--games-fps/quake3/quake3-1.34_alpha789.ebuild116
3 files changed, 126 insertions, 1 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index ea15508d0f3f..eba013757cbb 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quake3
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.40 2006/05/24 23:26:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.41 2006/05/26 01:00:38 vapier Exp $
+
+*quake3-1.34_alpha789 (26 May 2006)
+
+ 26 May 2006; Mike Frysinger <vapier@gentoo.org>
+ +quake3-1.34_alpha789.ebuild:
+ Version bump.
24 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+files/quake3-1.34_alpha778-gfbsd.patch, quake3-1.34_alpha778.ebuild:
diff --git a/games-fps/quake3/files/digest-quake3-1.34_alpha789 b/games-fps/quake3/files/digest-quake3-1.34_alpha789
new file mode 100644
index 000000000000..304671140ccf
--- /dev/null
+++ b/games-fps/quake3/files/digest-quake3-1.34_alpha789
@@ -0,0 +1,3 @@
+MD5 2da557a95dc58661e528c5686c932eb2 quake3-1.34_SVN789M.tar.bz2 2450958
+RMD160 208c2ddfa36681336f97847ff358242f36f4d937 quake3-1.34_SVN789M.tar.bz2 2450958
+SHA256 0b8768b97962f69b9f7455e736867a447d8677c93c43b34f67344446b797b0ee quake3-1.34_SVN789M.tar.bz2 2450958
diff --git a/games-fps/quake3/quake3-1.34_alpha789.ebuild b/games-fps/quake3/quake3-1.34_alpha789.ebuild
new file mode 100644
index 000000000000..7e54bbac0c8c
--- /dev/null
+++ b/games-fps/quake3/quake3-1.34_alpha789.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_alpha789.ebuild,v 1.1 2006/05/26 01:00:38 vapier Exp $
+
+# quake3-9999 -> latest svn
+# quake3-9999.REV -> use svn REV
+# quake3-VER_alphaREV -> svn snapshot REV for version VER
+# quake3-VER -> normal quake release
+
+if [[ ${PV} == 9999* ]] ; then
+ [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999./}"
+ ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
+ inherit subversion toolchain-funcs eutils games
+
+ SRC_URI=""
+ S=${WORKDIR}/trunk
+elif [[ ${PV} == *_alpha* ]] ; then
+ inherit toolchain-funcs eutils games
+
+ MY_PV=${PV/_alpha*/}
+ SNAP=${PV/*_alpha/}
+ MY_P=${PN}-${MY_PV}_SVN${SNAP}M
+ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit toolchain-funcs eutils games
+
+ SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
+fi
+
+DESCRIPTION="Quake III Arena - 3rd installment of the classic id 3D first-person shooter"
+HOMEPAGE="http://icculus.org/quake3/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="dedicated opengl teamarena"
+
+RDEPEND="opengl? (
+ virtual/opengl
+ media-libs/openal
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 )
+ media-libs/libsdl )
+ !dedicated? (
+ virtual/opengl
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 )
+ media-libs/libsdl )
+ games-fps/quake3-data
+ teamarena? ( games-fps/quake3-teamarena )"
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ cd "${S}"
+ fi
+}
+
+src_compile() {
+ buildit() { use $1 && echo 1 || echo 0 ; }
+ emake \
+ BUILD_SERVER=$(buildit dedicated) \
+ BUILD_CLIENT=$(buildit opengl) \
+ TEMPDIR="${T}" \
+ CC="$(tc-getCC)" \
+ ARCH=$(tc-arch-kernel) \
+ OPTIMIZE="${CFLAGS}" \
+ DEFAULT_BASEDIR="${GAMES_DATADIR}/quake3" \
+ DEFAULT_LIBDIR="${GAMES_LIBDIR}/quake3" \
+ || die
+}
+
+src_install() {
+ dodoc id-readme.txt TODO README BUGS ChangeLog
+ cd code/unix
+ dodoc README.*
+
+ if use opengl ; then
+ doicon quake3.png
+ make_desktop_entry quake3 "Quake III Arena"
+ fi
+
+ cd ../../build/release*
+ local old_x x
+ for old_x in ioq* ; do
+ x=${old_x%.*}
+ newgamesbin ${old_x} ${x} || die "newgamesbin ${x}"
+ dosym ${x} "${GAMES_BINDIR}"/${x/io}
+ done
+ exeinto "${GAMES_LIBDIR}"/${PN}/baseq3
+ doexe baseq3/*.so || die "baseq3 .so"
+ exeinto "${GAMES_LIBDIR}"/${PN}/missionpack
+ doexe missionpack/*.so || die "missionpack .so"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "The source version of Quake 3 will not work with Punk Buster."
+ ewarn "If you need pb support, then use the quake3-bin package."
+ echo
+}