summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-07-16 06:41:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-07-16 06:41:08 +0000
commita4429af29baf7b919668081d096b510d1a35ebd2 (patch)
treea9cc8e6d304e9c7cd91c4241ea2a2797583996cb /games-kids
parentVersion bump. (diff)
downloadgentoo-2-a4429af29baf7b919668081d096b510d1a35ebd2.tar.gz
gentoo-2-a4429af29baf7b919668081d096b510d1a35ebd2.tar.bz2
gentoo-2-a4429af29baf7b919668081d096b510d1a35ebd2.zip
Drop the python use flag because it results in confusing lack of functionality (bug #350795)
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gcompris/ChangeLog9
-rw-r--r--games-kids/gcompris/gcompris-12.01-r1.ebuild89
2 files changed, 97 insertions, 1 deletions
diff --git a/games-kids/gcompris/ChangeLog b/games-kids/gcompris/ChangeLog
index 8e3c7c53ea6d..f13dcbf33e08 100644
--- a/games-kids/gcompris/ChangeLog
+++ b/games-kids/gcompris/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-kids/gcompris
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.76 2012/05/26 03:02:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.77 2012/07/16 06:41:08 mr_bones_ Exp $
+
+*gcompris-12.01-r1 (16 Jul 2012)
+
+ 16 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +gcompris-12.01-r1.ebuild:
+ Drop the python use flag because it results in confusing lack of
+ functionality (bug #350795)
26 May 2012; Michael Sterrett <mr_bones_@gentoo.org>
-files/gcompris-9.6.1-build.patch, -gcompris-9.6.1.ebuild:
diff --git a/games-kids/gcompris/gcompris-12.01-r1.ebuild b/games-kids/gcompris/gcompris-12.01-r1.ebuild
new file mode 100644
index 000000000000..1a3e20949d1f
--- /dev/null
+++ b/games-kids/gcompris/gcompris-12.01-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/gcompris-12.01-r1.ebuild,v 1.1 2012/07/16 06:41:08 mr_bones_ Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="sqlite threads"
+
+inherit autotools eutils python games
+
+DESCRIPTION="full featured educational application for children from 2 to 10"
+HOMEPAGE="http://gcompris.net/"
+SRC_URI="mirror://sourceforge/gcompris/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnet"
+
+RDEPEND="x11-libs/gtk+:2
+ gnome-base/librsvg[gtk]
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-good
+ media-plugins/gst-plugins-ogg
+ media-plugins/gst-plugins-alsa
+ media-plugins/gst-plugins-vorbis
+ media-libs/sdl-mixer
+ media-libs/libsdl
+ dev-libs/libxml2
+ dev-libs/popt
+ virtual/libintl
+ games-board/gnuchess
+ dev-db/sqlite:3
+ gnet? ( net-libs/gnet:2 )
+ dev-python/pygtk"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ dev-perl/XML-Parser
+ sys-devel/gettext
+ sys-apps/texinfo
+ app-text/texi2html
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ media-gfx/tuxpaint
+ sci-electronics/gnucap"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ # Drop DEPRECATED flags, bug #387817
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' \
+ src/gcompris/Makefile.am src/gcompris/Makefile.in \
+ src/goocanvas/src/Makefile.am src/goocanvas/src/Makefile.in \
+ || die
+
+ epatch "${FILESDIR}"/${P}-build.patch
+ cp /usr/share/gettext/config.rpath .
+ eautoreconf
+}
+
+src_configure() {
+ GNUCHESS="${GAMES_BINDIR}"/gnuchess \
+ egamesconf \
+ --disable-dependency-tracking \
+ --datarootdir="${GAMES_DATADIR}" \
+ --datadir="${GAMES_DATADIR}" \
+ --localedir=/usr/share/locale \
+ --infodir=/usr/share/info \
+ --with-python="$(PYTHON -a)" \
+ $(use_enable gnet) \
+ --enable-sqlite \
+ --enable-py-build-only
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ prepgamesdirs
+}